Results 1 to 6 of 6

Thread: Problem: patch:fileshareset-124.noarch conflicts with kdebas

  1. #1

    Default Problem: patch:fileshareset-124.noarch conflicts with kdebas

    For a few days now I've been getting this when I run:

    Code:
    # zypper -v up
    ...
    Problem: patch:fileshareset-124.noarch conflicts with kdebase3-session.x86_64 < 3.5.9-65.2 provided by kdebase4-session-4.1.3-23.2.x86_64                                                                                                   
     Solution 1: Following actions will be done:                                                                          
      downgrade of kdebase4-session-4.1.3-23.2.x86_64 to kdebase4-session-4.0.4-6.1.x86_64                                
      downgrade of PolicyKit-kde-0.2-61.1.x86_64 to PolicyKit-kde-0.0.svn810196-5.1.x86_64                                
      deinstallation of plasmoid-forecast-0.2-2.5.x86_64                                                                  
      downgrade of kdebase4-runtime-4.1.3-63.1.x86_64 to kdebase4-runtime-4.0.4-20.2.i586                                 
      architecture change of kdebase4-runtime-4.1.3-63.1.x86_64 to kdebase4-runtime-4.0.4-20.2.i586                       
      downgrade of kde4-kdm-4.1.3-148.3.x86_64 to kde4-kdm-4.0.4-24.6.x86_64                                              
      downgrade of kdepim4-4.1.3-67.4.x86_64 to kdepim4-4.0.80-9.3.x86_64                                                 
      downgrade of kdegames4-4.1.3-26.4.x86_64 to kdegames4-4.0.4-16.1.x86_64                                             
      downgrade of kdemultimedia4-4.1.3-35.4.x86_64 to kdemultimedia4-4.0.4-15.1.x86_64                                   
      downgrade of kdebase4-workspace-4.1.3-148.3.x86_64 to kdebase4-workspace-4.0.4-24.6.x86_64                          
      downgrade of ktorrent-3.1.5-14.12.x86_64 to ktorrent-3.1.5-0.pm.1.x86_64                                            
      install ktorrent-3.1.5-0.pm.1.x86_64 (with vendor change)                                                           
        openSUSE Build Service                                                                                            
      -->                                                                                                                 
        packman.links2linux.de                                                                                            
      downgrade of kdenetwork4-filesharing-4.1.3-43.4.x86_64 to kdenetwork4-filesharing-4.0.4-19.1.x86_64                 
      downgrade of kdepim4-wizards-4.1.3-67.4.x86_64 to kdepim4-wizards-4.0.80-9.3.x86_64                                 
      deinstallation of powerdevil-1.4.1-14.4.x86_64                                                                      
      deinstallation of plasmoid-birthdayreminder-0.8.0-4.26.x86_64                                                       
      downgrade of kdebase4-4.1.3-55.5.x86_64 to kdebase4-4.0.4-18.2.x86_64                                               
      downgrade of kdeartwork4-screensaver-4.1.3-17.27.x86_64 to kdeartwork4-screensaver-4.0.4-14.1.x86_64                
      deinstallation of kde4-plasmoid-weather-0.4-1.114.x86_64                                                            
      deinstallation of kde4-plasmoid-system_status-0.5-2.39.x86_64                                                       
      ...                                    
      downgrade of kde4-krdc-4.1.3-43.4.x86_64 to kde4-krdc-4.0.4-19.1.x86_64                                             
      downgrade of kde4-kpat-4.1.3-26.4.x86_64 to kde4-kpat-4.0.4-16.1.x86_64                                             
      downgrade of kde4-korganizer-4.1.3-67.4.x86_64 to kde4-korganizer-4.0.80-9.3.x86_64                                 
      downgrade of kde4-kontact-4.1.3-67.4.x86_64 to kde4-kontact-4.0.80-9.3.x86_64                                       
      downgrade of kde4-konsole-4.1.3-55.5.x86_64 to kde4-konsole-4.0.4-18.2.x86_64                                       
      downgrade of kde4-konqueror-plugins-4.1.3-27.2.x86_64 to kde4-konqueror-plugins-4.0.svn767780-72.1.x86_64           
      downgrade of kde4-konqueror-4.1.3-55.5.x86_64 to kde4-konqueror-4.0.4-18.2.x86_64                                   
      downgrade of kde4-knotes-4.1.3-67.4.x86_64 to kde4-knotes-4.0.80-9.3.x86_64                                         
      downgrade of kde4-knewsticker-4.1.3-43.4.x86_64 to kde4-knewsticker-4.0.4-19.1.x86_64                               
      downgrade of kde4-kmix-4.1.3-35.4.x86_64 to kde4-kmix-4.0.4-15.1.x86_64                                             
      downgrade of kde4-kmines-4.1.3-26.4.x86_64 to kde4-kmines-4.0.4-16.1.x86_64                                         
      downgrade of kde4-kmail-4.1.3-67.4.x86_64 to kde4-kmail-4.0.80-9.3.x86_64                                           
      downgrade of kde4-kmahjongg-4.1.3-26.4.x86_64 to kde4-kmahjongg-4.0.4-16.1.x86_64                                   
      downgrade of kde4-kio_sysinfo-11.0-81.44.x86_64 to kde4-kio_sysinfo-11.0-74.2.x86_64                                
      downgrade of kde4-kio_kamera-4.1.3-54.4.x86_64 to kde4-kio_kamera-4.0.4-14.1.x86_64                                 
      downgrade of kde4-kio_audiocd-4.1.3-35.4.x86_64 to kde4-kio_audiocd-4.0.4-15.1.x86_64                               
      deinstallation of kde4-kgreeter-plugins-4.1.3-148.3.x86_64                                                          
      downgrade of kde4-kgpg-4.1.3-32.3.x86_64 to kde4-kgpg-4.0.4-19.1.x86_64                                             
      downgrade of kde4-kget-4.1.3-43.4.x86_64 to kde4-kget-4.0.4-19.1.x86_64                                             
      downgrade of kde4-kgamma-4.1.3-54.4.x86_64 to kde4-kgamma-4.0.4-14.1.x86_64                                         
      downgrade of kde4-kfind-4.1.3-55.5.x86_64 to kde4-kfind-4.0.4-18.2.x86_64                                           
      downgrade of kde4-keditbookmarks-4.1.3-55.5.x86_64 to kde4-keditbookmarks-4.0.4-18.2.x86_64                         
      downgrade of kde4-kdnssd-4.1.3-43.4.x86_64 to kde4-kdnssd-4.0.4-19.1.x86_64                                         
      downgrade of kde4-kcolorchooser-4.1.3-54.4.x86_64 to kde4-kcolorchooser-4.0.4-14.1.x86_64                           
      downgrade of kde4-kcalc-4.1.3-32.3.x86_64 to kde4-kcalc-4.0.4-19.1.x86_64                                           
      downgrade of kde4-kaddressbook-4.1.3-67.4.x86_64 to kde4-kaddressbook-4.0.80-9.3.x86_64                             
      downgrade of kde4-gwenview-4.1.3-54.4.x86_64 to kde4-gwenview-4.0.4-14.1.x86_64                                     
      downgrade of kde4-dolphin-4.1.3-55.5.x86_64 to kde4-dolphin-4.0.4-18.2.x86_64                                       
      downgrade of kde4-ark-4.1.3-32.3.x86_64 to kde4-ark-4.0.4-19.1.x86_64                                               
      downgrade of kde4-akregator-4.1.3-67.4.x86_64 to kde4-akregator-4.0.80-9.3.x86_64                                   
      deinstallation of kde4-akonadi-4.1.3-67.4.x86_64                                                                    
      deinstallation of powerdevil-lang-1.4.1-14.4.x86_64                                                                 
      downgrade of kdebase4-nsplugin-4.1.3-55.5.x86_64 to kdebase4-nsplugin-4.0.4-18.2.x86_64                             
      deinstallation of kde4-konqueror-plugins-lang-4.1.3-27.2.x86_64                                                     
      downgrade of libakonadi4-4.1.3-2.12.x86_64 to libakonadi4-4.0.72-14.1.x86_64                                        
      downgrade of libkdegames4-4.1.3-26.4.x86_64 to libkdegames4-4.0.4-16.1.x86_64                                       
     Solution 2: do not install patch:fileshareset-124.noarch                                                             
    
    Choose from above solutions by number or cancel [1/2/C]:
    Is there any way to get this fixed without ruing my KDE 4 Desktop?

    Code:
    # zypper -v lr                                                                       
    Verbosity: 1                                                                                      
    #  | Alias                                                    | Name                                               | Enabled | Refresh
    ---+----------------------------------------------------------+----------------------------------------------------+---------+--------
    1  | http://download.nvidia.com/opensuse/11.0                 | NVIDIA Repository                                  | Yes     | Yes
    2  | repo-oss                                                 | openSUSE-11.0-Oss                                  | Yes     | No
    3  | KDE4:/Factory:/Desktop/openSUSE_11.0                     | KDE4:/Factory:/Desktop/openSUSE_11.0               | Yes     | Yes
    4  | repo-non-oss                                             | openSUSE-11.0-Non-Oss                              | Yes     | No
    5  | KDE4:/Factory:/Extra-Apps/openSUSE_11.0                  | KDE4:/Factory:/Extra-Apps/openSUSE_11.0            | Yes     | Yes
    6  | http://ftp.skynet.be/pub/packman/suse/11.0/              | Packman Repository                                 | Yes     | Yes
    7  | http://download.videolan.org/pub/videolan/vlc/SuSE/11.0/ | VideoLan Repository                                | No      | No
    8  | KDE4:/Community/openSUSE_11.0_KDE4_Factory_Desktop       | KDE4:/Community/openSUSE_11.0_KDE4_Factory_Desktop | Yes     | Yes
    9  | repo-debug                                               | openSUSE-11.0-Debug                                | No      | No
    10 | KDE:/Qt/openSUSE_11.0                                    | KDE:/Qt/openSUSE_11.0                              | Yes     | Yes
    11 | openSUSE-11.0-Updates                                    | openSUSE-11.0-Updates                              | Yes     | Yes
    12 | openSUSE-DVD 11.0                                        | openSUSE-DVD 11.0                                  | No      | No
    Thanks,
    Ben Popatopalous
    openSuse 11.0 & 11.1 x86_64

  2. #2
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,164

    Default Re: Problem: patch:fileshareset-124.noarch conflicts with kd

    Yes there is just go Yast>Software>Online Update
    When Yast throws that error message at you look for then check the Do Not Install option then click Ok. That's what others are doing including myself. One other thing if you are using the Suseupdater turn it off.
    I'm just a curious cat
    My 64 bit: RADEON RX 570 |CPU AMD - Ryzen 5 1600
    MOTHERBOARD B450M D53H GGABYTE
    Opensuse Tumbleweed Plasma 5

  3. #3

    Default Re: Problem: patch:fileshareset-124.noarch conflicts with kd

    Thanks for the tip. I update from the konsole using 'zypper up' and 'zypper up -t package'. And that does not have any effect in konsole. Neither does 'zypper al' [al means add lock]. Hope this gets fixed soon. It's a bit irritating.
    Thanks,
    Ben Popatopalous
    openSuse 11.0 & 11.1 x86_64

  4. #4

    Default Re: Problem: patch:fileshareset-124.noarch conflicts with kd

    No kidding. It's annoying when this happens. It used to happen with OpenSuSE 10.2-10.3 all the time there, too.

    Someone would approve a package that has dependencies outside the standard repos and then you're stuck trying to figure out how to get the thing to go away so you can install other critical patches.


    This is also causing a nasty error in Suseupdater saying it can't talk to the daemon. I normally update packages through the System Tray but now I'm going to have to go back to zypper up.

  5. #5

    Default Re: Problem: patch:fileshareset-124.noarch conflicts with kd

    If you also look at this list... that package is dependending on KDE 4.0 when the 4.1 preview was just released on KDE:Factory.

    Probably bad timing. That package should be re-released as a new version depending on the 4.1 KDE libs.


    Quote Originally Posted by christoofar View Post
    No kidding. It's annoying when this happens. It used to happen with OpenSuSE 10.2-10.3 all the time there, too.

    Someone would approve a package that has dependencies outside the standard repos and then you're stuck trying to figure out how to get the thing to go away so you can install other critical patches.


    This is also causing a nasty error in Suseupdater saying it can't talk to the daemon. I normally update packages through the System Tray but now I'm going to have to go back to zypper up.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Problem: patch:fileshareset-124.noarch conflicts with kd

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •