Results 1 to 5 of 5

Thread: No sound for users but only for root

  1. #1

    Default No sound for users but only for root

    Thanks to a valuable advise from Mingus725 the wise penguin, I was able to find quite few options to put GRUB exactly where I wanted and installed open Suse 11 on my recent Dell Dimension over the weekend.

    Only one thing I could never understand was that there was no sound support for the default user whilst I had a complete sound support once I log out from KDE and log on as root. I spent whole day to find a way to make root as default KDM prompt but it was not easy as XDM and I still could not find it. I have set permission 777 on all the sound device as well as related lib and bin files.

    I set AppArmour off but I still could not get sound support and it kept saying that permission denied to open sound card. It is becoming to be a nightmare. I am from startx and openwin generation with mwm and CDE. I have not worked with Linux for a long time. Originally Unix did not care about limiting sound to particular users since sound daemon loaded before syslogger. Open sound system was much easier to deal with.

    I can be just happy if I could set KDM to prompt for username instead of automatically logon as just a member of user group or to find a way to provide sound to users. Yast user profile editor did not show any users whilst /etc/profile did exist. But root does not use such thing as profile therefore there was nothing I can even paste on profile.

    I have no need to use any of such privilege limiting feature. I would appreciate any idea or suggestuin.

    pinecloud.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: No sound for users but only for root

    Did you try adding your regular users to group "audio"? Then restart your PC.

    Guidance is here:
    SDB:AudioTroubleshooting - openSUSE - How to fix a permissions problem

  3. #3
    John Jones NNTP User

    Default Re: No sound for users but only for root

    > I have no need to use any of such privilege limiting feature. I would
    > appreciate any idea or suggestuin.


    Because of the way Linux works you DO need the (as you say) "privilege limiting
    feature" of both a normal user *and* a root, or superuser.

    You should never ever log into KDE as root. Not even to try to fix a problem
    like no sound for any or all users (even if it is now and always will be a
    single user system).

    You _may_ need root powers to fix a sound problem, and if you do then you are
    best served to follow the Linux way of using those powers which is to log into
    the GUI/KDE as a normal user and THEN become root, see:
    http://en.opensuse.org/SDB:Login_as_root

  4. #4
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: No sound for users but only for root

    Quote Originally Posted by pinecloud View Post
    . . . I am from “startx” and “openwin” generation with mwm and CDE. I have not worked with Linux for a long time . . .
    Linux has come a lonnnnnnnng way since then. Having worked with it that long ago can be both a help and a hindrance. Besides just the general improvements such as in the kernel, there are significant differences between distributions. If you worked with Slackware, Gentoo, Debian (or one of their derivatives) you will find SuSE (and Fedora, a close cousin) to be very different. Each is a new learning experience. The irony is that sometimes old users take longer to figure something out than new users because they are not hindered by old data.

    With openSUSE, you want to become familiar with the YaST modules. YaST is probably SuSE's major distinguishing feature, and it is great; nearly all system management is covered, eliminating the need most of the time to get into control files. Especially take a look at the sysconfig Editor - SuSE uses a group of its own control files (in addition to application and kernel files) to easily modify the behavior of the system. For example, under Display Manager (the default with KDE is kdm) there are settings for auto-login and allowed users, and you can control whether the openSUSE theme is used by kdm or KDE's vanilla dialog is used. In YaST there is also a sound module to configure the sound card, and there is also User/Group management. There is also a module for controlling the init processes and services.

  5. #5

    Default Now, It starts with more familiar "startx" at # prompt

    Thanks to all different advises after all, I was able to set system start as run level 3, edited each level rc there up. Now, Suse runs pretty much runs like Solaris and standard Unix. X runs from startx. Structural compliance of SuseX with X.orgs X was surprisingly perfect and clean whilst many distributions do fail in cleaning up binds in the process of disabling xdm. Fedora is also somewhat clean in this aspect but their graphic work (look and feel) are not as perfect as Suse. Once I ported Freedom Suite of 1997 era and applied system wide in recurring manner, unwanted privilege limiting is now completely gone. Yes, I learnt hard way how to modify and recompile pam md5 and kerberos to get what I wanted when necessary at given # prompt.

    Pinecloud

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •