Results 1 to 4 of 4

Thread: problems with umlauts in emacs and latex

  1. #1

    Default problems with umlauts in emacs and latex

    Hi,

    I used to type umlauts and other keys (,,.,,, etc) directly from the keybord into emacs, and latex never complained about these letter, as long as I used \usepackage{isolatin1}.

    Today, I discovered that this does not work anymore, neither on my laptop, nor on my workstation.

    I absolutely have no clue where to look for the parameter that might have changed. Perhaps someone has an idea?

    thanks a lot in advance!!!

    Volker

  2. #2
    Join Date
    Jun 2008
    Location
    Madrid
    Posts
    81

    Default Re: problems with umlauts in emacs and latex

    Hi Volker.

    Check this out:
    Linux.com :: Everything Linux and Open Source

    I just a similar problem not too long ago.
    It's suggested that one of these might do the trick:
    Code:
    export LC_CTYPE=iso_8859_1  
    export LC_CTYPE=iso-8859-1
    (if that resolves it, I think you put this in .bashrc, maybe someone else can confirm, or they'll spell it out in one of those links)

    Otherwise, I had luck finding if there were any problems with my locale settings--you'll receive errors if there are faulty settings-- with the following command:

    Code:
    perl -e ""
    Here's another site that looks useful (and mentions emacs specifically)
    The Linux keyboard and console HOWTO: How to make other programs work with non-ASCII chars

    I just googled "emacs accents" and "emacs non-ASCII characters"
    SuSE-12.3, Lenovo G780, 3.7.10-1.16-desktop

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,433

    Default Re: problems with umlauts in emacs and latex

    According to CTAN isolatin1 has been obsolete since 2006; so you need to change your package.Have you tried latin1?
    Last edited by john_hudson; 24-Nov-2008 at 11:50. Reason: Correction

  4. #4
    Join Date
    Jun 2008
    Location
    Madrid
    Posts
    81

    Default Re: problems with umlauts in emacs and latex

    I made a mistake, Volker. I misread your post thinking you couldn't produce the accents any longer. Not sure if any of that will prove helpful now.
    SuSE-12.3, Lenovo G780, 3.7.10-1.16-desktop

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •