Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Eclipse (Ganymede) does not start on Open SUSE 11.0

  1. #1
    atulkhot NNTP User

    Default Eclipse (Ganymede) does not start on Open SUSE 11.0

    Dear all
    Greetings from atul... A few days back, I just installed Open SUSE and I am loving it ;-)
    Eclipse is what I am having problem with...
    I start Eclipse, the splash screen appears and then it just hangs... I tried with Eclipse java and Eclipse Cpp.. I observed the same behaviour.

    I have sun jdk 1.6 on the box (installed from the openSuse disk)...

    Any pointers -
    TIA atul

  2. #2
    atulkhot NNTP User

    Default Re: Eclipse (Ganymede) does not start on Open SUSE 11.0

    Dear all
    I did some more investigation... the .log in my workspace has this error..

    java.lang.RuntimeException: Widget disposed too early!
    at org.eclipse.ui.internal.WorkbenchPartReference$1.widgetDisposed(WorkbenchPartReference.java:171)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:117)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    ...

    any idea how to work around this?

    -- thx atul

  3. #3
    Join Date
    Jun 2008
    Location
    present moment
    Posts
    80

    Default Re: Eclipse (Ganymede) does not start on Open SUSE 11.0

    So if you have your workspace already this means you have opened Eclipse before this error occured?

    Have you set your JAVA_HOME correctly?

    What project have you set up that is the cause of this error, or have you set one up yet?
    "Instead of finding fault with others, try to look to your own weaknesses."

  4. #4
    Chetanji NNTP User

    Default Re: Eclipse (Ganymede) does not start on Open SUSE 11.0


    So if you have your workspace already this means you have opened Eclipse
    before this error occured?

    Have you set your JAVA_HOME correctly?

    What project have you set up that is the cause of this error, or have
    you set one up yet?


    --
    "Instead of finding fault with others, try to look to your own
    weaknesses."
    ------------------------------------------------------------------------
    Chetanji's Profile: http://forums.opensuse.org/member.php?userid=887
    View this thread: http://forums.opensuse.org/showthread.php?t=400259


  5. #5
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Eclipse (Ganymede) does not start on Open SUSE 11.0

    Quote Originally Posted by atulkhot View Post
    Dear all
    I did some more investigation... the .log in my workspace has this error..

    java.lang.RuntimeException: Widget disposed too early!
    at org.eclipse.ui.internal.WorkbenchPartReference$1.widgetDisposed(WorkbenchPartReference.java:171)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:117)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    ...

    any idea how to work around this?

    -- thx atul
    Hi!
    Try to start your Eclipse with:
    Code:
    eclipse -clean
    .
    Good luck
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  6. #6
    ram88 NNTP User

    Default Re: Eclipse (Ganymede) does not start on Open SUSE 11.0


    atulkhot;1899013 Wrote:
    > Dear all
    > I did some more investigation... the .log in my workspace has this
    > error..
    >
    > java.lang.RuntimeException: Widget disposed too early!
    > at
    > org.eclipse.ui.internal.WorkbenchPartReference$1.widgetDisposed(WorkbenchPartReference.java:171)
    > at
    > org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:117)
    > at
    > org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    > ...
    >
    > any idea how to work around this?
    >
    > -- thx atul


    Hi!
    Try to start your Eclipse with:

    Code:
    --------------------

    #eclipse -clean

    --------------------

  7. #7
    irsha NNTP User

    Default Re: Eclipse (Ganymede) does not start on Open SUSE 11.0

    Hi
    install gtk from yast it will work

    Thanks
    Irshad A

  8. #8
    irsha NNTP User

    Default Re: Eclipse (Ganymede) does not start on Open SUSE 11.0


    Hi
    install gtk from yast it will work

    Thanks
    Irshad A


    --
    irsha
    ------------------------------------------------------------------------
    irsha's Profile: http://forums.opensuse.org/member.php?userid=20028
    View this thread: http://forums.opensuse.org/showthread.php?t=400259


  9. #9
    smuwanga NNTP User

    Default Re: Eclipse (Ganymede) does not start on Open SUSE 11.0

    My Eclipse(Ganymede) still freezes on OpenSuse 11.0. I have jdk 6 too.I defined the Java_Home like export JAVA_HOME="/home/smuwanga/software/jdk1.6.0_11"

    I also tried the another option of installing the gtk(which is eclipse 3.3) from the openSUSE DVD through Yast. It installed successfully. Where can I find this installation so that I can start eclipse?

    Thanking,
    Simon P.

  10. #10
    smuwanga NNTP User

    Default Re: Eclipse (Ganymede) does not start on Open SUSE 11.0


    My Eclipse(Ganymede) still freezes on OpenSuse 11.0. I have jdk 6 too.I
    defined the Java_Home like export
    JAVA_HOME="/home/smuwanga/software/jdk1.6.0_11"

    I also tried the another option of installing the gtk(which is eclipse
    3.3) from the openSUSE DVD through Yast. It installed successfully.
    Where can I find this installation so that I can start eclipse?

    Thanking,
    Simon P.


    --
    smuwanga
    ------------------------------------------------------------------------
    smuwanga's Profile: http://forums.opensuse.org/member.php?userid=8775
    View this thread: http://forums.opensuse.org/showthread.php?t=400259


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •