Do you have a login for a kde3 desktop?

But anyway you should have a kdebase4, there is something very odd going on

what repos do you have

zypper lr -u