Results 1 to 6 of 6

Thread: My speller doesn't work in Firefox

  1. #1
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default My speller doesn't work in Firefox

    Hi
    I have set Firefox to ckeck my spalling as I tipe. I ajusted Edit -> preferrences --> Advantsed --> Genneril --> Browseing.

    Can anybody advise what I might do to fix it?

    Thanks

    Swender

    (Yikes!)
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: My speller doesn't work in Firefox

    Hmm, seans to werk for me.

    What packages and versions of the following do you have installed?

    MozillaFirefox
    mozilla-xulrunner190

    What are the settings of anything with spell in it in about:config?

  3. #3
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,245

    Default Re: My speller doesn't work in Firefox

    Works fine here i spell checked the quote. Interesting correction for swerdna

    Geoff

    Quote Originally Posted by swearword View Post
    Hi
    I have set Firefox to check my spelling as I type. I adjusted Edit -> preferences --> Advanced --> General --> Browsing.

    Can anybody advise what I might do to fix it?

    Thanks

    Swender

    (Yikes!)
    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: My speller doesn't work in Firefox

    Quote Originally Posted by ken_yap View Post
    Hmm, seans to werk for me.

    What packages and versions of the following do you have installed?

    MozillaFirefox
    mozilla-xulrunner190

    What are the settings of anything with spell in it in about:config?
    john@acer110:~> rpm -qa | egrep "zillaFire|zilla-xulru"
    mozilla-xulrunner190-gnomevfs-1.8.99.5-28.1
    mozilla-xulrunner190-1.8.99.5-28.1
    MozillaFirefox-2.9.95-25.1


    about:config --->
    HTML Code:
    extensions.spellcheck.inline.max-misspellings  default  integer  500
    layout.spellscheck.Default                     default  integer  1
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: My speller doesn't work in Firefox

    Here are my results, on OpenSUSE 11.0, are you running 10.3?

    MozillaFirefox-3.0.3-1.1
    mozilla-xulrunner190-1.9.0.3-1.1
    mozilla-xulrunner190-gnomevfs-1.9.0.3-1.1

    about:config options with spell in it, same as yours but with one extra setting:

    spellchecker.dictionary en-US

    Seems to me that one's important.

  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: My speller doesn't work in Firefox

    Quote Originally Posted by ken_yap View Post
    Here are my results, on OpenSUSE 11.0, are you running 10.3?

    MozillaFirefox-3.0.3-1.1
    mozilla-xulrunner190-1.9.0.3-1.1
    mozilla-xulrunner190-gnomevfs-1.9.0.3-1.1

    about:config options with spell in it, same as yours but with one extra setting:

    spellchecker.dictionary en-US

    Seems to me that one's important.
    I joined the Firefox forum and searched posts on the phrase"spellchecker.dictionary en-US". The solution is to open a text-entry box (e.g. in a forum like this), right-click and a drop-down list opens. Select "check spelling". Now it's fixed.

    So your probing and the tip of the missing "spellchecker.dictionary en-US" lead to the solution -- thanks.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •