Results 1 to 8 of 8

Thread: cd googleearth/sh google not working?

  1. #1

    Default cd googleearth/sh google not working?

    greetings forum
    running 11.0 and trying to install googleearth with no result. see below
    dave@linux-gyb8:~> cd /home/dave/
    dave@linux-gyb8:~> GoogleEarthLinux.bin
    bash: ./GoogleEarthLinux.bin: Permission denied
    dave@linux-gyb8:~> sudo sh GoogleEarthLinux.bin
    root's password:
    Verifying archive integrity... All good.
    Uncompressing Google Earth for GNU/Linux 4.3.7284.3916..............................................................
    You don't seem to be running an X server (no DISPLAY set).
    Google Earth and its installer both require X11.
    Aborting...
    dave@linux-gyb8:~>
    any ideas where the block is?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: cd googleearth/sh google not working?

    what sort of graphics do you have (that's your problem)

    give us the contents of

    /etc/X11/xorg.conf
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jul 2008
    Location
    Mayen (Germany)
    Posts
    27

    Thumbs down Re: cd googleearth/sh google not working?

    Quote Originally Posted by dr1445 View Post
    dave@linux-gyb8:~> GoogleEarthLinux.bin
    bash: ./GoogleEarthLinux.bin: Permission denied
    dave@linux-gyb8:~> sudo sh GoogleEarthLinux.bin
    Normally Google Earth not needs the root Account. Have you after download maked a
    Code:
    chmod +x GoogleEarthLinux.bin
    ?
    That was my last Error ;-)
    Sincereley yours

    Sascha Manns
    Community & Support Agent - open-slx GmbH

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,298
    Blog Entries
    15

    Default Re: cd googleearth/sh google not working?

    Quote Originally Posted by dr1445
    greetings forum
    running 11.0 and trying to install googleearth with no result. see
    below
    dave@linux-gyb8:~> cd /home/dave/
    dave@linux-gyb8:~> GoogleEarthLinux.bin
    bash: ./GoogleEarthLinux.bin: Permission denied
    dave@linux-gyb8:~> sudo sh GoogleEarthLinux.bin
    root's password:
    Verifying archive integrity... All good.
    Uncompressing Google Earth for GNU/Linux
    4.3.7284.3916..............................................................
    You don't seem to be running an X server (no DISPLAY set).
    Google Earth and its installer both require X11.
    Aborting...
    dave@linux-gyb8:~>
    any ideas where the block is?
    Hi
    You install it as your user in your home directory not root.... Try
    again without the sudo.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.18-0.2-default
    up 1 day 3:36, 1 user, load average: 0.09, 0.21, 0.19
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82


  5. #5

    Default Re: cd googleearth/sh google not working?

    as you can see i tried to run nonroot but got denied, thats when i ran as sudo sh. heres the xorg.conf
    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "Module"
    Load "extmod"
    Load "type1"
    Load "glx"
    Load "freetype"
    Load "dbe"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "Pixart Imaging USB OPTICAL MOUSE"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 360 270
    HorizSync 30-70
    Identifier "Monitor[0]"
    ModelName "PAVILION MX70"
    Option "DPMS"
    Option "PreferredMode" "1280x1024"
    VendorName "HP"
    VertRefresh 50-120
    UseModes "Modes[0]"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1600x1200" 202.00 1600 1664 1856 2160 1200 1201 1204 1250 +HSync +VSync
    Modeline "1280x1024" 157.50 1280 1344 1504 1728 1024 1025 1028 1072
    EndSection

    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection

    Section "Device"
    BoardName "GeForce4 MX 4000"
    BusID "1:0:0"
    Driver "nvidia"
    Identifier "Device[0]"
    Screen 0
    VendorName "NVidia"
    EndSection

    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection

    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "Composite" "on"
    EndSection

  6. #6

    Default Re: cd googleearth/sh google not working?

    regarding chmod, do you reckon chmod 755 GoogleEarthLinux.bin should remove the block?

  7. #7
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: cd googleearth/sh google not working?

    In science it's a rule that you don't change more than one variable at a time when conducting an experiment. When you want to find out what's wrong you change one thing at a time.

    1. You try ./GoogleEarth.bin and it doesn't work. Ok.

    2. Next thing you should try is either chmod 755 GoogleEarthLinux.bin followed by ./GoogleEarthLinux.bin again, or sh GoogleEarthLinux.bin (without the sudo).

    3. So why did you throw sudo into the mix at the same time? As pointed out you didn't need to do sudo. The failure to execute was not to do with root or not, it was to do with file permissions.

    So just go and do one of the alternatives in 2.

  8. #8

    Default Re: cd googleearth/sh google not working?

    ok permissions was the problem. i did
    #cd /home/dave/
    #chmod 755 GoogleEarthLinux.bin
    then all went well
    $ cd /home/dave/
    GoogleEarthLinux.bin
    today i have been installing a carb upgrade on my motorcycle, i guess my mind was on the bike mods not the suse mods! i have the same problem with a 11.1 beta install, better fix that one before i forget to do it.
    thanks all

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •