Results 1 to 9 of 9

Thread: Dolphin & Konqueror-doplhin kparts crash

  1. #1
    Join Date
    Jun 2008
    Location
    Austin, TX
    Posts
    52

    Default Dolphin & Konqueror-doplhin kparts crash

    Hi guys, I'm having this problem of Dolphin crashing with a SIGSEGV whenever I launch it. Konqueror(KDE4) launches and works fine with web browsing, but whenever I use it for file management, Konqueror(KDE4) crashes with SIGSEGV(presumably since it uses Dolphin kparts for file management ?).
    launching Dolphin from command prompt gives an error message

    Code:
    sathya@shaman:/>  dolphin
    dolphin: symbol lookup error: dolphin: undefined symbol: _ZN19KonqFileUndoManager6incRefEv
    <unknown program name>(10717)/: Communication problem with  "dolphin" , it probably crashed.
    Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "
    Any idea why this is happening ? This has started once I did an upgrade from KDE4.0.4 to KDE 4.1.3 ?
    Any help would be appreciated.
    Thanks!
    Dell Inspiron 1520 | Intel Core2Duo T5250 | 2GB |nVidia 8600mGT |160GB |openSUSE 11.3

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Dolphin & Konqueror-doplhin kparts crash

    Open Yast - Software Management
    filter by repo and check them all, but particularly the kde4 factory repo's
    can you see any Red or Blue text in the lists?

    If there are, mark them for upgrade/downgrade

    You could just do an update all unconditionally in the kde4 desktop if you have fast internet

    Do you have the QT repo?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Austin, TX
    Posts
    52

    Default Re: Dolphin & Konqueror-doplhin kparts crash

    I do have the QT repo. there are bunch of packages in red and blue. will have to sort out the dependencies all of them :-/ as choosing update 1 package gives conflict reports. Oh well will try them and report back-- this is gonna take some time, I have an extremely slow net connection.
    Thanks anyways
    Dell Inspiron 1520 | Intel Core2Duo T5250 | 2GB |nVidia 8600mGT |160GB |openSUSE 11.3

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Dolphin & Konqueror-doplhin kparts crash

    Just to make it easy. temporarily uncheck the dependency check.

    Click the check box of blue and red packages and they should schedule for update/rollback.

    When done swich the dependency back on and verify. If there are dependency errors - report back.

    Normally, with High speed Internet, I would just say: Update all unconditionally.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    Austin, TX
    Posts
    52

    Default Re: Dolphin & Konqueror-doplhin kparts crash

    Thanks will do so. which repo should I use ? Have these for KDE4

    Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_Factory

    Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.0

    Should I disable any of these?
    Dell Inspiron 1520 | Intel Core2Duo T5250 | 2GB |nVidia 8600mGT |160GB |openSUSE 11.3

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Dolphin & Konqueror-doplhin kparts crash

    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    Austin, TX
    Posts
    52

    Default Re: Dolphin & Konqueror-doplhin kparts crash

    awesome, thanks. have started the update procedure. will report back once its done.
    Thanks again!
    Dell Inspiron 1520 | Intel Core2Duo T5250 | 2GB |nVidia 8600mGT |160GB |openSUSE 11.3

  8. #8
    Join Date
    Jun 2008
    Location
    Austin, TX
    Posts
    52

    Default Re: Dolphin & Konqueror-doplhin kparts crash

    Just wanted to let you guys know, its working alright now.
    Thanks for all the help!
    Dell Inspiron 1520 | Intel Core2Duo T5250 | 2GB |nVidia 8600mGT |160GB |openSUSE 11.3

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Dolphin & Konqueror-doplhin kparts crash

    Great. Happy to know we sorted it for you.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •