Results 1 to 10 of 10

Thread: compis: emerald theme cant be activated, title bar is gone

  1. #1
    tyskjaevel NNTP User

    Default compis: emerald theme cant be activated, title bar is gone

    hi,
    i am pretty new in using linux...
    i've got opensuse 11 with kde 4.1 running on a dell latitude d420 with intel graphic chip onboard. compiz is installed as well as the emerald theme manager, both recently and updated in latest version.
    when i right-click on the fusion-icon in my system tray in the panel and select compiz as window manager the title of the windows is gone and if i then open emerald to activate the theme i wanna use, nothing happens...
    i googelt quite a lot but all the advice was to install the nvidia driver coorectly (which i don't have because it's intel I am using) or the reinstall compiz / emerald from an actual reposity or redoing the settings, which when i follow the advice does not bring any solution in my case.
    under window decoration emerald --replace is set.
    so my questions are:
    1) how do i get the main title bar of my windows back using compiz?
    2) how can activate an emerald theme because clicking on it and close doesn't work?

    thanks!
    oliver

  2. #2
    Join Date
    Sep 2008
    Location
    Bangalore, India
    Posts
    365

    Default Re: compis: emerald theme cant be activated, title bar is go

    In fusion-icon set "Select Window Decorator" to Emerald.

    Press Alt+F2 and type "emerald --replace" without quotes.

  3. #3
    tyskjaevel NNTP User

    Default Re: compiz: emerald theme cant be activated, title bar is go

    thx freedguy,
    tried this several times before but it doesn't work.
    as i said "emerald --replace" is said and applying it again doesn't change my prob. of course emerald is set active in the fusion-icon.
    any more suggestions?
    oliver

  4. #4
    Join Date
    Sep 2008
    Location
    Bangalore, India
    Posts
    365

    Default Re: compiz: emerald theme cant be activated, title bar is go

    Is "compiz-kde4" installed?

    Do you see any errors when running "emerald --replace" in konsole?

  5. #5
    tyskjaevel NNTP User

    Default Re: compis: emerald theme cant be activated, title bar is go

    heyho,
    yeah, thx, it says "symbol lookup error: /usr/lib/libwnck-1.so.22: undefined symbol: g_dgettext"
    but when i check the package "libwnck-1-22" in yast it is installed, and even if i reinstall it, it doesn't help?!
    what to do?
    oliver

  6. #6
    Join Date
    Sep 2008
    Location
    Bangalore, India
    Posts
    365

    Default Re: compis: emerald theme cant be activated, title bar is go

    Can you see any libwnck stuff in /usr/lib/?

    For example, if there is something like libwnck-1.so.18 just symlink it to the missing library: sudo ln -s /usr/lib/libwnck-1.so.18 /usr/lib/libwnck-1.so.22

    If it doesn't work add this repo and update both compiz and emerald: Index of /repositories/X11:/XGL/openSUSE_11.0_KDE4_Factory

  7. #7
    tyskjaevel NNTP User

    Default Re: compis: emerald theme cant be activated, title bar is go

    hej freedguy,
    thanks fpr the hint you gave me, but there's is libwnck-1.so.22 resp. libwnck-1.so.22.3.13 in /usr/lib/

    anyway, i updated compiz and emerald from the repository you have posted... the result stays the same:

    Code:
    emerald: symbol lookup error: /usr/lib/libwnck-1.so.22: undefined symbol: g_dgettext
    what does this mean?
    thx,
    oliver

  8. #8
    Join Date
    Sep 2008
    Location
    Bangalore, India
    Posts
    365

    Default Re: compis: emerald theme cant be activated, title bar is go

    The only solution i'm left with is uninstall all compiz and emerald packages, add this repo and install "compiz-git-all" Index of /repositories/home:/cyberorg/openSUSE_11.0

    This will install unstable compiz and emerald but it just works. You wont get the problems you're getting now, most likely.

  9. #9
    tyskjaevel NNTP User

    Default Re: compis: emerald theme cant be activated, title bar is go

    tried this - and guess what happened

    the same problems remains.

    i've got no clue, maybe it is kde4.1.x, maybe just me or some other packages... maybe it's a sign not to waste system resources for playing around with compiz^^

    thanks a lot for your help freedguy but i will wait and try it again when there is an update that (perhaps) even wants to work with my laptop.
    anyway, it's nice to get help here so that i don't feel totally lost in the linux universe!

  10. #10
    Join Date
    Sep 2008
    Location
    Bangalore, India
    Posts
    365

    Default Re: compis: emerald theme cant be activated, title bar is go

    Umm...try this one last thing.

    Go to your home directory and rename .kde4 and .compiz folders to .kde4.old and .compiz.old respectively (they are hidden folders), logout and login back and see if any miracle happens

    Anyways its been nice talking to you, Oliver

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •