Results 1 to 5 of 5

Thread: Perl Math::GSL, GSL & BLAS in openSUSE

  1. #1
    Join Date
    Nov 2008
    Location
    Planet Earth
    Posts
    15

    Default Perl Math::GSL, GSL & BLAS in openSUSE

    Hi,

    I am having considerable trouble in getting Perl's Math::GSL installed on openSUSE 11.0. I am working on AMD Turion 64 X2, 2Gb RAM and perl 5.10.0. First I had trouble with older versions of GSL. Now, after getting that compiled from source it seems that Math::GSL does not like the way the BLAS library available from the SUSE repositories was compiled. Has anyone had problems with this?

    Thanks,

  2. #2
    eberkers NNTP User

    Default Re: Perl Math::GSL, GSL & BLAS in openSUSE

    I have no direct answer to your question, but I am interested when you get one I need it for something too.
    Octave is using BLAS, so it must be supported somehow. I need it as part of it++, will soon look into that.

  3. #3
    Join Date
    Nov 2008
    Location
    Planet Earth
    Posts
    15

    Default Re: Perl Math::GSL, GSL & BLAS in openSUSE

    Yes, Octave uses BLAS without problems. However, it is Math::GSL which cries about BLAS. I am not entirely sure about the solution. I will have to try to compile BLAS from source anyway but I wanted to ask if someone in this forum had experience with the problem.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,670
    Blog Entries
    15

    Default Re: Perl Math::GSL, GSL & BLAS in openSUSE

    Quote Originally Posted by campephilus
    Yes, Octave uses BLAS without problems. However, it is Math::GSL which
    cries about BLAS. I am not entirely sure about the solution. I will have
    to try to compile BLAS from source anyway but I wanted to ask if someone
    in this forum had experience with the problem.
    Hi
    The problem is the gsl version. For some strange reason 11 ships with
    1.9 using cpan installing Math::GSL::Vector::Test it identified wanting
    gsl 1.11. So if you download 10.3 versions of gsl and gsl-devel from;
    http://download.opensuse.org/reposit...openSUSE_10.3/

    Then you can remove the old (newer??) versions of gsl and install the
    1.11 versions;

    Code:
    sudo zypper rm gsl gsl-devel
    cd to your download location;
    Code:
    sudo rpm -Uhv gsl-1.11*
    sudo rpm -Uhv gsl-devel-1.11*
    Then use cpan to install.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.18-0.2-default
    up 4:32, 3 users, load average: 1.24, 0.59, 0.28
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82


  5. #5
    Join Date
    Nov 2008
    Location
    Planet Earth
    Posts
    15

    Default Re: Perl Math::GSL, GSL & BLAS in openSUSE

    Yes, to upgrade to GSL 1.11 was the solution.
    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •