Results 1 to 9 of 9

Thread: KDE 4.1.3 Black screen

  1. #1

    Unhappy KDE 4.1.3 Black screen

    Hi all.
    I have installed KDE 4.1.3 on my openSuse 11.0 using one click install.
    The startup of KDE is really slow. After login pops the openSuse loading bar for a few minutes, then I just have a black screen with a white square on the top left edge. After few minutes KDE pops normally and everything works fine.:S
    Tips?
    Thank you!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE 4.1.3 Black screen

    Could be a number of things>

    First thing I would try is to login with kde3 (if you have it or icewm)

    In a terminal (uernme*= your user name)

    mv /home/uernme/.kde4 .kde4old
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: KDE 4.1.3 Black screen

    Thank you! That actually solved the problem. Now I will have to set my preferences again, but that's not big problem.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE 4.1.3 Black screen

    Yes. It renamed your .kde4 folder to .kde4old
    it holds all your settings
    but it was something in there causing the problem

    probably related to desktop effects or plasmoids/plasma
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: KDE 4.1.3 Black screen

    Hi I have the same problem and need a little more assistance doing this. Firstly is there a keyboard short to get to the console then how would I get to copy the old settings over my corrupt settings

  6. #6

    Default Re: KDE 4.1.3 Black screen

    K wait before I get creamed 4 a dumb *** I figured out the mv command so I just need the shortcut to terminal thanks

  7. #7

    Default Re: KDE 4.1.3 Black screen

    You can get to the console using the CTRL+ALT+F1.

  8. #8
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: KDE 4.1.3 Black screen

    ...and back via Ctrl + Alt + F7.

  9. #9

    Default Re: KDE 4.1.3 Black screen

    Thanks all. I've had the same problem for a few weeks, after changing some desktop settings.

    I had thought I'd somehow messed up my OS and was going to re-install it. However after trying all the keys on my keyboard I managed to bring up Firefox, then a quick search for "black screen white square" brought me straight here to this thread, and the solution!

    As a suggestion it would be nice if openSUSE could somehow detect a failure to bring up the desktop and (for openSUSE novices like me) offer reset it back to the default, but anyway, problem solved. Thanks again.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •