Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: cant install vlc

  1. #1
    Join Date
    Oct 2008
    Location
    delhi.inida
    Posts
    32

    Default cant install vlc

    hey .. i had installed vlc on my previous installation of opensuse11.0 but now when i am tryinf to install it from yast it gives following error File './noarch/iso-codes-2.0-16.1.noarch.rpm' not found on medium 'http://download.opensuse.org/distribution/11.0/repo/oss/'
    help...

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: cant install vlc

    First lets see what repo's you have

    in a terminal

    zypper lr
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Oct 2008
    Location
    delhi.inida
    Posts
    32

    Default Re: cant install vlc

    this is output when i did zypper ]Alias | Name | Enabled | Refresh
    --+--------------------------------------------------------------------+--------------------------------------------------------------------+---------+--------
    1 | repo-debug | openSUSE-11.0-Debug | Yes | No
    2 | Index of /pub/packman/suse/11.0 | Packman Repository | Yes | Yes
    3 | openSUSE-11.0-Non-Oss | openSUSE-11.0-Non-Oss | Yes | No
    4 | Index of /pub/videolan/vlc/SuSE/11.0/ | VideoLan Repository | Yes | Yes
    5 | Index of /repositories/home:/cubo/openSUSE_11.0 | Index of /repositories/home:/cubo/openSUSE_11.0 | Yes | Yes
    6 | openSUSE-11.0-Oss | openSUSE-11.0-Oss | Yes | Yes
    7 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes
    |

    .. i have added packman,videolan,oss,non oss reposterios ...to my yast reposteries...
    help...

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: cant install vlc

    Ok
    First
    Go to Yast - software management
    Filter by repo
    select vlc/videolan repo and make sure you have libdvdcss ticked, if not tick to install.
    Once you you have that, disable vlc/videolan reo

    Now again in software management
    filter by repo
    select Packman

    Now, from the top left ish of your screen click the packages tab and select update all in this list unconditionally.

    Now scroll down the list and make sure VLC is checked for install or it will show as update if it was already installed.

    accept

    leave vlc disabled
    you should end up with only libdvdcss installed from there
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Oct 2008
    Location
    delhi.inida
    Posts
    32

    Default Re: cant install vlc

    this is output when i did zypper ]Alias | Name | Enabled | Refresh
    --+--------------------------------------------------------------------+--------------------------------------------------------------------+---------+--------
    1 | repo-debug | openSUSE-11.0-Debug | Yes | No
    2 | Index of /pub/packman/suse/11.0 | Packman Repository | Yes | Yes
    3 | openSUSE-11.0-Non-Oss | openSUSE-11.0-Non-Oss | Yes | No
    4 | Index of /pub/videolan/vlc/SuSE/11.0/ | VideoLan Repository | Yes | Yes
    5 | Index of /repositories/home:/cubo/openSUSE_11.0 | Index of /repositories/home:/cubo/openSUSE_11.0 | Yes | Yes
    6 | openSUSE-11.0-Oss | openSUSE-11.0-Oss | Yes | Yes
    7 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes |

    .. i have added packman,videolan,oss,non oss reposterios ...to my yast reposteries...
    help...

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: cant install vlc

    Quote Originally Posted by prakhar3003 View Post
    this is output when i did zypper ]Alias | Name | Enabled | Refresh
    --+--------------------------------------------------------------------+--------------------------------------------------------------------+---------+--------
    1 | repo-debug | openSUSE-11.0-Debug | Yes | No
    2 | Index of /pub/packman/suse/11.0 | Packman Repository | Yes | Yes
    3 | openSUSE-11.0-Non-Oss | openSUSE-11.0-Non-Oss | Yes | No
    4 | Index of /pub/videolan/vlc/SuSE/11.0/ | VideoLan Repository | Yes | Yes
    5 | Index of /repositories/home:/cubo/openSUSE_11.0 | Index of /repositories/home:/cubo/openSUSE_11.0 | Yes | Yes
    6 | openSUSE-11.0-Oss | openSUSE-11.0-Oss | Yes | Yes
    7 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes |

    .. i have added packman,videolan,oss,non oss reposterios ...to my yast reposteries...
    help...
    DID YOU DO THIS

    Ok
    First
    Go to Yast - software management
    Filter by repo
    select vlc/videolan repo and make sure you have libdvdcss ticked, if not tick to install.
    Once you you have that, disable vlc/videolan reo

    Now again in software management
    filter by repo
    select Packman

    Now, from the top left ish of your screen click the packages tab and select update all in this list unconditionally.

    Now scroll down the list and make sure VLC is checked for install or it will show as update if it was already installed.

    accept

    leave vlc disabled
    you should end up with only libdvdcss installed from there
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,245

    Default Re: cant install vlc

    No need to shout!

    Geoff
    Quote Originally Posted by caf4926 View Post
    DID YOU DO THIS
    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: cant install vlc

    Shout not intentional
    Just not paying attention - sorry prakhar3003, geoffro
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,490
    Blog Entries
    37

    Default Re: cant install vlc

    Quote Originally Posted by caf4926 View Post
    Shout not intentional
    Just not paying attention
    IMHO thats why one often has to be a bit more verbose, and provide the reasons behind a recommendation - without the reasoning, the importance is simply lost and not understood.

    Of course, I am guilty myself on many occasions of not providing explanations as well.

    prakhar3003, an explanation .... some of us have discovered that vlc and the codecs as packaged by videolan, are not compatible with the packman packaged video players nor compatible with the packman packaged codecs. Which in essence means you can use Packman packaged multimedia, or Videolan packaged multimedia, but not both. If you try using both, and if you do not understand the precise limitations, one can run in to the sort of problems that you ran into.

    Now the one package that only videolan provides, which is useful (for dvd playback) is libdvdcss2. So since only videolan provides that, while you still have your videolan repos, install libdvdcss2.

    Then after that is installed, per caf4926 recommendation, remove (or disable) the videolan repos. Then using packman as your repository source, replace any videolan packaged apps (except for libdvdcss2). ie install packman packaged libffmpeg0 and packman packaged vlc.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: cant install vlc

    Quote Originally Posted by oldcpu View Post
    IMHO thats why one often has to be a bit more verbose, and provide the reasons behind a recommendation - without the reasoning, the importance is simply lost and not understood.

    Of course, I am guilty myself on many occasions of not providing explanations as well.

    prakhar3003, an explanation .... some of us have discovered that vlc and the codecs as packaged by videolan, are not compatible with the packman packaged video players nor compatible with the packman packaged codecs. Which in essence means you can use Packman packaged multimedia, or Videolan packaged multimedia, but not both. If you try using both, and if you do not understand the precise limitations, one can run in to the sort of problems that you ran into.

    Now the one package that only videolan provides, which is useful (for dvd playback) is libdvdcss2. So since only videolan provides that, while you still have your videolan repos, install libdvdcss2.

    Then after that is installed, per caf4926 recommendation, remove (or disable) the videolan repos. Then using packman as your repository source, replace any videolan packaged apps (except for libdvdcss2). ie install packman packaged libffmpeg0 and packman packaged vlc.
    prakhar3003
    You are in the hands of the Master Now (oldcpu). Thanks for that clarification oldcpu. You are quite right.

    Apologies all round for my unnecessary brevity and hard hitting reply.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •