Results 1 to 4 of 4

Thread: AMAROK and software RAID

  1. #1
    matgra NNTP User

    Default AMAROK and software RAID

    I have problem play music with Amarok on my openSUSE 11 running an software RAID5 file system.
    Must confess that I find it strange that it is possible to run a HD movie in Mplayer with no distortion and even listen to my MP3 music whit jampal whit no problem.

    Copying any mp3 file from one place to another happens within seconds.

    But Playing a mp3 music file in Amarok is distorted. It sounds as if the data is not read as fast as needed. This is the case if the mp3 music exists on a raid5 partition but not if the file is put in a partition that is not a part of the raid array.

    Configuration:

    Kernel: Linux 2.6.25.18-0.2-pae i686
    GUI: 4.0.4 (KDE 4.0.4 >= 20080505) "release 33.3"
    AMAROK: 1.4.10-100.pm.1-i586 from http://packman.iu.bremen.de/suse/11.0

    CPU
    Intel(R) Pentium(R) 4 CPU 3.00GHz
    3 GB in memory

    Graffa
    GeForce 7600 GS

    4 SATA hard drivers
    /dev/sda: Maxtor 6B300S0: 300 GB
    /dev/sdb: WDC WD7501AALS-00J7B0: 750 GB
    /dev/sdc: WDC WD7500AAKS-00RBA0: 750 GB
    /dev/sdd: ST3750330AS: 750 GB

    sda: is holding one windows system and one openSUSE10.3 system and all systems swap file.

    sdb, sdc and sdd is all partitioned in 4 primary partitions
    sdx1: 98GB
    sdx2: 1GB
    sdx3 500GB
    sdx4: 98 GB

    sdb4, sdc4 and sdd4 is building the md0 raid5 system holding the primary openSUSE11 system
    sdb2 is holding the boot partition.

    sdb3, sdc3 and sdd3 is building md1 holding all data ( and my music)

    sdc2 and sdd2 is not used but will hold the boot partition of the new openSUSE11.1 system when it will be installed on md3

    sdb1, sdc1 and sdd1 is partitioned in the same size but have not yet formed the md3 raid.
    Sdc1 is holding a stable openSUSE11 system for security reasons.

    Putting 4 GB music on the sdc1 drive and testing playing some MP3's from that single partition system or from the system running on md0 is not distorted. But music stored on md0 or as planned stored om md1 will bi distorted as I play it. This regardless if I uses the Yauap or the Xine sound system are used.

    Could some one advise?

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: AMAROK and software RAID

    Bizarre. The only thing I can think of is that your disk interrupts are somehow conflicting with the sound card interrupts. Can you post the output of:

    Code:
    cat /proc/interrupts
    Does your sound card have a separate IRQ line?

  3. #3
    matgra NNTP User

    Default Re: AMAROK and software RAID

    CPU0 CPU1
    0: 131 0 IO-APIC-edge timer
    1: 2 0 IO-APIC-edge i8042
    4: 6 0 IO-APIC-edge
    6: 5 0 IO-APIC-edge floppy
    7: 0 0 IO-APIC-edge parport0
    8: 0 0 IO-APIC-edge rtc0
    9: 0 0 IO-APIC-fasteoi acpi
    12: 4 0 IO-APIC-edge i8042
    14: 44949 0 IO-APIC-edge ata_piix
    15: 0 0 IO-APIC-edge ata_piix
    16: 313331 0 IO-APIC-fasteoi uhci_hcd:usb4, HDA Intel, nvidia
    18: 0 0 IO-APIC-fasteoi uhci_hcd:usb3
    19: 166983 0 IO-APIC-fasteoi ata_piix, uhci_hcd:usb2
    20: 10010 0 IO-APIC-fasteoi eth0
    23: 2 0 IO-APIC-fasteoi uhci_hcd:usb1, ehci_hcd:usb5
    NMI: 0 0 Non-maskable interrupts
    LOC: 864369 602301 Local timer interrupts
    RES: 188129 148802 Rescheduling interrupts
    CAL: 549269 726405 function call interrupts
    TLB: 11894 16292 TLB shootdowns
    TRM: 0 0 Thermal event interrupts
    SPU: 0 0 Spurious interrupts
    ERR: 0
    MIS: 0

  4. #4
    matgra NNTP User

    Default Re: AMAROK and software RAID

    The sound card is an on board devise. The IRQ is 16 and active.
    " 16: 332457 0 IO-APIC-fasteoi uhci_hcd:usb4, HDA Intel, nvidia" from the interupts file. Any clue?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •