Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: KDE 4.2

  1. #1

    Default KDE 4.2

    I'd like to upgrade my opensuse 11.0 to use KDE 4.2 (4.1.7x). What do I need to do to accomplish this?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

  3. #3

    Default Re: KDE 4.2

    Thanks, I added the repos you suggested and deleted the other KDE4 repos. However, I know get dependency errors when I attempt to upgrade. Are there any other repos I need to add or remove?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: KDE 4.2

    you may need the QT repo
    Index of /repositories/KDE:/Qt/openSUSE_11.0

    but thought you would already have it

    what are the errors? You can save them to file with the advanced button.

    The beauty of the software management in Yast is you can always exit before accepting, so try this:

    In software management - filter by repo
    switch off the dependency check just temporarily

    Now go to each of the new kde4 and the QT repo's and from the packages tab at the top - choose update all in this list unconditionally.
    When you have done that to each now check the dependency box and check.

    see if that resolves the issue
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,245

    Default Re: KDE 4.2

    Just a note here as stated 4.2 is not stable yet unless you are willing to have an unstable system you should wait until the stable release.

    Geoff
    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

  6. #6

    Default Re: KDE 4.2

    Quote Originally Posted by cirehawk View Post
    I'd like to upgrade my opensuse 11.0 to use KDE 4.2 (4.1.7x). What do I need to do to accomplish this?
    just play around with the qt repo's and that should fix it for you

    as long as you are on 11 and not an 11 beta, there the problem will hopefully be fixed soon as it has a few applications dependant on on a build a few weeks old.

    you should find that 4.1.7 is very stable, I have yet to have any problems running it.

  7. #7

    Default Re: KDE 4.2

    Quote Originally Posted by AlienHealer View Post
    just play around with the qt repo's and that should fix it for you

    as long as you are on 11 and not an 11 beta, there the problem will hopefully be fixed soon as it has a few applications dependant on on a build a few weeks old.

    you should find that 4.1.7 is very stable, I have yet to have any problems running it.
    Hmm, there are other Qt repos? Also, I saved the dependency file, but it's rather large. I'd hate to post the whole thing here.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: KDE 4.2

    How about showing us what reops you have:

    zypper lr -u
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: KDE 4.2

    Sure thing. Here are the results.

    1 | KDE:/KDE4:/Community/openSUSE_11.0_KDE4_UNSTABLE_Desktop | KDE:/KDE4:/Community/openSUSE_11.0_KDE4_UNSTABLE_Desktop | Yes | Yes | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.0_KDE4_UNSTABLE_Desktop
    2 | Index of /repositories/drivers:/webcam/openSUSE_11.0_Update | openSUSE BuildService - Drivers for webcams | Yes | Yes | Index of /repositories/drivers:/webcam/openSUSE_11.0_Update
    3 | http://ftp.skynet.be/pub/packman/suse/11.0/_1 | Packman Repository | Yes | Yes | Index of /pub/packman/suse/11.0
    4 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes | Index of /update/11.0
    5 | drivers:webcam | drivers:webcam | Yes | Yes | Index of /repositories/drivers:/webcam/openSUSE_11.0
    6 | KDE:/KDE4:/UNSTABLE:/Desktop/openSUSE_11.0 | KDE:/KDE4:/UNSTABLE:/Desktop/openSUSE_11.0 | Yes | Yes | Index of /repositories/KDE:/KDE4:/UNSTABLE:/Desktop/openSUSE_11.0
    7 | Index of /repositories/server:/database/openSUSE_11.0 | openSUSE BuildService - Database | Yes | Yes | Index of /repositories/server:/database/openSUSE_11.0
    8 | Index of /repositories/KDE:/Backports/openSUSE_11.0 | openSUSE BuildService - KDE:Backports | Yes | Yes | Index of /repositories/KDE:/Backports/openSUSE_11.0
    9 | Index of /distribution/11.0/repo/oss | Main Repository (OSS) | Yes | Yes | Index of /distribution/11.0/repo/oss
    10 | http://www.opensuse-education.org/do.../repo/1.0/11.0 | openSUSE Education | Yes | Yes | http://www.opensuse-education.org/do.../repo/1.0/11.0
    11 | KDE4:/UNSTABLE:/Extra-Apps/openSUSE_11.0 | KDE:/KDE4:/UNSTABLE:/Extra-Apps/openSUSE_11.0 | Yes | Yes | Index of /repositories/KDE:/KDE4:/UNSTABLE:/Extra-Apps/openSUSE_11.0
    12 | KDE:Qt_1 | KDE:Qt | Yes | Yes | Index of /repositories/KDE:/Qt/openSUSE_11.0
    13 | Index of /distribution/11.0/repo/non-oss | Main Repository (NON-OSS) | Yes | Yes | Index of /distribution/11.0/repo/non-oss
    14 | Index of /repositories/KDE:/Community/openSUSE_11.0 | openSUSE BuildService - KDE:Community | Yes | Yes | Index of /repositories/KDE:/Community/openSUSE_11.0

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: KDE 4.2

    It looks OK

    Though I'm not sure I would have the KDE/Backports in there

    Really the dependency error should be giving you a clue. Can't you see a common denominator in the error?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •