Results 1 to 4 of 4

Thread: VM ware version issues

  1. #1
    Join Date
    Nov 2008
    Location
    Edmonton Alberta
    Posts
    16

    Default VM ware version issues

    Hi all,
    I've been following a number of forum posts trying to get VMWare to work. It started last night with installing the player, thinking that was what i needed. I followed the install guid on the wiki but could not get vmware-any-any to run (not surprisingly Now) But the player did open and run my VM. Then my computer crashed from heat exhaustion, as separate issue, and on reboot I was unable to get the vm to turn on. It was late and I didn't write down the error.

    Today I've been installing and installing different combinations of versions of vmware (not the player) and the any-any thing (what is it any way) I final got the VMware Server Console 1.0.6 build-91891 to install with vmware-any-any-update117d (Thanks Magic31, SUSE 11 and VMWARE Server 1.0.6 - openSUSE Forums)

    VMstarted and it was glorious. And then i powered on the same vm that ran last night.

    Code:
    Unable to change virtual machine power state: The process exited with an error:
    vmxvmdb: Index name being generated from config file
    POST(no connection): Version mismatch with vmmon module: expecting 138.0, got 168.0.
    You have an incorrect version of the `vmmon' kernel module.
    Try reinstalling VMware Server.
    
    POST(no connection): Failed to initialize monitor device.
    
    Failed to initialize VM.
    End of error message.
    Can someone please tell me the combination to this lock?

    This is what I have:
    uname -a
    Linux 2.6.25.18-0.2-pae #1 SMP 2008-10-21 16:30:26 +0200 i686 i686 i386 GNU/Linux
    running on hp nx9420 1GB ram

    gcc gcc-c++ and others just in case you see a conflict
    gcc43-objc-4.3.1_20080507-6.1
    gcc-obj-c++-4.3-39.1
    gcc43-c++-4.3.1_20080507-6.1
    gcc-4.3-39.1
    gcc43-obj-c++-4.3.1_20080507-6.1
    libgcc43-4.3.1_20080507-6.1
    gcc43-4.3.1_20080507-6.1
    gcc-objc-4.3-39.1
    gcc-c++-4.3-39.1

    Kernel source and headers
    linux-kernel-headers-2.6.25-8.1
    kernel-xen-2.6.25.18-0.2
    kernel-pae-2.6.25.18-0.2
    nfs-kernel-server-1.1.2-9.2
    kernel-source-2.6.25.18-0.2
    kernel-syms-2.6.25.18-0.2

    There is mounting pressure to get this vm to work. I maintain some vb6 code and am going on a trip next week. If i can't get windows up I'm going to have to uninstall suse


    Also: If someone is looking for the vmware-any-any here is another download spot. Hope google sees it
    Files - vmkernelnewbies | Google Groups

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: VM ware version issues

    On 11/13/2008 rtpth wrote:
    > POST(no connection): Version mismatch with vmmon module: expecting
    > 138.0, got 168.0.


    Run vmware-config.pl again and see if that fixes it.
    I don't understand why you need the any-any patch for VMWare Server 1 on Opensuse 11. It should work without it.

    Uwe

  3. #3
    Join Date
    Nov 2008
    Location
    Edmonton Alberta
    Posts
    16

    Default Re: VM ware version issues

    Yeah I've run that .pl a few times, i've uninstantiated Vm reinstalled. How do i start over? It worked once. How do I undo all the things that the runme.pl did?

  4. #4
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: VM ware version issues

    * rtpth,

    there should be vmware-uninstall.pl

    HTH
    Uwe

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •