Results 1 to 2 of 2

Thread: Running smsd in the background

  1. #1
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Running smsd in the background

    I have installed gnokii software and is working fine.
    It have a database in mysql, where it create two tables for inbox and outbox.
    Now if i want to receive sms or send sms, i have to run the following line in terminal and the daemon will run until you want and by ctrl+C exit from that line. But it will still run.
    /usr/sbin/smsd -u sms -d smsgw -c localhost -m mysql
    Now the case is if i close terminal it will be stopped and no more sms send and receive.
    So how can i run this daemon forever without terminal, i think >/dev/null or somehow like this will work, but not sure.
    Any ideas to do this.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,308
    Blog Entries
    15

    Default Re: Running smsd in the background

    Quote Originally Posted by mmarif4u
    I have installed gnokii software and is working fine.
    It have a database in mysql, where it create two tables for inbox and
    outbox.
    Now if i want to receive sms or send sms, i have to run the following
    line in terminal and the daemon will run until you want and by ctrl+C
    exit from that line. But it will still run.
    > /usr/sbin/smsd -u sms -d smsgw -c localhost -m mysql
    >

    Now the case is if i close terminal it will be stopped and no more sms
    send and receive.
    So how can i run this daemon forever without terminal, i think
    >/dev/null or somehow like this will work, but not sure.

    Any ideas to do this.
    Hi
    I would have thought there is a config file down in the /etc
    or /etc/sysconfig directory where you can add your options. Then a
    startup script in /etc/init.d? If so then to enable, you should be able
    to run;
    Code:
    chkconfig smsd on
    The above will activate it to start at boot, to start it now, use;
    Code:
    sudo /etc/init.d/smsd start
    If my assumptions are wrong, then you need to adapt
    the /etc/init.d/skeleton script to meet your needs. One of the
    prerequisites to start would be mysql.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.18-0.2-default
    up 7:49, 1 user, load average: 0.02, 0.09, 0.13
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •