Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: SOLVED: I have to run vmware-config.pl each time I boot.

  1. #1
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default SOLVED: I have to run vmware-config.pl each time I boot.

    Hi
    I have openSUSE 11.0 KDE3.5 with VMware Server version 2.0.0 installed. It runs Windows 2000 guest in openSUSE host with networking and file sharing, printing and so on just fine.

    The problem is that after I boot the Suse computer and put this address into Firefox: http: //127.0.0.1:8222, it gives the following error:
    Failed to Connect
    Firefox can't establish a connection to the server at 127.0.0.1:8222.
    Though the site seems valid, the browser was unable to establish a connection............etc etc
    If I totally reconfigure VMware by running the following command and following the bouncingt ball, it starts to work just fine again:
    Code:
    vmware-config.pl
    What do I do to make the configuration stick through the openSUSE boot cycle?

    Thanks
    Swerdna
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,196
    Blog Entries
    15

    Default Re: I have to run vmware-config.pl each time I boot.

    Quote Originally Posted by swerdna
    Hi
    I have openSUSE 11.0 KDE3.5 with VMware Server version 2.0.0 installed.
    It runs Windows 2000 guest in openSUSE host with networking and file
    sharing, printing and so on just fine.

    The problem is that after I boot the Suse computer and put this address
    into Firefox: http: //127.0.0.1:8222, it gives the following error:
    > Failed to Connect
    > Firefox can't establish a connection to the server at 127.0.0.1:8222.
    > Though the site seems valid, the browser was unable to establish a
    > connection............etc etc

    If I totally reconfigure VMware by running the following command and
    following the bouncingt ball, it starts to work just fine again:

    Code:
    --------------------
    vmware-config.pl
    --------------------


    What do I do to make the configuration stick through the openSUSE boot
    cycle?

    Thanks
    Swerdna
    Hi
    Is the vmware service configured to start at boot?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.18-0.2-default
    up 4:55, 1 user, load average: 0.28, 0.30, 0.29
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80


  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: I have to run vmware-config.pl each time I boot.

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Is the vmware service configured to start at boot?
    No it wasn't. So I went to Yast --> runlevels --> expert and switched on three of four vmware lines. Then clicked over to "expert" mode and checked levels 2, 3 and 5. However they don't "stick" when I reboot.

    So I looked carefully at the console dialogue when I run vmware-config.pl and there's one hint of an error occurring. At one line it responds/says:
    illegal runlevel specified for vmware: r
    That's the only hint of anything disliked in the dialogue. The dialogue is included below:
    Code:
    suse110:/home/john # vmware-config.pl
    Making sure services for VMware Server are stopped.
    
    Stopping VMware autostart virtual machines:
       Virtual machines                                                   failed
    Stopping VMware management services:
       VMware Virtual Infrastructure Web Access
       VMware Server Host Agent                                           failed
    Stopping VMware services:
       VMware Authentication Daemon                                        done
       VM communication interface socket family:                           done
       Virtual machine communication interface                             done
       Virtual machine monitor                                             done
       Bridged networking on /dev/vmnet0                                   done
       Host network detection                                              done
       Virtual ethernet                                                    done
    
    None of the pre-built vmmon modules for VMware Server is suitable for your
    running kernel.  Do you want this program to try to build the vmmon module for
    your system (you need to have a C compiler installed on your system)? [no] yes
    
    Using compiler "/usr/bin/gcc". Use environment variable CC to override.
    
    Your kernel was built with "gcc" version "4.3.1", while you are trying to use
    "/usr/bin/gcc" version "4.3". This configuration is not recommended and VMware
    Server may crash if you'll continue. Please try to use exactly same compiler as
    one used for building your kernel. Do you want to go with compiler
    "/usr/bin/gcc" version "4.3" anyway? [no] yes
    
    What is the location of the directory of C header files that match your running
    kernel? [/lib/modules/2.6.25.18-0.2-pae/build/include]
    
    Extracting the sources of the vmmon module.
    
    Building the vmmon module.
    
    Using 2.6.x kernel build system.
    make: Entering directory `/tmp/vmware-config0/vmmon-only'
    make -C /lib/modules/2.6.25.18-0.2-pae/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: Entering directory `/usr/src/linux-2.6.25.18-0.2-obj/i386/pae'
    make -C /usr/src/linux-2.6.25.18-0.2 O=/usr/src/linux-2.6.25.18-0.2-obj/i386/pae/. modules
      CC [M]  /tmp/vmware-config0/vmmon-only/linux/driver.o
      CC [M]  /tmp/vmware-config0/vmmon-only/linux/driverLog.o
      CC [M]  /tmp/vmware-config0/vmmon-only/linux/hostif.o
      CC [M]  /tmp/vmware-config0/vmmon-only/common/comport.o
      CC [M]  /tmp/vmware-config0/vmmon-only/common/cpuid.o
      CC [M]  /tmp/vmware-config0/vmmon-only/common/hashFunc.o
      CC [M]  /tmp/vmware-config0/vmmon-only/common/memtrack.o
      CC [M]  /tmp/vmware-config0/vmmon-only/common/phystrack.o
      CC [M]  /tmp/vmware-config0/vmmon-only/common/task.o
      CC [M]  /tmp/vmware-config0/vmmon-only/common/vmx86.o
      CC [M]  /tmp/vmware-config0/vmmon-only/vmcore/moduleloop.o
      LD [M]  /tmp/vmware-config0/vmmon-only/vmmon.o
      Building modules, stage 2.
      MODPOST 1 modules
      CC      /tmp/vmware-config0/vmmon-only/vmmon.mod.o
      LD [M]  /tmp/vmware-config0/vmmon-only/vmmon.ko
    make[1]: Leaving directory `/usr/src/linux-2.6.25.18-0.2-obj/i386/pae'
    cp -f vmmon.ko ./../vmmon.o
    make: Leaving directory `/tmp/vmware-config0/vmmon-only'
    The vmmon module loads perfectly into the running kernel.
    
    None of the pre-built vmci modules for VMware Server is suitable for your
    running kernel.  Do you want this program to try to build the vmci module for
    your system (you need to have a C compiler installed on your system)? [yes]
    
    Extracting the sources of the vmci module.
    
    Building the vmci module.
    
    
    
    Using 2.6.x kernel build system.
    make: Entering directory `/tmp/vmware-config0/vmci-only'
    make -C /lib/modules/2.6.25.18-0.2-pae/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: Entering directory `/usr/src/linux-2.6.25.18-0.2-obj/i386/pae'
    make -C /usr/src/linux-2.6.25.18-0.2 O=/usr/src/linux-2.6.25.18-0.2-obj/i386/pae/. modules
      CC [M]  /tmp/vmware-config0/vmci-only/linux/driver.o
      CC [M]  /tmp/vmware-config0/vmci-only/linux/driverLog.o
      CC [M]  /tmp/vmware-config0/vmci-only/linux/vmciKernelIf.o
      CC [M]  /tmp/vmware-config0/vmci-only/common/vmciContext.o
      CC [M]  /tmp/vmware-config0/vmci-only/common/vmciDatagram.o
      CC [M]  /tmp/vmware-config0/vmci-only/common/vmciDriver.o
      CC [M]  /tmp/vmware-config0/vmci-only/common/vmciDs.o
      CC [M]  /tmp/vmware-config0/vmci-only/common/vmciEvent.o
      CC [M]  /tmp/vmware-config0/vmci-only/common/vmciGroup.o
      CC [M]  /tmp/vmware-config0/vmci-only/common/vmciHashtable.o
      CC [M]  /tmp/vmware-config0/vmci-only/common/vmciProcess.o
      CC [M]  /tmp/vmware-config0/vmci-only/common/vmciQueuePair.o
      CC [M]  /tmp/vmware-config0/vmci-only/common/vmciResource.o
      LD [M]  /tmp/vmware-config0/vmci-only/vmci.o
      Building modules, stage 2.
      MODPOST 1 modules
      CC      /tmp/vmware-config0/vmci-only/vmci.mod.o
      LD [M]  /tmp/vmware-config0/vmci-only/vmci.ko
    make[1]: Leaving directory `/usr/src/linux-2.6.25.18-0.2-obj/i386/pae'
    cp -f vmci.ko ./../vmci.o
    make: Leaving directory `/tmp/vmware-config0/vmci-only'
    The vmci module loads perfectly into the running kernel.
    
    None of the pre-built vsock modules for VMware Server is suitable for your
    running kernel.  Do you want this program to try to build the vsock module for
    your system (you need to have a C compiler installed on your system)? [yes]
    
    Extracting the sources of the vsock module.
    
    Building the vsock module.
    
    Using 2.6.x kernel build system.
    make: Entering directory `/tmp/vmware-config0/vsock-only'
    make -C /lib/modules/2.6.25.18-0.2-pae/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: Entering directory `/usr/src/linux-2.6.25.18-0.2-obj/i386/pae'
    make -C /usr/src/linux-2.6.25.18-0.2 O=/usr/src/linux-2.6.25.18-0.2-obj/i386/pae/. modules
      CC [M]  /tmp/vmware-config0/vsock-only/linux/af_vsock.o
      CC [M]  /tmp/vmware-config0/vsock-only/linux/driverLog.o
      CC [M]  /tmp/vmware-config0/vsock-only/linux/util.o
      CC [M]  /tmp/vmware-config0/vsock-only/linux/vsockAddr.o
      LD [M]  /tmp/vmware-config0/vsock-only/vsock.o
      Building modules, stage 2.
      MODPOST 1 modules
    WARNING: "VMCIDatagram_CreateHnd" [/tmp/vmware-config0/vsock-only/vsock.ko] undefined!
    WARNING: "VMCIDatagram_DestroyHnd" [/tmp/vmware-config0/vsock-only/vsock.ko] undefined!
    WARNING: "VMCI_GetContextID" [/tmp/vmware-config0/vsock-only/vsock.ko] undefined!
    WARNING: "VMCIDatagram_Send" [/tmp/vmware-config0/vsock-only/vsock.ko] undefined!
      CC      /tmp/vmware-config0/vsock-only/vsock.mod.o
      LD [M]  /tmp/vmware-config0/vsock-only/vsock.ko
    make[1]: Leaving directory `/usr/src/linux-2.6.25.18-0.2-obj/i386/pae'
    cp -f vsock.ko ./../vsock.o
    make: Leaving directory `/tmp/vmware-config0/vsock-only'
    The vsock module loads perfectly into the running kernel.
    
    You have already setup networking.
    
    Would you like to skip networking setup and keep your old settings as they are?
    (yes/no) [yes]
    
    None of the pre-built vmnet modules for VMware Server is suitable for your
    running kernel.  Do you want this program to try to build the vmnet module for
    your system (you need to have a C compiler installed on your system)? [yes]
    
    Extracting the sources of the vmnet module.
    
    Building the vmnet module.
    
    Using 2.6.x kernel build system.
    make: Entering directory `/tmp/vmware-config0/vmnet-only'
    make -C /lib/modules/2.6.25.18-0.2-pae/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: Entering directory `/usr/src/linux-2.6.25.18-0.2-obj/i386/pae'
    make -C /usr/src/linux-2.6.25.18-0.2 O=/usr/src/linux-2.6.25.18-0.2-obj/i386/pae/. modules
      CC [M]  /tmp/vmware-config0/vmnet-only/driver.o
      CC [M]  /tmp/vmware-config0/vmnet-only/hub.o
      CC [M]  /tmp/vmware-config0/vmnet-only/userif.o
    
      CC [M]  /tmp/vmware-config0/vmnet-only/netif.o
      CC [M]  /tmp/vmware-config0/vmnet-only/bridge.o
      CC [M]  /tmp/vmware-config0/vmnet-only/filter.o
      CC [M]  /tmp/vmware-config0/vmnet-only/procfs.o
      CC [M]  /tmp/vmware-config0/vmnet-only/smac_compat.o
      CC [M]  /tmp/vmware-config0/vmnet-only/smac.o
      CC [M]  /tmp/vmware-config0/vmnet-only/vnetEvent.o
      CC [M]  /tmp/vmware-config0/vmnet-only/vnetUserListener.o
      LD [M]  /tmp/vmware-config0/vmnet-only/vmnet.o
      Building modules, stage 2.
      MODPOST 1 modules
      CC      /tmp/vmware-config0/vmnet-only/vmnet.mod.o
      LD [M]  /tmp/vmware-config0/vmnet-only/vmnet.ko
    make[1]: Leaving directory `/usr/src/linux-2.6.25.18-0.2-obj/i386/pae'
    cp -f vmnet.ko ./../vmnet.o
    make: Leaving directory `/tmp/vmware-config0/vmnet-only'
    The vmnet module loads perfectly into the running kernel.
    continued next post
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: I have to run vmware-config.pl each time I boot.

    continued from previous post
    Code:
    Please specify a port for remote connections to use [904]
    
    WARNING: VMware Server has been configured to run on a port different from the
    default port. Please make sure to use this port when installing remote clients
    on other machines.
    
    Using Existing SSL Certificate.
    You have a pre-existing config.xml.  The new version will be created as
    /etc/vmware/hostd/NEW_config.xml.  Please check the new file for any new values
    that you may need to migrate to your current config.xml.
    
    Do you want to use the current proxy port values? [yes]
    
    The current administrative user for VMware Server  is 'john'.  Would you like
    to specify a different administrator? [no]
    
    Using john as the VMware Server administrator.
    
    You have a pre-existing authorization.xml.  The new version will be created as
    /etc/vmware/hostd/NEW_authorization.xml.  Please check the new file for any new
    values that you may need to migrate to your current authorization.xml.
    
    You have a pre-existing vmInventory.xml.  The new version will be created as
    /etc/vmware/hostd/NEW_vmInventory.xml.  Please check the new file for any new
    values that you may need to migrate to your current vmInventory.xml.
    You have a pre-existing clients.xml.  The new version will be created as
    /usr/lib/vmware/hostd/docroot/client/NEW_clients.xml.  Please check the new
    file for any new values that you may need to migrate to your current
    clients.xml.
    
    This program previously created the file
    /usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16/work, and was about to
    remove it.  Somebody else apparently did it already.
    
    insserv: script vmware-core: service VMware already provided!
    insserv: script vmware-mgmt: service VMware already provided!
    insserv: script vmware: service VMware already provided!
    insserv: exiting now!
    illegal runlevel specified for vmware: r   <<===== error line here============
    In which directory do you want to keep your virtual machine files?
    [/mnt/sdb2/vmware]
    
    You have a pre-existing datastores.xml.  The new version will be created as
    /etc/vmware/hostd/NEW_datastores.xml.  Please check the new file for any new
    values that you may need to migrate to your current datastores.xml.
    
    Do you want to enter a serial number now? (yes/no/help) [no]
    
    Starting VMware services:
       Virtual machine monitor                                             done
       Virtual machine communication interface                             done
       VM communication interface socket family:                           done
       Virtual ethernet                                                    done
       Bridged networking on /dev/vmnet0                                   done
       VMware Server Authentication Daemon (background)                    done
       Shared Memory Available                                             done
    Starting VMware management services:
       VMware Server Host Agent (background)                               done
       VMware Virtual Infrastructure Web Access
    Starting VMware autostart virtual machines:
       Virtual machines                                                    done
    
    The configuration of VMware Server 2.0.0 build-116503 for Linux for this
    running kernel completed successfully.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,196
    Blog Entries
    15

    Default Re: I have to run vmware-config.pl each time I boot.

    Quote Originally Posted by swerdna
    continued from previous post

    Code:
    --------------------
    Please specify a port for remote connections to use [904]

    WARNING: VMware Server has been configured to run on a port different
    from the default port. Please make sure to use this port when
    installing remote clients on other machines.

    Using Existing SSL Certificate.
    You have a pre-existing config.xml. The new version will be created
    as /etc/vmware/hostd/NEW_config.xml. Please check the new file for any
    new values that you may need to migrate to your current config.xml.

    Do you want to use the current proxy port values? [yes]

    The current administrative user for VMware Server is 'john'. Would
    you like to specify a different administrator? [no]

    Using john as the VMware Server administrator.

    You have a pre-existing authorization.xml. The new version will be
    created as /etc/vmware/hostd/NEW_authorization.xml. Please check the
    new file for any new values that you may need to migrate to your
    current authorization.xml.
    You have a pre-existing vmInventory.xml. The new version will be
    created as /etc/vmware/hostd/NEW_vmInventory.xml. Please check the new
    file for any new values that you may need to migrate to your current
    vmInventory.xml. You have a pre-existing clients.xml. The new version
    will be created
    as /usr/lib/vmware/hostd/docroot/client/NEW_clients.xml. Please check
    the new file for any new values that you may need to migrate to your
    current clients.xml.
    This program previously created the file
    /usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16/work, and was
    about to remove it. Somebody else apparently did it already.

    insserv: script vmware-core: service VMware already provided!
    insserv: script vmware-mgmt: service VMware already provided!
    insserv: script vmware: service VMware already provided!
    insserv: exiting now!
    illegal runlevel specified for vmware: r
    In which directory do you want to keep your virtual machine files?
    [/mnt/sdb2/vmware]

    You have a pre-existing datastores.xml. The new version will be
    created as /etc/vmware/hostd/NEW_datastores.xml. Please check the new
    file for any new values that you may need to migrate to your current
    datastores.xml.
    Do you want to enter a serial number now? (yes/no/help) [no]

    Starting VMware services:
    Virtual machine monitor
    done Virtual machine communication
    interface done VM communication interface
    socket family: done Virtual
    ethernet done
    Bridged networking on /dev/vmnet0
    done VMware Server Authentication Daemon
    (background) done Shared Memory
    Available done Starting
    VMware management services: VMware Server Host Agent
    (background) done VMware Virtual
    Infrastructure Web Access Starting VMware autostart virtual machines:
    Virtual machines
    done The configuration of VMware Server 2.0.0 build-116503 for Linux
    for this running kernel completed successfully.
    --------------------

    Hi
    Have a look here
    http://communities.vmware.com/thread/174678

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.18-0.2-default
    up 7:35, 1 user, load average: 0.08, 0.23, 0.21
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80


  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: I have to run vmware-config.pl each time I boot.

    That thread was spot on.
    I now start a VMware server session with this command before doing the http address //127.0.0.1:8222
    Code:
    /etc/init.d/vmware start
    Works great now.
    Thanks malcolmlewis.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  7. #7
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: I have to run vmware-config.pl each time I boot.

    * swerdna,

    setting the scripts to not run in parallel slows down things, IMHO. What I did was a crontab entry for root with
    @reboot /etc/init.d/vmware restart

    Uwe

  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: I have to run vmware-config.pl each time I boot.

    Quote Originally Posted by buckesfeld View Post
    * swerdna,

    setting the scripts to not run in parallel slows down things, IMHO. What I did was a crontab entry for root with
    @reboot /etc/init.d/vmware restart

    Uwe
    I chose not to change the "run in parallel" thing because I don't understand it. So I too chose the "/etc/init.d/vmware restart" method. But I hadn't thought of the cron job method; thanks for the tip.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  9. #9

    Default Re: SOLVED: I have to run vmware-config.pl each time I boot.

    hi,

    I am using opensuse 11 - Gnome, I would like to use xen , vmware to install windows xp. so please guide me this regards.

    suresh

  10. #10
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: SOLVED: I have to run vmware-config.pl each time I boot.

    Quote Originally Posted by sureshmenon View Post
    hi,

    I am using opensuse 11 - Gnome, I would like to use xen , vmware to install windows xp. so please guide me this regards.

    suresh
    That's a different topic. Please start a new thread asking for that advice.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •