Results 1 to 2 of 2

Thread: No accents in Firefox and Ooo but Konqueror

  1. #1

    Default No accents in Firefox and Ooo but Konqueror

    Hello all,

    I have a openSuse10.3 using US-language locales with a German keyboard. I would like to be able to write French accents with this keyboard but I do not know how to figure this out with firefox and open office.

    I have set up nodeadkeys in the Regional settings of KDE and I added furthermore this in the yast/sax2 keyboard settings. In the sax2 testfield the accents work nicely, as well as in konqueror. But as soon as I use Firefox or OpenOffice these accents don't work at all.

    Someone knows about this problem? Do I have to change to German locales for the Linux system?

    Thanks in advance for your help.

    Peter

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,433

    Default Re: No accents in Firefox and Ooo but Konqueror

    I am not quite sure why you have chosen nodeadkeys as the French keyboard requires deadkeys for circumflex and diaeresis.

    The straightforward way to get accents is to select Regional>Keyboard layouts and add the relevant keyboard layouts.

    What you do then depends on your typing skills because you will get a full AZERTY or QUERTZ keyboard if you select French or German.

    If you don't expect the French accents to be in particular places, you can find all the French accents as ALT deadkeys on the German keyboard.

    If you do know where you expect to find the French or German accents, you can install both keyboards and click on the flag to swap between them, carrying on with the keyboard you are most comfortable with until you come to an accent.

    OK it slows you down but this will work for all applications, including OO, Firefox, mysql, etc.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •