Results 1 to 7 of 7

Thread: VLC & Compiz

  1. #1

    Default VLC & Compiz

    I have the following problem:
    Since I installed Compiz Fusion on my desktop, I can't seem to get VLC or any other media player to play video files correctly. I remember back when I used 10.3 with Compiz Emerald, I never had this problem.

    Thanks in advance
    My System reqs are:
    Intel Dual Core T2500 @ 2.00GHz
    1 GB RAM
    ATI X1600 Mobility
    OpenSuse 11.0
    GNOME
    Spyros Papaspyropoulos
    Internet Specialist
    www.x2interactive.gr | www.papaspyropoulos.com | www.webdesignblog.gr (In Greek)

  2. #2
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    1,140

    Default Re: VLC & Compiz

    Although it's not much of an answer, you did mention trying other mediaplayers.

    I got SMplayer (Mplayer + fancy gui) working just fine along with Compiz-Fusion.
    It's a more than decent alternative to VLC with great subtitle support and plays pretty much anything.

    If you want to stick with vlc I suggest trying to find some video output option and messing around with that.
    Special effects <- KDE 4.2 Showing off
    More KDE -> PINK KDE

  3. #3

    Default Re: VLC & Compiz

    I installed SMplayer but I still get the same problems. To be precise I get a flashing screen (black flash) and an annoying flicker.
    Spyros Papaspyropoulos
    Internet Specialist
    www.x2interactive.gr | www.papaspyropoulos.com | www.webdesignblog.gr (In Greek)

  4. #4
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    1,140

    Default Re: VLC & Compiz

    Don't think I can be of any help then as it works perfectly for me, can just advice you to make sure you have the latest ATI drivers installed.

    How to do install them is described on ATI - openSUSE (including a nice one click installer). But I'm guessing you already did since you got some function out of Compiz-Fusion.
    Special effects <- KDE 4.2 Showing off
    More KDE -> PINK KDE

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,490
    Blog Entries
    37

    Default Re: VLC & Compiz

    ToxicWaste, you could try to:
    a. disable special desktop effects (ie Compiz) and see if your video works, or
    b. in each of your Media Players, change the output video mode from "auto" (or from "xv" (xvideo)) to "x11".

    Also, a number of users of Intel graphic cards also have this problem in openSUSE-11.0. Some managed to find an edit to the /etc/X11/xorg.conf file to address this. Does your PC have an Intel graphics card?

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: VLC & Compiz

    I think Lee (oldcpu) is probably in the ball park with (b)
    I had to change settings in video output on laptop to x11

    let us know if it resolves the problem please.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: VLC & Compiz

    Thanks a million guys!!!

    Oldcpu yes, after deactivating Desktop Effects, everything worked fine. Once I re-activated them I got the same issue.

    I switched my players to X11 and everything works fine. The only problem I have is that VLC doesn't have any audio any more no matter what I do to change the settings in the audio menu. That is a shame 'cause VLC was my favourite. No matter, I will use SMplayer from now on.

    Good night!
    Spyros Papaspyropoulos
    Internet Specialist
    www.x2interactive.gr | www.papaspyropoulos.com | www.webdesignblog.gr (In Greek)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •