Results 1 to 5 of 5

Thread: Opensuse 10.3 - I seem not to get automatic updates anymore

  1. #1
    xyz987123 NNTP User

    Default Opensuse 10.3 - I seem not to get automatic updates anymore

    Hello,

    I'm using Opensuse 10.3 and have observed that for quite a while, I have not been getting automatic updates anymore.

    As an example, my kernel is still 2.6.22.18-0.2-default (obtained using the command "uname -r"). If I look then on Index of /update/10.3/repodata I see that there is a file called "patch-kernel-5700.xml", dated 21-Oct-2008 that should have updated (at least that is what I think) my kernel to 2.6.22.19.

    I have tried in Yast - Software Management to update the packages manually (option: "Update if newer version available"), but according to Yast, there were no such packgages.

    The repositories that are currently active on my machine are:


    (I have disabled a few others like packman and the buildservice for Openoffice and Mozilla, as I thought that would have helped resolving my issue. But it didn't.)

    Does anybody have an idea what I should do?

    Thank you for your help!

  2. #2
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Opensuse 10.3 - I seem not to get automatic updates anym

    Are you tried to delete these repositories (after that quit from the repository manager!), and add them again?
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: Opensuse 10.3 - I seem not to get automatic updates anym

    Try YaST>Software>Online Update; you have to confirm that you want to install a new kernel; it will not be installed automatically without your permission.
    Last edited by john_hudson; 09-Nov-2008 at 02:28. Reason: Add full reference

  4. #4
    xyz987123 NNTP User

    Default Re: Opensuse 10.3 - I seem not to get automatic updates anym

    Thank you both for your very quick reactions!

    I deleted the 3 repositories, went out of the repository manager and added them again:


    I did not delete the other repositories like packman, etc... that were anyhow not enabled. (Should I have done so?)

    After adding the 3 repositories, Yast was downloading a whole lot files (mainly xml files as I could see it).

    I then also tried YaST>Software>Online Update as suggested by John. Also the online updater was quite busy for a while downloading stuff. At the end I got the error message: "No active update repository is available. Exit Online Update now? Yes/No".

    Do you have any further suggestions?

    (Also, just to make sure: was I right about the assumption that by now my Opensuse 10.3 should have been upgraded to 2.6.22.19?)

  5. #5
    xyz987123 NNTP User

    Thumbs up Re: Opensuse 10.3 - I seem not to get automatic updates anym

    ISSUE SOLVED

    Today I started up the computer and ... the automatic update tool indicated there were a lot of updates to be made. (A.o. the 2.6.19.22 kernel) Apparently there was a reboot needed.

    So in summary, what made it work for me:

    1) I deleted the OSS, Non-OSS and Update repositories
    2) Went out of the Repository Manager
    3) Added the 3 repositories I removed under 1 again
    4) Rebooted the computer
    5) Then the automatic updater indicated there were updates available...

    Thanks again to ram88 and John Hudson for their help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •