Results 1 to 3 of 3

Thread: Configuration of proxy in YaST issues

  1. #1

    Default Configuration of proxy in YaST issues

    Hello,

    Here's newbie.
    To access internet, I need to pass through an auto config script.

    I configure Konqueror and Firefox with the script and it works well.

    In YaST, I used Network Services and Proxy.
    I fill the window with Activate proxy and put the address of the script in the fields.
    The address is : http://myproxy.domain/proxy/proxy.pac

    When I use the button Test Proxy parameters it doesn't work. The error message is :
    '<url> malformed
    curl: (3) <url> malformed
    + About to connect() to proxy myproxy.domain port 1080 (#0)
    + Trying XX.XX.XX.XX... connexion refused
    + Trying XX.XX.XX.YY... connexion refused
    + couldn't connect to host
    + closing connection #0
    curl: (7) couldn't connect to host


    I check the /etc/sysconfig/proxy file : it is correct.

  2. #2
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Configuration of proxy in YaST issues

    for some reason, Yast configuration does not writes everything.
    2 soluions, one easier but bad because of yast bug, and one handwork.

    1.
    Setup proxy in Yast, Finish, then reopen and put user/pass, and now you may "test" connection as much as you please.
    *** BUG: sometimes yast "forgets" password.

    2.
    Open /etc/sysconfig/proxy and set proxies yourself, in manner:
    Code:
    user:pass@proxyaddr:port
    ***BUG: resetting network doesnt pick up the values. Reboot is needed.

  3. #3

    Default Re: Configuration of proxy in YaST issues

    Thanks for your help.
    Everything works well now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •