Results 1 to 6 of 6

Thread: Problems with Gnome desktop

  1. #1

    Default Problems with Gnome desktop

    Hello everybody.

    I installed OpenSuSE 11 on my rather old desktop platform:

    . Asus TUV4X MB
    . Pentium III CPU at 866MHZ
    . ATI Xpert 98 RXL AGP 2X graphic card
    . 640MB of RAM
    . EIDE hard disk and CD-ROM

    I configured Xorg as to use the framebuffer deivce at 1280x1024 and everything was working fine.

    Today I expanded the system memory to 1GB of RAM and, without touching anything, the Gnome desktop started behaving in a strangely manner.

    A few minutes after I booted the system and entered Gnome (which automatically starts both Firefox 3 and Thunderbird 2) I had a freeze of the session. The mouse did not move but the system was still alive (I was able to log into it via SSH from another box).

    After a reboot, I had the same problem after a couple of minutes.

    Since the only thing I changed was the amount of RAM, I started playing with the following BIOS settings (here are the default values):

    AGP Capability: [4X mode]
    Video Memory Cace Mode: [USWC]
    AGP Aperture Size: [64MB]

    I tried by setting the AGP aperture size to 256MB and the system was able to run for more time (approx 20 minutes) but then, all of a sudded, I was kicked back to the GDM login.

    I logged in again and tried to switch screen by pressing CTRL-ALT-F1 but the video screen got "garbled" in the sense that I had a mix of both graphical and text characters depicted.

    As an example, I had the character prompt depicted into the upper half section of the screen (but it was barely visible) and the rest of the graphical desktop was corrupted.

    Of course, I was unable to return to the graphical screen (CTRL-ALT-F7) and I had to reboot the machine.

    I then set the followin options in the BIOS:

    AGP Capability: [2x MODE]
    AGP Aperture Size: [16MB]

    Restarted the system and, with both Firefox and Thunderbid active, I was able to type this request without problems.

    My "guts instinct" seems to indicate that once you reach a given amount of allocated (used) RAM, something goes wrong with the video card memory and the screen gets corrupted.

    After typing this message I'd load the system with OpenOffice, Acrobat Reader and another memory-hogging applications just to test it.

    Another option is that perhaps the RAM module I added is bad thus giving the above behaviour (so by reverting to the original situation should solve this issue).

    I can post both the xorg.conf and the output from dmesg if someone's interested.


  2. #2

    Default Re: Problems with Gnome desktop

    When I add RAM and my system becomes unstable I suspect the RAM. It may be bad or incompatible with my system.

  3. #3

    Default Re: Problems with Gnome desktop

    Well, this is an option but in my experience when you have bad RAM the system either locks or PANICs.

    Anyway, since I last posted my message the system's been working fine and stable (I'm keeping my fingers crossed); I tried to increase the workload and memory usage by starting OpenOffice (with a large Excel file), Acrobat Reader (with a 500pages manual) and using VMware Server 2.0's Remote Console (via the Firefox plugin) with 5 different open sessions and I had no problems.

    I'll keep the forum updated with my findings as soon as they progress.


  4. #4

    Default Re: Problems with Gnome desktop

    That's a pretty good load. Sounds like you got it. Glad everything seems to be working so far.

  5. #5

    Default Re: Problems with Gnome desktop

    Hello everybody.

    Just to inform the group that the box with OpenSuSE is still running and it's been running all over the last week-end without apparent problems.

    Perhaps the problem was really due to the AGP aperture size.


  6. #6

    Default Re: Problems with Gnome desktop

    That's great. Glad you got it fixed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts