Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: FreeNX Time-out

  1. #1
    Join Date
    Sep 2008
    Location
    St Louis, MO USA
    Posts
    398

    Default FreeNX Time-out

    I haven't had much luck with ssh X11 forwarding on my server. At the suggestion of another forum user, I am trying to set up FreeNX. Everything installed okay, I created a user, added a password, but I can't actually start a session. I enter my username and password with the nxclient, it authenticates fine, and then sits for a while "Downloading session information" and then times out. Choosing "Details" gives me the following message:

    Code:
    NX> 203 NXSSH running with pid: 30235
    NX> 285 Enabling check on switch command
    NX> 285 Enabling skip of SSH config files
    NX> 285 Setting the preferred NX options
    NX> 200 Connected to address: myIPAddress on port: mySSHPort
    NX> 202 Authenticating user: nx
    NX> 208 Using auth method: publickey
    HELLO NXSERVER - Version 1.5.0-70 OS (GPL, using backend: 2.1.0)
    NX> 105 hello NXCLIENT - Version 1.5.0
    NX> 134 Accepted protocol: 1.5.0
    NX> 105 SET SHELL_MODE SHELL
    NX> 105 SET AUTH_MODE PASSWORD
    NX> 105 login
    NX> 101 User: zak
    NX> 102 Password: 
    NX> 103 Welcome to: remoteServer user: zak
    NX> 105 listsession --user="zak" --status="suspended,running" --geometry="1600x1200x24+render" --type="unix-gnome"
    NX> 127 Sessions list of user 'zak' for reconnect:
    
    Display Type             Session ID                       Options  Depth Screen         Status      Session Name
    ------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------
    
    
    NX> 148 Server capacity: not reached for user: zak
    NX> 105 startsession  --link="lan" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --media="1" --mediahelper="esd" --imagecompressionmethod="3" --imagecompressionlevel="-1" --render="1" --session="mySession" --type="unix-gnome" --geometry="1024x768+288+198" --kbtype="pc102/us" --screeninfo="1024x768x24+render" 
    
    NX> 280 Exiting on signal: 15
    I don't even see any error in that output, except the last line. What is going wrong here? SSH is open in the firewall; I am not sure what else to check.

    I really need some way to run some graphical apps on the remote machine, and a VNC session is too slow.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,319
    Blog Entries
    15

    Default Re: FreeNX Time-out

    Quote Originally Posted by zak89
    I haven't had much luck with ssh X11 forwarding on my server. At the
    suggestion of another forum user, I am trying to set up FreeNX.
    Everything installed okay, I created a user, added a password, but I
    can't actually start a session. I enter my username and password with
    the nxclient, it authenticates fine, and then sits for a while
    "Downloading session information" and then times out. Choosing "Details"
    gives me the following message:


    Code:
    --------------------
    NX> 203 NXSSH running with pid: 30235
    NX> 285 Enabling check on switch command
    NX> 285 Enabling skip of SSH config files
    NX> 285 Setting the preferred NX options
    NX> 200 Connected to address: myIPAddress on port: mySSHPort
    NX> 202 Authenticating user: nx
    NX> 208 Using auth method: publickey
    HELLO NXSERVER - Version 1.5.0-70 OS (GPL, using backend: 2.1.0)
    NX> 105 hello NXCLIENT - Version 1.5.0
    NX> 134 Accepted protocol: 1.5.0
    NX> 105 SET SHELL_MODE SHELL
    NX> 105 SET AUTH_MODE PASSWORD
    NX> 105 login
    NX> 101 User: zak
    NX> 102 Password:
    NX> 103 Welcome to: remoteServer user: zak
    NX> 105 listsession --user="zak" --status="suspended,running"
    --geometry="1600x1200x24+render" --type="unix-gnome" NX> 127 Sessions
    list of user 'zak' for reconnect:
    Display Type Session ID Options
    Depth Screen Status Session Name ------- ----------------
    -------------------------------- -------- ----- --------------
    ----------- ------------------------------
    NX> 148 Server capacity: not reached for user: zak
    NX> 105 startsession --link="lan" --backingstore="1"
    --encryption="1" --cache="16M" --images="64M" --media="1"
    --mediahelper="esd" --imagecompressionmethod="3"
    --imagecompressionlevel="-1" --render="1" --session="mySession"
    --type="unix-gnome" --geometry="1024x768+288+198" --kbtype="pc102/us"
    --screeninfo="1024x768x24+render" NX> 280 Exiting on signal: 15
    --------------------


    I don't even see any error in that output, except the last line. What
    is going wrong here? SSH is open in the firewall; I am not sure what
    else to check.

    I really need some way to run some graphical apps on the remote
    machine, and a VNC session is too slow.
    Hi
    Just to confirm is it freenx or the one from nomachine? I have had much
    better luck with the version from nomachine...

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.18-0.2-default
    up 1 day 22:35, 3 users, load average: 0.27, 0.27, 0.28
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80


  3. #3
    Join Date
    Sep 2008
    Location
    St Louis, MO USA
    Posts
    398

    Default Re: FreeNX Time-out

    Well, it's from the openSUSE repo. I do have the rpms from nomachine, I suppose I could try that.

  4. #4
    Join Date
    Sep 2008
    Location
    St Louis, MO USA
    Posts
    398

    Default Re: FreeNX Time-out

    Well, the rpms from nomachine don't seen to install at all. There are no errors during installation (either via the rpm command or yast2 (with the packages in my own local repo), but there are no nx* commands available, and rpm -q reports that the rpm are not installed (even though they are shown as installed in yast!). I am having a really bad day.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,319
    Blog Entries
    15

    Default Re: FreeNX Time-out

    Quote Originally Posted by zak89
    Well, it's from the openSUSE repo. I do have the rpms from nomachine, I
    suppose I could try that.
    Hi
    Yes, if you could remove the opensuse rpm's and install the ones from
    nomachine. Did you also reset the ssh_config file to original and
    restart sshd?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.18-0.2-default
    up 1 day 23:05, 3 users, load average: 0.29, 0.19, 0.14
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80


  6. #6
    Join Date
    Sep 2008
    Location
    St Louis, MO USA
    Posts
    398

    Default Re: FreeNX Time-out

    I uninstalled openSUSE's freeNX packages and installed the rpms from nomachine. Something went wrong, though, because like I said before, rpm reports the packages as uninstalled, even though I had just "rpm -ivh"ed them. I then put nomachines rpms' in my own local repo, and installed them again via yast2. Still no dice. I haven't reverted my ssh files, though. But that shouldn't stop the rpms from installing, and why are they not generating an error message?

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,319
    Blog Entries
    15

    Default Re: FreeNX Time-out

    Quote Originally Posted by zak89
    Well, the rpms from nomachine don't seen to install at all. There are no
    errors during installation (either via the rpm command or yast2 (with
    the packages in my own local repo), but there are no nx* commands
    available, and rpm -q reports that the rpm are not installed (even
    though they are shown as installed in yast!). I am having a really bad
    day.
    Hi
    You must be..... did you try starting the server?
    Code:
    malcolml@kermit-opensuse:~$ zypper se -i nx
    Reading installed packages...
    
    S | Name     | Summary         | Type
    --+----------+-----------------+--------
    i | nxclient | NX Client       | package
    i | nxnode   | NX Server Node  | package
    i | nxserver | NX Free Edition | package
    
    malcolml@kermit-opensuse:~$ sudo /etc/init.d/nxserver restart
    root's password:
    NX> 123 Service stopped.
    NX> 153 Stopping NX server monitor.
    NX> 153 NX server monitor already stopped.
    NX> 122 Service started.
    NX> 999 Bye.
    NX> 723 Cannot start NX statistics:
    NX> 709 NX statistics are disabled for this server.
    NX> 999 Bye.
    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.18-0.2-default
    up 1 day 23:22, 4 users, load average: 0.09, 0.09, 0.09
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80


  8. #8
    Join Date
    Sep 2008
    Location
    St Louis, MO USA
    Posts
    398

    Default Re: FreeNX Time-out

    I feel so dumb....

    It is installed, but rather than putting the binaries in /usr/bin, they were installed in /etc/init.d as init scripts, like you showed. Not only that, the server was already running!

    I'll see if it works any better now.

    Thanks!

  9. #9
    Join Date
    Sep 2008
    Location
    St Louis, MO USA
    Posts
    398

    Default Re: FreeNX Time-out

    I am still getting the following error when trying to start a session:

    Code:
    NX> 203 NXSSH running with pid: 23807
    NX> 285 Enabling check on switch command
    NX> 285 Enabling skip of SSH config files
    NX> 285 Setting the preferred NX options
    NX> 200 Connected to address: 72.14.182.249 on port: 22
    NX> 202 Authenticating user: nx
    NX> 208 Using auth method: publickey
    HELLO NXSERVER - Version 3.2.0-16 - LFE
    NX> 105 Hello NXCLIENT - Version 3.2.0
    NX> 134 Accepted protocol: 3.2.0
    NX> 105 Set shell_mode: shell
    NX> 105 Set auth_mode: password
    NX> 105 Login 
    NX> 101 User: zak
    NX> 102 Password: ********
    NX> 500 ERROR: Operation timeout in communication with SSH server
    NX> 999 Bye.
    NX> 280 Exiting on signal: 15
    Do I need to create an nx user or something? How did you set your's up after installing the packages?

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,319
    Blog Entries
    15

    Default Re: FreeNX Time-out

    Quote Originally Posted by zak89
    I feel so dumb....

    It is installed, but rather than putting the binaries in /usr/bin, they
    were installed in /etc/init.d as init scripts, like you showed. Not only
    that, the server was already running!

    I'll see if it works any better now.

    Thanks!
    Hi
    You may also need to remove the .nx directories in the local and remote
    hosts and try again....

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.18-0.2-default
    up 2 days 0:26, 1 user, load average: 0.00, 0.12, 0.22
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80


Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •