Results 1 to 7 of 7

Thread: Problem with MIDI

  1. #1
    mensola NNTP User

    Default Problem with MIDI

    I've some problems running MIDI: i'm unable to hear MIDI generated by TuxGuitar or Guitar PRO for few days...
    I've started "timidity" from my Gnome engine typing:

    Code:
    Cristiano@linux-n7lx:~> timidity -iA -Os
    *** PULSEAUDIO: Unable to connect: Connection refused
    Can't open pcm device 'default'.
    Couldn't open ALSA pcm device (`s')
    So i ran alsamixer:
    Code:
    Cristiano@linux-n7lx:~> alsamixer
    *** PULSEAUDIO: Unable to connect: Connection refused
    
    alsamixer: function snd_ctl_open failed for default: Connection refused
    And also:
    Code:
    Cristiano@linux-n7lx:~> pulseaudio
    W: core-util.c: setpriority(): Permission denied
    E: pid.c: Daemon already running.
    E: main.c: pa_pid_file_create() failed.
    Cristiano@linux-n7lx:~> u
    bash: u: command not found
    Cristiano@linux-n7lx:~> su
    Password: 
    linux-n7lx:/home/Cristiano # pulseaudio
    W: main.c: This program is not intended to be run as root (unless --system is specified).
    E: pid.c: Daemon already running.
    E: main.c: pa_pid_file_create() failed.
    linux-n7lx:/home/Cristiano #
    But i still can't listen any MIDI suond...
    What shall i do? I'm being crazy...

  2. #2
    mensola NNTP User

    Default Re: Problem with MIDI

    I forgot this... Typing "timidity -ia -os" (caps lower) linux prints:
    Code:
    Cristiano@linux-n7lx:~> timidity -ia -os
    *** PULSEAUDIO: Unable to connect: Connection refused
    s: No such file or directory
    Couldn't open dsp device (`d')
    Cristiano@linux-n7lx:~> Warning: Missing charsets in String to FontSet conversion
    Warning: Missing charsets in String to FontSet conversion
    Warning: Missing charsets in String to FontSet conversion
    Warning: Missing charsets in String to FontSet conversion
    Warning: Missing charsets in String to FontSet conversion
    CONNECTION PROBLEM WITH XAW PROCESS: Resource temporarily unavailable

  3. #3

    Default Re: Problem with MIDI

    The command is timidity -iA -Os , not timidity -ia -os. If you want to make MIDI sounds excellent , take these steps > http://susewiki.org/index.php?title=Using_MIDI
    Try again if this not works to reinstall timidity.

  4. #4
    mensola NNTP User

    Default Re: Problem with MIDI

    I've reinstalled timiditt but i haven't solved the problem: i can't hear any MIDI generated by other application (but if i open a MIDI-song with timidity i will hear the song).

    This is what I watch into the shell typing timidity -iA -Os
    Code:
    Cristiano@linux-n7lx:~> su
    Password: 
    linux-n7lx:/home/Cristiano # timidity -iA -Os
    Requested buffer size 32768, fragment size 8192
    ALSA pcm 'default' set buffer size 32768, period size 8192 bytes
    TiMidity starting in ALSA server mode
    Opening sequencer port: 129:0 129:1 129:2 129:3

  5. #5
    Join Date
    Jun 2008
    Location
    Brisbane Australia
    Posts
    30

    Default Re: Problem with MIDI

    Looks like you now have timidity working OK. I found that TuxGuitar needed to have the config changed to point at the Timidity MIDI "port". Not at my usual machine so cannot tell you exactly haw to do it - was under one of the tabs.

    Cheers

  6. #6

    Default Re: Problem with MIDI

    Yes , your timidity works now. But you have to select the port inside the Tuxguitar settings / sound.

  7. #7
    mensola NNTP User

    Default Re: Problem with MIDI

    Quote Originally Posted by Growlboy View Post
    Yes , your timidity works now. But you have to select the port inside the Tuxguitar settings / sound.
    done it. it's seems works...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •