Results 1 to 6 of 6

Thread: Need tcl-8.4 and tk-8.4

  1. #1

    Default Need tcl-8.4 and tk-8.4

    hi,

    i have to install the opal compiler. its not the opal in the repository but a compiler for the functional programming language opal.
    it depend on tcl-8.4 and tk-8.4. where can i find this rpms? i just found rpms from opensuse 10.3. is it possible to take this?

  2. #2

    Default Re: Need tcl-8.4 and tk-8.4

    hi,

    i built my own rpms from source and installed them. but is it possible to have tcl/tk-8.4 and also tcl/tk-8.5 installed?

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Need tcl-8.4 and tk-8.4

    Should be ok if the directories and filenames don't clash, and you point your app to the correct version.

    Sure you can't use 8.5?

    Otherwise probably best to build from the source tarball and install in say /usr/local.

  4. #4

    Default Re: Need tcl-8.4 and tk-8.4

    if the newer packages are install and i try to install the rpm the system tells me tcl-/tk-8.4 is needed and it stops the install process. so i'm sure i cant use 8.5.
    zypper doesn't care where i install my tcl/tk packages. a simple zypper install tcl/tk will always update to 8.5.

    maybe i have to try rpm instead of zypper to install all packages side by side?

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Need tcl-8.4 and tk-8.4

    zypper just calls rpm, so that won't make any difference to the installation directories. That's why if you really need them side by side you have to compile from source to be able to change the installation directories.

    Try bypassing the 8.4 requirement for your software, what was it called, opal? Chances are, if it isn't very version specific and 8.5 is mostly just bug-fixes over 8.4, it might just work. Or you could compile that package against 8.5.

  6. #6

    Default Re: Need tcl-8.4 and tk-8.4

    hi,
    the packages maintainer released a new version in which tcl/tk 8.5 is supported. so its no longer necessary to have both versions installed. nevertheless, it's interesting to understand how i could install two different versions of one package.


    thx for help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •