Results 1 to 6 of 6

Thread: VBOX question

  1. #1

    Default VBOX question

    Hi all,
    i'm runing vbox version 2 non-oss. In order to enable usb support i have to run following commands every time before starting vbox (application itself and not virtual machine):
    Code:
    /etc/init.d/vboxdrv setup
    -and-
    mount -a -t usbfs
    does anyone know how to make vbox enable usb support without running these commands everytime?

    thnx
    Last edited by nikotron; 30-Oct-2008 at 07:24. Reason: typos

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: VBOX question

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: VBOX question

    yes i did.

  4. #4
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,125

    Default Re: VBOX question

    I'm a real rookie with vbox, but I'll offer my experience. When you start up vbox, you get a screen listing your VMs. Under settings, there is a usb choice. Clicking that opens a dialog box that lets you set up various usb devices. You must add a least one device to that list. You can add a generic usb device. I also add my external hard drive. Once I did that, I never had to do it again.
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  5. #5
    Will Honea NNTP User

    Default Re: VBOX question

    nikotron wrote:

    >
    > Hi all,
    > i'm runing vbox version 2 non-oss. In order to enable usb support i
    > have to run following commands *every* time before starting vbox
    > (application itself and not virtual machine):
    >
    > Code:
    > --------------------
    >
    > /etc/init.d/vboxdrv setup
    > -and-
    > mount -a -t usbfs
    >
    > --------------------
    >
    >
    > does anyone know how to make vbox enable usb support without running
    > these commands everytime?


    I still haven't gotten around to fixing init to load usbfs as define in
    fstab but about the only glitch I've seen is that VB looks as if it ignores
    any USB devices plugged in before usbfs is mounted.

    --
    Will Honea

  6. #6
    Join Date
    Jun 2008
    Location
    Boston MA area
    Posts
    61

    Default Re: VBOX question

    You could always create a small script and put it into the various autostart places. If you use KDE, just put it into ~/.kde/Autostart (Go->Autostart from Konqueror)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •