Results 1 to 10 of 10

Thread: cannot get virtualbox to work.

  1. #1
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default cannot get virtualbox to work.

    Hi all,

    This is what I get when I try to fire up vbox:

    Code:
    VERR_VM_DRIVER_NOT_INSTALLED (rc=-1908)
    
    The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Re-setup the kernel module by executing
    
    '/etc/init.d/vboxdrv setup'
    
    as root. Users of Ubuntu or Fedora should install the DKMS package at first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.
    So I try this in Konsole:
    Code:
    /etc/init.d/vboxdrv setup
    and I get this:
    Code:
    Stopping VirtualBox kernel module                                    done
    Recompiling VirtualBox kernel module, NOT. It has been packaged.     done
    Starting VirtualBox kernel module                                    failed
      (No suitable module for running kernel found)
    This is what I have done so far:

    1- installed through yast using vbox repo
    2- rebooted for new kernel
    3- added the users to vboxusers
    4- enabled the vbox services.

    All this and still get this error.

    Any ideas?

    Thanks

    Heeter
    Linux Counter 475994

  2. #2
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,125

    Default Re: cannot get virtualbox to work.

    Did it ever work for you? Is this the first try at it? Each time I had a problem, either I forgot to add myself to vboxusers (which you did) or I didn't start vboxdrv (not the setup).

    Anyway, since its not working now, why not uninstall it? Then go to virtualbox.org and follow the links to download the latest version (2.0.4) and install that one. I just updated to that version and its working fine.

    Oh! I keep getting an error message about usb. I just click "ok" and continue loading and usb works fine. I have been fooling around with my 11.1 beta installs and now virtualbox brings up the boot screen twice before it actually loads beta3. An annoyance, but one I'm sure I caused and can live with.
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  3. #3
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default Re: cannot get virtualbox to work.

    Thanks Prexy,

    It has never worked, been toiling away at it since yesterday.

    I do have the latest one (2.0.4).


    Heeter
    Linux Counter 475994

  4. #4
    Join Date
    Aug 2008
    Location
    dublin
    Posts
    54

    Default Re: cannot get virtualbox to work.

    you need the kernel sources if you have compiled it by yourself. In pronciple you can add a repo
    Index of /repositories/Virtualization:/VirtualBox
    and install the opensource version.

    Alin
    Without Questions there are no Answers!

  5. #5

    Default Re: cannot get virtualbox to work.

    Sorry the board has no no delete function.
    I am posting on another post but for some reason it jumps to this thread.
    The only thing I can do is to edit.

    Sorry folks for the inconvenience.
    People who do not break things first will never learn to create anything

  6. #6
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default Re: cannot get virtualbox to work.

    Thanks ealin,

    I did use that repo,

    Conram, what does that link too? Cannot see anything about virtualbox in there.

    Heeter
    Linux Counter 475994

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: cannot get virtualbox to work.

    Are you using this repo
    Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.0

    and you have gone thru all the steps here
    VirtualBox Installation - openSUSE

    Note:
    Prerequisites for VirtualBox downloads

    Whether you use binaries or installing from source you have to install the following packages first:

    • kernel-source
    • kernel-syms
    • Xalan-c
    • Xerces-c

    Make sure all kernel packages match the kernel

    And the following:

    Post-Installation

    Though VirtualBox will start after you've just installed it, there are a few other necessary steps to complete before you can really get the most out of VirtualBox. These include:

    • Making sure that the vboxdrv driver is loaded.

    In the terminal (as root), execute the following command:
    modprobe vboxdrv

    • Add your user to the vboxusers group:

    groupmod --add-user <login> vboxusers
    Or open YaST -> Security and Users -> UserManagement, and edit your user and add them to the vboxusers group. To do this, select your user name, click on Edit, switch to the Details tab and check the vboxusers check box.
    You should then be able to run VirtualBox just fine!
    [edit]
    Getting vboxdrv module to auto load (openSUSE OSE package only)

    The version of VirtualBox OSE provided in the openSUSE OSS repo comes with its own kernel module so the vboxdrv setup command does not add this. It also does not set up the kernel module to auto load at system start up, if this is how you like it then ignore this section and have fun.
    This can be done by one of three ways:

    • The first way is by using insserv to add the module

    insserv vboxdrv

    • The second way is by going into system services (runlevel) and enabling vboxdrv

    YaST -> System > System Services (runlevel)-> vboxdrv and select the enable button and finish.

    • The last way is by adding it to the Modules_loaded_on_boot setting under sysconfig editor

    YaST -> System -> /etc/sysconfig editor -> System -> Kernel -> MODULES_LOADED_ON_BOOT and just type in vboxdrv in the input box.
    No matter which way you go with this will get the vboxdrv kernel module to auto load on boot of the system.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default Re: cannot get virtualbox to work.

    Thanks Caf,

    It is still not responding. I can startup the GUI, but cannot start up a virtual machine.

    I have done everything that you noted.......

    I also typed into konsole: /etc/init.d/vboxdrv setup and I am still getting this:

    Code:
    Stopping VirtualBox kernel module                                    done
    Recompiling VirtualBox kernel module, NOT. It has been packaged.     done
    Starting VirtualBox kernel module                                    failed
      (No suitable module for running kernel found)
    I am going to reboot.

    Heeter
    Linux Counter 475994

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: cannot get virtualbox to work.

    A re-boot may sort it. Let us know.

    I used to use the above repo, then I switched to the Sun .rpm

    I just deleted vbox from the repo in Yast

    then installed the .rpm from a terminal.

    But it was all working for me anyway. But might be worth a try.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default Re: cannot get virtualbox to work.

    Hey Thanks Caf,

    I messed around with it until this morning.

    I have given up and removed all virtualbox stuff, and installed VMware server. I got that up and running no problem.

    Thanks again guys, I will work with vmware server instead for now.

    Heeter
    Linux Counter 475994

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •