Results 1 to 3 of 3

Thread: KDE 4.1.2 system tray icons lost

  1. #1
    Join Date
    Aug 2008
    Location
    England
    Posts
    63

    Default KDE 4.1.2 system tray icons lost

    I have just updated my KDE 4 to 4.1.2 from the suse repository. When I start the session (I have also rebooted the computer) the system tray area is visible by its border and it grows as applications load and when I kill system tray applications, such as amarok and klipper, the tray shrinks.
    There are no icons in the tray and no mouse over activity. This renders system tray applications unreachable.

    Can anyone help me with this.
    I have looked in the ~/.xsession-errors file, some results below, is there anywhere else I can look for error reports?


    klipper adds nothing to the .xsession-errors file.
    .xsession-errors file on amarok launch:

    kdeinit4: preparing to launch /opt/kde3/bin/amarok
    kwin: X Error (error: <unknown>[DAMAGE+0], request: XDamageDestroy[DAMAGE+2], resource: 0x18051a2)
    QLayout "unnamed" added to QVBox "unnamed", which already has a layout
    QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout for PlaylistWindow/PlaylistWindow
    QObject::connect: Incompatible sender/receiver arguments
    StarManager::ratingsColorsChanged() --> ContextBrowser::ratingOrScoreOrLabelsChanged(const QString&)
    Amarok: [Loader] Starting amarokapp..
    Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
    QObject: Do not delete object, 'unnamed', during its event handler!

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: KDE 4.1.2 system tray icons lost

    * pblewis,

    the systray is available on the panel? RIght click the panel, Add Widgets, check the Systray. I'd remove it and add it back.

    Uwe

  3. #3
    Join Date
    Aug 2008
    Location
    England
    Posts
    63

    Default Re: KDE 4.1.2 system tray icons lost

    I have resolved the problem.
    I found that I was a few packages short of a full KDE 4.1.2 with the kdebase4-workspace being one of them!

    Sorry to have bothered everyone, but if anyone has the same problem, then this is the solution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •