Results 1 to 2 of 2

Thread: Chinese characters no longer displaying

  1. #1

    Default Chinese characters no longer displaying

    Yikes! I was on a mission to get Chinese input enabled, and in the process I broke the environment's ability to display character's natively. Sort of....

    I went through a lot of trials... first tried to get fcitx running, installed xmlto to try to fix a compile error, which installed a few dozen packages, and finally I couldn't get it work, gave up, and installed scim / skip.

    So now, on my OS11.0, KDE4.0, scim / skip DOES work correctly, I can input chinese characters into any standard application. (So the character fonts are present, and display correctly), but in Dolphin, or in any file open dialog, any file which has chinese characters in the name will display the characters as a Q-mark, instead of the proper character. Eg: "早上好" ="???".

    I've tried removing as many of the "extra" packages installed while trying to get fcitx working, and reinstalling every package I imagined may have a relation to the font rendering... but I'm still busted.

    Any guesses?

  2. #2

    Default Re: Chinese characters no longer displaying

    You mention that problems are with the file names. Are these files in NTFS/FAT partitions? If so, check fstab for the nls/codepage options. Default 11.0 should handle this flawlessly if you checked Chinese at installation step, just in case you modified it. Another possibility is the display font in Dolphin, see if other fonts get luck.
    As a lazy man, I recommend you to use 11.0 DVD and scim for an easy life. My 11.0 with KDE3.5 works just fine, both scim and display.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts