Results 1 to 3 of 3

Thread: Gnome Desktop Effects Not Working. Suse 11, Compiz, ATI

Hybrid View

  1. #1
    macarey1 NNTP User

    Default Gnome Desktop Effects Not Working. Suse 11, Compiz, ATI

    Desktop effects will not work. Wobbly, cube, transparency, fire...nothing. It's just the standard theme. I've tried a few different configs, and have downloaded the specific drivers I thought would be needed to make this work. If I tail /var/log/messages while enabling desktop effects through Simple CompizConfig this is what I see:

    Oct 22 17:06:26 D6CDV4H1-Suse kernel: compiz[14221]: segfault at 74 ip b79a6523 sp bf8b12bc error 6 in libwall.so[b799f000+10000]

    I do have dual-head display correctly working!

    I feel that at this point, I just may be missing something obvious, but don't know what to look for. Please review the below information on my setup and configurations to assist in enabling desktop effects (which I really love on my test Opensuse 11 box!).




    Monitor: Dell 1970FPT
    Card: ATI Radeon HD2400 XT (RV610 94C1)
    * Activate 3D Acceleration is enabled *





    D6CDV4H1-Suse:~ # uname -a
    Linux D6CDV4H1-Suse 2.6.25.16-0.1-pae #1 SMP 2008-08-21 00:34:25 +0200 i686 i686 i386 GNU/Linux





    D6CDV4H1-Suse:~ # rpm -qa | grep compiz
    compiz-0.7.8-3.1
    python-compizconfig-0.7.8-2.2
    compiz-emerald-themes-0.6.0-2.1
    compiz-fusion-plugins-main-0.7.8-2.2
    compiz-fusion-plugins-extra-0.7.8-2.2
    compiz-gnome-0.7.8-3.1
    compiz-manager-0.0.1_git080201-51.1
    compizconfig-settings-manager-0.7.8-2.2
    compiz-emerald-0.7.8-2.2
    libcompizconfig-0.7.8-2.2





    D6CDV4H1-Suse:~ # rpm -qa | grep gnome-desktop
    gnome-desktop-2.22.1-26.1
    gnome-desktop-devel-2.22.1-26.1
    libgnome-desktop-2-2-2.22.1-26.1





    D6CDV4H1-Suse:~ # fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Radeon HD 2400 XT
    OpenGL version string: 2.1.7873 Release





    D6CDV4H1-Suse:~ # glxinfo
    name of display: :0.0
    display: :0 screen: 0
    direct rendering: Yes
    server glx vendor string: SGI
    server glx version string: 1.2

    (I have shortened my glxinfo output as the post can only handle 10000 characters. I can add it later if it is necessary to view the entire output)




    D6CDV4H1-Suse:/etc/X11 # cat xorg.conf
    # /.../
    # SaX generated X11 config file
    # Created on: 2008-10-08T08:07:43-0400.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    Option "AllowMouseOpenFail" "on"
    Option "IgnoreABI" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "Module"
    Load "glx"
    Load "type1"
    Load "extmod"
    Load "dbe"
    Load "freetype"
    Load "dri"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection


    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "Logitech M-UV69a Optical Wheel Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 376 301
    HorizSync 30-81
    Identifier "Monitor[0]"
    ModelName "1907FPT"
    Option "DPMS"
    Option "PreferredMode" "1280x1024"
    VendorName "DELL"
    VertRefresh 43-60
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "ATI Radeon HD 2400 XT (RV610 94C1)"
    Driver "fglrx"
    Identifier "Device[0]"
    Option "SaXDualHead"
    Option "XAANoOffscreenPixmaps" "true"
    Option "Capabilities" "0x00000000"
    Option "SaXDualMode" "Xinerama"
    Option "ForceMonitors" "auto,crt1"
    Option "SaXDualHSync" "30-81"
    Option "SaXDualMonitorModel" "1907FPT"
    Option "SaXDualVSync" "50-60"
    Option "VRefresh2" "50-60"
    Option "Mode2" "1280x1024,1280x960,1280x800,1152x864,1280x768,1280x720,1024x768,1280x600,1024x600,800x600,768x576,640x480"
    Option "FSAAScale" "0"
    Option "FSAAEnable" "off"
    Option "VideoOverlay" "on"
    Option "SaXDualMonitorVendor" "DELL"
    Option "HSync2" "30-81"
    Option "SaXDualResolution" "1280x1024"
    Option "DesktopSetup" "Horizontal,Reverse"
    Option "SaXDualOrientation" "RightOf"
    Screen 0
    VendorName "ATI"
    EndSection



    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "Composite" "on"
    EndSection



    I will be happy to provide any other information necessary. Thank you to all who at least took a look at my post! Looking forward to hear back as this is my first post with OpenSuse.

  2. #2
    macarey1 NNTP User

    Default Re: Gnome Desktop Effects Not Working. Suse 11, Compiz, ATI

    This is resolved.
    A complete uninstall and re-install of Compiz seemed to fix my issue. All effects are now working -

  3. #3
    handzilla NNTP User

    Default Re: Gnome Desktop Effects Not Working. Suse 11, Compiz, ATI

    Hello from the Philippines!

    Here's a simple fix which came as a sudden inspiration:

    After opening control center then click-opening Compiz CCSM, i clicked on "enable desktop effects" which results in the windows borders disappearing, right? Alright, not to worry, just move the mouse to the upper-right corner of your screen and you should see all the windows scaled down and layed out... Notice the borders are back!? K, now just click Compiz' CCSM and close...

    Hope it works... Best regards to one & all. Thank you all Linux developers...!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •