Results 1 to 5 of 5

Thread: Error message about local

  1. #1
    Join Date
    Oct 2008
    Location
    Grenoble, France
    Posts
    19

    Default Error message about local

    Each time I open a terminal I get 13 lines of message saying:
    locale fr.UTF8 catalog libshell message 3.682 "%s: mauvaises options" does not m atch "on"

    I do not find any information nor in this forum nor with google.

    My system is:
    Opensuse 11.0, Linux 2.6.25.16-0.1-default, x86_64

    Thanks for your advices.

    Patrick

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Error message about local

    Quote Originally Posted by samontetro View Post
    Each time I open a terminal I get 13 lines of message saying:
    locale fr.UTF8 catalog libshell message 3.682 "%s: mauvaises options" does not m atch "on"

    I do not find any information nor in this forum nor with google.

    My system is:
    Opensuse 11.0, Linux 2.6.25.16-0.1-default, x86_64

    Thanks for your advices.

    Patrick
    Hi there -- welcome to the Forums.

    Here's two guesses from me:
    1. Check that you have the rpm package "glibc-locale" installed.
    2. Check also that exactly fr.UTF8 appears when you execute this command in a console:
      Code:
      locale -a | grep fr
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  3. #3
    Join Date
    Oct 2008
    Location
    Grenoble, France
    Posts
    19

    Default Re: Error message about local

    Check that you have the rpm package "glibc-locale" installed.

    Yes, it is.
    # rpm -qa |grep -i glibc
    glibc-info-2.8-14.1
    glibc-32bit-2.8-14.1
    glibc-2.8-14.1
    glibc-locale-32bit-2.8-14.1
    glibc-locale-2.8-14.1
    glibc-devel-2.8-14.1
    glibc-devel-32bit-2.8-14.1


    Check also that exactly fr.UTF8 appears when...
    No, I have only fr_FR.utf8, not fr.UTF8

    I do not know where it is set. It do not exist in my environment:
    # env |grep -i utf8
    #

    and the default value for LANG is set to POSIX.
    # echo $LANG
    POSIX

    Patrick

  4. #4
    pgen NNTP User

    Default Re: Error message about local

    Are you using ksh ?
    Try a minimal ~/.kshrc, mine is containing :
    Code:
    PS1='${PWD} $ '
    set -o vi
    also remove /etc/ksh.kshrc

  5. #5
    pgen NNTP User

    Default Re: Error message about local


    Are you using ksh ?
    Try a minimal ~/.kshrc, mine is containing :

    Code:
    --------------------
    PS1='${PWD} $ '
    set -o vi
    --------------------


    also remove /etc/ksh.kshrc


    --
    pgen
    ------------------------------------------------------------------------
    pgen's Profile: http://forums.opensuse.org/member.php?userid=18642
    View this thread: http://forums.opensuse.org/showthread.php?t=397954


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •