Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: characters like blocks

  1. #1
    Join Date
    Sep 2008
    Location
    Curacao (island in the Caribean Sea)
    Posts
    43

    Default characters like blocks

    I compiled EKIGA and after the try out I deleted the program
    Now I don't see characters anymore in the applications
    filezilla and MySQL-administrator.
    for every character I see a square block
    Does anybody know how to get the characters back??
    Suse 10.3 KDE
    Thanks

  2. #2
    Join Date
    Mar 2008
    Location
    San Diego (California)
    Posts
    475

    Default Re: characters like blocks

    is it only in one user or in any users and root?
    ~ There are 10 types of people. Those who understand binary, and those who don't. ~

  3. #3
    Join Date
    Sep 2008
    Location
    Curacao (island in the Caribean Sea)
    Posts
    43

    Default Re: characters like blocks

    Root also gets blocks in those programs.
    Maybe it has something to do with unicode characters.
    If the OS doesn't recognize them it displays small blocks?
    Under MS Windows i also had it once when I installed a chinese printer driver.
    How toget rid of it
    Thanks

  4. #4
    Join Date
    Mar 2008
    Location
    San Diego (California)
    Posts
    475

    Default Re: characters like blocks

    yes typically when some characters are not recognized they are displayed either with blocks or with weird accented letter (such as )

    It's some weird and tricky problem in this case. It is most probably not a global setting that has been changed, otherwise you would see those characters everywhere, in any application.

    I compiled ekiga on my previous suse installation (10.3), but did not screw up anything at all.
    Did the weirdness of the characters start immediately when you installed it or only when you unistalled it (and how did you unistall it? through the UNISTALL file in the source?)

    I would try three things, in the order:
    1) unistall those two applications, and reinstall
    2) if this is not solving, rename any folder in your home that contains the settings of those applications, then restart the application (maybe they have some weird LANGUAGE settings)
    3) if again that did not solve, reinstall Ekiga through Yast (i believe it is on the mirrors). This might override some weird settings that the compilation of the program caused

    Good luck, keep us posted!
    ~ There are 10 types of people. Those who understand binary, and those who don't. ~

  5. #5
    Join Date
    Sep 2008
    Location
    Curacao (island in the Caribean Sea)
    Posts
    43

    Default Re: characters like blocks

    I deleted the binary "ekiga" in /usr/bin
    I installed the ekiga.rpm
    I can't find the configuration file for filezilla
    firefox works great and it comes from the same club
    Still my characters are blocked.
    Do you know where the config file for filezilla is?
    /etc didn't give me a clue
    Thanks Teunis

  6. #6
    Join Date
    Mar 2008
    Location
    San Diego (California)
    Posts
    475

    Default Re: characters like blocks

    there will be something in your home dir as a hidden folder or file. It might be /home/USERNAME/.mozilla ....... or something else. From menu, choose the option "view hidden files" then you can do a search
    ~ There are 10 types of people. Those who understand binary, and those who don't. ~

  7. #7
    Join Date
    Sep 2008
    Location
    Curacao (island in the Caribean Sea)
    Posts
    43

    Default Re: characters like blocks

    Yes there is a .filezilla directory
    I took a look at filezilla.xml and layout.xml with firefox.
    In layout there is a language id "56"
    Any hint where to look for?

  8. #8
    Join Date
    Mar 2008
    Location
    San Diego (California)
    Posts
    475

    Default Re: characters like blocks

    close the program, rename that folder (any other name is fine) then restart the application. Another .filezilla folder will be automatically created and it will contain the default settings.
    If the characters weirdness was due to a screwed up setting over there, it will be solved.
    If it is solved, then you can inspect if that language id is different, and also you can copy back all the other configuration files and settings, so that you have your old configuration except for the screwed up setting(s)
    ~ There are 10 types of people. Those who understand binary, and those who don't. ~

  9. #9
    Join Date
    Sep 2008
    Location
    Curacao (island in the Caribean Sea)
    Posts
    43

    Default Re: characters like blocks

    No that did not work.
    It should have something to do with not recognizing the characters
    If .filezilla/layout.xml is used for the layout I see:
    <?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
    <FileZilla3>
    <Layout Builddate="2007-09-25" Buildtime="22:45:51">
    <Resources>
    <xrc file="toolbar.xrc" date="1190760460" />
    <xrc file="quickconnectbar.xrc" date="1190760460" />
    <xrc file="dialogs.xrc" date="1190760460" />
    <xrc file="netconfwizard.xrc" date="1190760460" />
    <xrc file="menus.xrc" date="1190760460" />
    </Resources>
    <Font font="Sans Serif 10" width="1080" height="14" />
    <Language id="56" />
    <Language id="53" date="1190760461" />
    etc.
    Maybe the font should be changed?
    I also have the problem as root so I think the problem is
    global

  10. #10
    Join Date
    Mar 2008
    Location
    San Diego (California)
    Posts
    475

    Default Re: characters like blocks

    if i understand correctly from this thread, you did NOT try uninstalling Filezilla, correct?
    I would try that. This way the folder in which it is installed would go deleted...normally.. If you want to make sure, search while it is still installed for filezilla, normally it would be in /opt/kde3/share/apps if you are a kde user, or somewhere in opt or usr. Do a system-wide search if you cannot find it.
    Once you unistall make sure that folder is gone, if still there rename it (do not delete, so that if things get sorted you can compare and find out what setting got screwed up and next time it happens you dont need to do all this). You could also back it up before uninstalling.
    Also if you find out what setting caused this, you can solve also for the other app without uninstalling it.

    So uninstall, delete any remaining folder and reinstall. It MUST work because originally it was working and there has not been any system-wide screw up
    ~ There are 10 types of people. Those who understand binary, and those who don't. ~

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •