Results 1 to 4 of 4

Thread: Unable to install/remove/update applications!

  1. #1

    Default Unable to install/remove/update applications!

    Hi, I'm going through the learning curve after migrating from WinXP to OpenSUSE 11.x, and I still don't understand several points so please help me with this one to start with.

    Initially I was able to install, remove and update all the applications without problem. Now this module simply doesn't load. I launch it from the Yast window but after it requests the Root PWD the module never opens. Furthermore, I installed Opera and recently I tried to update to 6.0 but it never worked.

    I'm really puzzled as I only created the administrator account so there shouldn't be a permissions issue.

    Please let me know your suggestions.


  2. #2
    Join Date
    Jun 2008

    Default Re: Unable to install/remove/update applications!

    Before doing anything at all: create a user-account and use root *only* for administrative tasks. You propably messed up something with admin privileges, which has much worse consequences than messing up stuff as user.

    There's a reason for splitted user-privileges. In case you ever went online as root, reinstall your system, for it might have been attacked already.

  3. #3
    Join Date
    Mar 2008
    Vsters, Sweden ex. Highbury London UK

    Default Re: Unable to install/remove/update applications!

    Yes as gropiuskalle you should NEVER run a Linux system as root.
    As it can result in a broken anb/or compromised system.
    You might be able to fix things by using the dvd by booting from it and doing a system restore.

    If not a reinstall (thought normally needed) my be your best bet. Make sure you backup your data first. And make sure you have a normal user and only use root when absolutely necessary like running yast.

    Also do some reading eg here and here

    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

  4. #4

    Default Re: Unable to install/remove/update applications!

    Thanks for all the responses. I just checked and yes, I'm using another account (aside from root). In any case I also think is very likely I messed up something as I keep having this problems. I'm gonna reinstall completely and start from scratch.

    Thanks again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts