Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Compileing IceCat

  1. #11

    Default Re: Compileing IceCat

    opening knetworkmanager from console I get the error message:
    Connection to D-Bus system message bus failed:
    Failed to connect to socket /usr/local/var/run/dbus/system_bus_socket: no such file or directory.

    It seems I need to reinstall dbus or change some configuration files. Does anyone know what I should do about this dbus error?

    Suse seems to think dbus is installed in /usr/local/var/ but there is nothing there but empty directories. Is this a problem?

  2. #12
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Compileing IceCat

    As I said...

    Quote Originally Posted by gropiuskalle
    Try to reinstall it via YaST and hope you haven't installed in some other path [...]
    Uninstall-scripts often fail. Sorry I can only explain, but can not help.

    Still curious about the the need of a higher dbus-version or installing IceCat at all... anyway.

    Edit: system_bus_socket is located in /var/run/dbus/ normally. A symlink might help, but well...

  3. #13

    Default Re: Compileing IceCat

    Quote Originally Posted by jdg_gehrig View Post
    opening knetworkmanager from console I get the error message:
    Connection to D-Bus system message bus failed:
    Failed to connect to socket /usr/local/var/run/dbus/system_bus_socket: no such file or directory.

    It seems I need to reinstall dbus or change some configuration files. Does anyone know what I should do about this dbus error?

    Suse seems to think dbus is installed in /usr/local/var/ but there is nothing there but empty directories. Is this a problem?
    It might help after manual install to do a
    SuSEconfig

    At gropiuskalle thanks for correcting checkinstall
    People who do not break things first will never learn to create anything

  4. #14
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,520
    Blog Entries
    37

    Default Re: Compileing IceCat

    Quote Originally Posted by jdg_gehrig View Post
    ...... I cannot load the XINE engine. Sound doesn't work either.
    If your sound works generically, but not in IceCat, then I can't help, as I don't use IceCat.

    If your sound does not work at all, you could try the opensuse audio troubleshooting guide:
    SDB:AudioTroubleshooting - openSUSE

    If you are having problems installing the packman libxine1 (but have the Novell/SuSE-GmbH xine-lib installed) then a technique that works is to mark the Novell/SuSE-GmbH xine-lib for de-install, and before de-installing it, also mark the Packman packaged libxine1 for installation. Then apply the two settings simultaneous.

  5. #15

    Default Re: Compileing IceCat

    How would I create the symbolic link? What would it point to?

    oldcpu:
    It doesn't seem to be a sound problem, but a I screwed up dbus problem and need to reconfigure it. XINE is just one of the libraries that no longer works, along with knetwork manager.

    also: SuSEconfig did not work. What should I do next?

  6. #16

    Default Re: Compileing IceCat

    Thank you gropiuskalle,
    thanks for your help the symlink was the problem xine started working on reboot and knetworkmanager is back up! As for your question about Dbus I don't know why it needed a higher version but in ./configure it listed it as a problem. It confuses me too.

    --John

  7. #17
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Compileing IceCat

    So it worked out? That's good to hear!

    I'm not sure wether you are willing to to touch anything at all now, since now your sys is back, alive and kicking, but there might be problems ocurring when dbus would get updatet via YaST. Is dbus in the rpm-database at all? You should check that:

    Code:
    rpm -qa | grep dbus
    Here's my output so you can compare:

    Code:
    05:13 hoppers:~ > rpm -qa | grep dbus
    dbus-1-1.2.1-15.1
    libedbus0-svn_20080924-2.2
    dbus-1-glib-0.74-88.1
    dbus-1-qt3-0.62-179.1
    dbus-1-python-0.82.4-49.1
    dbus-1-x11-1.2.1-18.1
    dbus-1-devel-1.2.1-15.1
    dbus-1-glib-devel-0.74-88.1
    dbus-1-qt3-devel-0.62-179.1
    libdbus-1-qt3-0-0.8.1-24.1
    [the devels are not necessary]

    Keep an eye on it.

    I'm sure you learned a lesson, right?

  8. #18

    Default Re: Compileing IceCat

    here is my output:
    Code:
    jgehrig@john-desktop-xp:~> rpm -qa | grep dbus
    dbus-1-qt3-devel-0.62-110
    libqt4-dbus-1-4.3.1-23.6
    dbus-1-glib-0.74-25
    dbus-1-x11-1.0.2-67.5
    dbus-1-qt3-0.62-110
    dbus-1-1.0.2-59
    dbus-1-devel-1.0.2-59.4
    seems to be fine

    and I DEFINITELY have learned my lesson!

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •