Results 1 to 7 of 7

Thread: newbie problem

  1. #1

    Cool newbie problem

    Hi,
    I am really a newbie.
    I became a 10.3 machine and I realised it to upgrade to 11.0.
    There were two ethernet cards (onboard SiS900 and PCI Realtek RT8139).
    The upgrade to 11.0 I realised with CD network install.
    After that I realised to upgrade LAN to WiFi with MSI PC70SE.
    I deleted the two cards in Network Settings and begun to try establish a connection with my WiFi (I found Ralink driver - I havent used it to this time).
    Now I am back to my old combination onboard + PCI Realtek but I cannot establish connection and I do not know if I have made something wrong or what happen.

    sysinfo:/ in Konqueror says - you are online
    ping in console says
    ping: sendmsg: Operation not permitted
    hardware information in YaST2 says that I have 2 Ethernets and 1 Loopback Network Interfaces

    P.S.: Where can I see which services/programs I run in openSUSE (like TaskManager in Windows XP)?

    Thanks

  2. #2
    Join Date
    Jul 2008
    Location
    Ljubljana
    Posts
    522

    Default Re: newbie problem

    The "Task Manager" in KDE is called KSysGuard. As for your networking problems, can you specify what exactly happened? You replaced your PCI LAN card with a wireless and then took out the wireless and put the LAN card back in or what?
    http://stopsoftwarepatents.eu/
    Even if free software were ****, it should still get our preference over the non-free **** secreted by IT corporations.
    A free rephrasing of RMS

  3. #3

    Default Re: newbie problem

    Yes, exactly, because I lost connection - but it was only firewall configuration error.

    Now, I use SiS600 onboard (It is confusing because I deleted configuration for it and openSUSE use configuration from RT8139) and wish to use MSI PC70SE card because I must move my PC away from cable connection.

    I found Ralink, but I cannot compile it - I am newbie
    Ralink Technology: Linux
    http://www.ralinktech.com.tw/data/dr....8.0.0.tar.bz2

    output from make is:
    make -C tools
    make[1]: Entering directory `/root/TemPoRaRy/MSIPC70SE/2008_0918_RT2860_Linux_STA_v1.8.0.0/tools'
    gcc -g bin2h.c -o bin2h
    make[1]: Leaving directory `/root/TemPoRaRy/MSIPC70SE/2008_0918_RT2860_Linux_STA_v1.8.0.0/tools'
    /root/TemPoRaRy/MSIPC70SE/2008_0918_RT2860_Linux_STA_v1.8.0.0/tools/bin2h
    cp -f os/linux/Makefile.6 /root/TemPoRaRy/MSIPC70SE/2008_0918_RT2860_Linux_STA_v1.8.0.0/os/linux/Makefile
    make -C /lib/modules/2.6.25.16-0.1-pae/build SUBDIRS=/root/TemPoRaRy/MSIPC70SE/2008_0918_RT2860_Linux_STA_v1.8.0.0/os/linux modules
    make[1]: Entering directory `/usr/src/linux-2.6.25.16-0.1-obj/i386/pae'
    make[1]: *** No rule to make target `modules'. Stop.
    make[1]: Leaving directory `/usr/src/linux-2.6.25.16-0.1-obj/i386/pae'
    make: *** [LINUX] Error 2

    P.S.: OpenSUSE 11, KDE4

  4. #4

    Default Re: newbie problem

    I solved it using ndiswrapper.
    Now I must solve how to load ndiswrapper at boot.

    In Konsole in directory where are inf,sys, and cat file (rt2860.*):
    ndiswrapper -i rt2860.inf
    modprobe ndiswrapper


    In file /etc/modprobe.conf after ISDN I put:

    ########################################################################
    # WLAN
    ########################################################################
    alias wlan0 ndiswrapper

    Now I run in security mode (via registration) with WEP.

  5. #5
    Join Date
    Jul 2008
    Location
    Ljubljana
    Posts
    522

    Default Re: newbie problem

    To load ndiswraper at boot just go to YAST/Network Devices/Network Settings. If there's already a Wireless connection, just edit it (putting in your WEP/WPA key, your network ESSID name, and of course tick the option "Run at boot"), if it's not there, you just click on Add and select Wireless connection, put in ndiswrapper as your driver name and the other required settings. After a reboot or two your wireless should run at boot automatically.
    Good luck!
    http://stopsoftwarepatents.eu/
    Even if free software were ****, it should still get our preference over the non-free **** secreted by IT corporations.
    A free rephrasing of RMS

  6. #6

    Default Re: newbie problem

    Thanks.
    Thats it.

    I changed device name from wlan0 to ndiswrapper and after reboot it installed a new RaLink card with device name wlan0 (maybe I should more often reboot).
    All is OK now.

    P.S.: It is not so important now, but what I made wrong by compiling the driver (LINUX error 2)?
    Last edited by Andrej_novell; 20-Oct-2008 at 13:41. Reason: adding a P.S.

  7. #7
    Join Date
    Jul 2008
    Location
    Ljubljana
    Posts
    522

    Default Re: newbie problem

    Glad it works now. As for your P.S. I don't know the answer, I never compile anything (as a linux newb I fear that compiling might easily break things unless you know precisely what you're doing - which I don't).
    http://stopsoftwarepatents.eu/
    Even if free software were ****, it should still get our preference over the non-free **** secreted by IT corporations.
    A free rephrasing of RMS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •