Results 1 to 7 of 7

Thread: No internet / no ping response ipw2200

  1. #1

    Default No internet / no ping response ipw2200

    Hello -

    After much browsing I've gotten a connection to my hidden-SSID, WPA-PSK network, but I now cannot ping the access point, nor any websites, nor navigate using FireFox or Konqueror. Some bg info:

    linux-c3fb:~ # lspci
    00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
    00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root Port (rev 03)

    --snip--

    02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
    03:01.0 CardBus bridge: Texas Instruments PCI6515 Cardbus Controller
    03:01.5 Communication controller: Texas Instruments PCI6515 SmartCard Controller
    03:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
    linux-c3fb:~ # lspci -n
    00:00.0 0600: 8086:2590 (rev 03)
    00:01.0 0604: 8086:2591 (rev 03)

    --snipsnip--

    03:01.5 0780: 104c:8038
    03:03.0 0280: 8086:4220 (rev 05)
    linux-c3fb:~ # dmesg | less
    ACPI: PCI Interrupt 0000:00:1e.3[B] -> GSI 17 (level, low) -> IRQ 17
    PCI: Setting latency timer of device 0000:00:1e.3 to 64
    ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
    ipw2200: Copyright(c) 2003-2006 Intel Corporation
    ACPI: \_SB_.PCI0.IDE0.SEC0.MAST: found ejectable bay
    ACPI: \_SB_.PCI0.IDE0.SEC0.MAST: Adding notify handler
    ACPI: Error installing bay notify handler
    ...Now onto the good stuff. As I said before, this is a wireless network with 3 access points through the building (only 2 shown in iwlist scan), a hidden-SSID, and WPA-PSK encryption.

    linux-c3fb:~ # iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    eth1 IEEE 802.11g ESSID:"Nystec WiFi"
    Mode:Managed Frequency:2.412 GHz Access Point: 00:1A:6C:3C:81:70
    Bit Rate:54 Mb/s Tx-Power=20 dBm Sensitivity=8/0
    Retry limit:7 RTS thr:off Fragment thr:off
    Encryption key:FC8E-9CA4-CD50-D1E0-A296-0D72-1B0F-3AA7-BCBC-B667-BA4D-104C-409A-7DF0-2FA4-F2C8 Security mode:open
    Power Management:off
    Link Quality=94/100 Signal level=-33 dBm Noise level=-87 dBm
    Rx invalid nwid:0 Rx invalid crypt:9 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:1
    linux-c3fb:~ # iwlist scan
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    eth1 Scan completed :
    Cell 01 - Address: 00:1A:6C:3C:81:70
    ESSID:"<hidden>"
    Protocol:IEEE 802.11bg
    Mode:Master
    Frequency:2.412 GHz (Channel 1)
    Encryption key:on
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
    11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
    48 Mb/s; 54 Mb/s
    Quality=93/100 Signal level=-34 dBm
    IE: IEEE 802.11i/WPA2 Version 1
    Group Cipher : CCMP
    Pairwise Ciphers (1) : CCMP
    Authentication Suites (1) : PSK
    Extra: Last beacon: 28ms ago
    Cell 02 - Address: 00:1A:6C:3C:79:B0
    ESSID:"<hidden>"
    Protocol:IEEE 802.11bg
    Mode:Master
    Frequency:2.437 GHz (Channel 6)
    Encryption key:on
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
    11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
    48 Mb/s; 54 Mb/s
    Quality=50/100 Signal level=-71 dBm
    IE: IEEE 802.11i/WPA2 Version 1
    Group Cipher : CCMP
    Pairwise Ciphers (1) : CCMP
    Authentication Suites (1) : PSK
    Extra: Last beacon: 128ms ago
    I have already added the WIRELESS_AP_SCANMODE='2' string, and I am connected wirelessly to the 00:1A:6C:3C:81:70 access point, but I cannot ping the outside network, nor do I get a response trying to ping the access point. I run the ping command on the access point and it simply stays there, sending and receiving nothing, not even working. I run the ping command on a website on the internet, and I get this:
    linux-c3fb:~ # ping 87.248.113.14
    connect: Network is unreachable
    Any help is greatly appreciated!

    Jay
    Last edited by bosox1304; 17-Oct-2008 at 05:18. Reason: Added more detail on ping.

  2. #2
    Menes Narmer NNTP User

    Default Re: No internet / no ping response ipw2200

    bosox1304 wrote:

    > Any help is greatly appreciated!


    It looks to me like you're connected the the WAP. What does your routing
    table look like?

    --
    Menes Narmer
    menesofmemphis [at] gmail [dot] com

    "Unity and humility is the lesson all of history teaches."

  3. #3

    Default Re: No internet / no ping response ipw2200

    Yeah, I am connected. It took almost a week of cruising the forums and a couple of SUSE reinstalls to get that far.

    Would this be the output you're asking for?
    linux-c3fb:~ # route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    192.168.9.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0 eth0
    FYI, I'm running openSUSE 11.0, KDE 4, my ipv6 is off, and I cannot change anything about the access point (it's one of my work networks).

    Thanks again!

    Jay

  4. #4
    Menes Narmer NNTP User

    Default Re: No internet / no ping response ipw2200

    bosox1304 wrote:

    >
    > Yeah, I am connected. It took almost a week of cruising the forums and a
    > couple of SUSE reinstalls to get that far.
    >
    > Would this be the output you're asking for?
    >> linux-c3fb:~ # route -n
    >> Kernel IP routing table
    >> Destination Gateway Genmask Flags Metric Ref Use
    >> Iface
    >> 192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0
    >> eth0
    >> 192.168.9.0 0.0.0.0 255.255.255.0 U 0 0 0
    >> eth1
    >> 169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0
    >> eth1
    >> 127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0
    >> lo
    >> 0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0
    >> eth0

    >
    > FYI, I'm running openSUSE 11.0, KDE 4, my ipv6 is off, and I cannot
    > change anything about the access point (it's one of my work networks).


    @Jay:

    Two strange things here, and one will probably be the fix.

    The first is that on eth1 you've got a route to the 169.254.0.0 network.
    IIRC, this is a network used by Windows machines for auto-assignment of IP
    addresses when a DHCP server could not be reached. This is just strange.

    The second is that your default gateway is associated with eth0, not eth1.
    So, anything bound for a network other than 192.168.2.0 or .9.0 will
    attempt to use the eth0 interface. If you're not jacked in, you won't get
    anywhere.

    The most likely solution is to change your gateway to something on the .9.0
    network (using your addressing scheme, probably .9.1). This is at least
    worth a try.

    HTH!

    --
    Menes Narmer
    menesofmemphis [at] gmail [dot] com

    "Unity and humility is the lesson all of history teaches."

  5. #5

    Default Re: No internet / no ping response ipw2200

    Well, now my n00b is showing...

    I used the terminal to work on the route - I was able to delete the offenders, but I am having a difficult time adding them. Could you kindly point out what I'm doing wrong?

    linux-c3fb:~ # route del -net 192.168.9.0 netmask 255.255.255.0 eth1
    linux-c3fb:~ # route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0 eth0
    linux-c3fb:~ # route add -net 192.168.9.1 netmask 255.255.255.0 eth1
    route: netmask doesn't match route address
    Usage: route [-nNvee] [-FC] [<AF>] List kernel routing tables
    route [-v] [-FC] {add|del|flush} ... Modify routing table for AF.

    route {-h|--help} [<AF>] Detailed usage syntax for specified AF.
    route {-V|--version} Display version/author and exit.

    -v, --verbose be verbose
    -n, --numeric don't resolve names
    -e, --extend display other/more information
    -F, --fib display Forwarding Information Base (default)
    -C, --cache display routing cache instead of FIB

    <AF>=Use '-A <af>' or '--<af>'; default: inet
    List of possible address families (which support routing):
    inet (DARPA Internet) inet6 (IPv6) ax25 (AMPR AX.25)
    netrom (AMPR NET/ROM) ipx (Novell IPX) ddp (Appletalk DDP)
    x25 (CCITT X.25)
    linux-c3fb:~ # route add -net 192.168.9.1 eth1
    SIOCADDRT: Invalid argument
    linux-c3fb:~ # route del -net 192.168.2.0 netmask 255.255.255.0 eth1
    SIOCDELRT: No such process
    linux-c3fb:~ # route del -net 169.254.0.0 netmask 255.255.0.0 eth1
    linux-c3fb:~ # route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0 eth0
    linux-c3fb:~ # route add -net 192.168.9.1 eth1
    SIOCADDRT: Invalid argument
    linux-c3fb:~ # route add -net 192.168.9.1 netmask 0.0.0.0 eth1
    SIOCADDRT: Invalid argument
    Thanks!

    Jay

  6. #6

    Default Re: No internet / no ping response ipw2200

    UPDATE!

    I decided to scrap my SUSE11 install and start out fresh. Now I'm on SUSE11 with KDE3.5, everything else remains the same. Odd thing is now I am pulling an IP and name servers have been applied, but I still cannot pull a webpage. I have no problem pinging other machines on the wireless network though. Here is my...

    ifstatus eth1
    Code:
    linux-r4ao:/home/nystec # ifstatus eth1
        eth1      device: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
        eth1      DHCP client (dhcpcd) is running
                  IPADDR='192.168.9.116'
                  NETMASK='255.255.255.0'
                  GATEWAYS='192.168.9.1'
                  HOSTNAME='linux-r4ao.nystec-rome.syrres.com'
                  DNSSERVERS='4.2.2.1 4.2.2.2'
                  REBINDTIME='6300'
                  DHCPCHADDR='00:16:6f:76:3d:09'
    eth1 is up
    3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
        link/ether 00:16:6f:76:3d:09 brd ff:ff:ff:ff:ff:ff
        inet 192.168.9.116/24 brd 192.168.9.255 scope global eth1
        eth1      IP address: 192.168.9.116/24
    Configured routes for interface eth1:
      169.254.0.0 - 255.255.0.0 eth1
    Active routes for interface eth1:
      192.168.9.0/24  proto kernel  scope link  src 192.168.9.116
      169.254.0.0/16  scope link
    1 of 1 configured routes for interface eth1 up
    bssid=00:1a:6c:3c:81:70
    ssid=Nystec WiFi
    id=0
    pairwise_cipher=TKIP
    group_cipher=TKIP
    key_mgmt=WPA-PSK
    wpa_state=COMPLETED
    ip_address=192.168.9.116
    ... and my route -n
    Code:
    linux-r4ao:/home/nystec # route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
    192.168.9.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
    169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth1
    127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
    0.0.0.0         192.168.2.1     0.0.0.0         UG    0      0        0 eth0
    To refresh, I am not using Knetworkmanager, I prefer the terminal method. However, as this is a learning experience for me, if I could get advice on both the terminal method and the GUI way I would appreciate it.

    As always, thanks in advance!

    Jay

  7. #7

    Default Re: No internet / no ping response ipw2200

    **UPDATE** (And this time a good one!)

    I am typing this using my wireless connection, which is great. Problem is, I'm not quite sure what exactly I did to enable it! My steps from the last post include clearing my routing table...

    Code:
    linux-r4ao:/ # route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.9.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
    169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth1
    127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
    0.0.0.0         192.168.9.1     0.0.0.0         UG    0      0        0 eth1
    ... and under YaST2 -> Network Settings -> Global Options -> DHCP Client Options enabling "Request Broadcast Response." Honestly, I'm not too sure what that means, but after an ifdown, my ifup reads this...

    Code:
    linux-r4ao:/ # ifup eth1
        eth1      device: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
        eth1      starting wpa_supplicant
    Starting DHCP Client Daemon on eth1... . . . . . . . . . . . . . . . no IP address yet... backgrounding.
    [
    ... I followed this with an ifstatus...
    Code:
    linux-r4ao:/ # ifstatus eth1
        eth1      device: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
        eth1      DHCP client NOT running
    eth1 is up
    3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
        link/ether 00:16:6f:76:3d:09 brd ff:ff:ff:ff:ff:ff
    bssid=00:1a:6c:3c:81:70
    ssid=Nystec WiFi
    id=0
    pairwise_cipher=TKIP
    group_cipher=TKIP
    key_mgmt=WPA-PSK
    wpa_state=COMPLETED
    ...Okay... that led me to run dhcpcd, followed by another ifstatus...

    Code:
    linux-r4ao:/ # ifstatus eth1
        eth1      device: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
        eth1      DHCP client (dhcpcd) is running
                  IPADDR='192.168.9.116'
                  NETMASK='255.255.255.0'
                  GATEWAYS='192.168.9.1'
                  HOSTNAME='linux-r4ao.nystec-rome.syrres.com'
                  DNSSERVERS='4.2.2.1 4.2.2.2'
                  REBINDTIME='6300'
                  DHCPCHADDR='00:16:6f:76:3d:09'
    eth1 is up
    3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
        link/ether 00:16:6f:76:3d:09 brd ff:ff:ff:ff:ff:ff
        inet 192.168.9.116/24 brd 192.168.9.255 scope global eth1
        eth1      IP address: 192.168.9.116/24
    Configured routes for interface eth1:
      169.254.0.0 - 255.255.0.0 eth1
    Active routes for interface eth1:
      192.168.9.0/24  proto kernel  scope link  src 192.168.9.116
      169.254.0.0/16  scope link
      default via 192.168.9.1
    1 of 1 configured routes for interface eth1 up
    bssid=00:1a:6c:3c:81:70
    ssid=Nystec WiFi
    id=0
    pairwise_cipher=TKIP
    group_cipher=TKIP
    key_mgmt=WPA-PSK
    wpa_state=COMPLETED
    ip_address=192.168.9.116
    ...Now, if we compare this to my ifstatus from the above post and..... it's the same thing! Odd. So my questions now are...

    1. Why did the changes have any affect on things?
    2. Is there any way I can set up for the dhcpcd command to be run immedeatly after the wireless connection is connected? It's somewhat of a pain to have to open the terminal, etc...

    Thanks!

    Jay

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •