Results 1 to 4 of 4

Thread: KGhostView Problems

  1. #1

    Default KGhostView Problems

    All of these people seem to be having the same or similar problems displaying postscript files in KGhostView. I'm not finding any satisfying solutions. Any ideas out there besides rolling back to ghostscript 7.07? Or maybe a thread containing the solution that I haven't found yet?

    postscript aspect ratio - openSUSE Forums
    Fonts In Ghostview Look Thin - openSUSE Forums
    PDF's stretched when viewing - openSUSE Forums
    Problems With Postscript - openSUSE Forums

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: KGhostView Problems

    One reason may be that the PDF or PS files were created using fonts for which the user does not have matching screen fonts on their system.

    I have occasionally had the problem with fancy PDFs downloaded from the Internet but they always print out correctly. I have not had any problems with PDF or PS files which have been created on my system.

  3. #3

    Default Re: KGhostView Problems

    Thanks for your comment John. The problem is that, for me at least, the same docs look fine in GV. I would think, naively, that GV and KGV use identical ghostscript routines and have access to the same fonts. Even PS that I create on my machine look f-ed up in KGV but fine in GV, as long as I use the "pixel-based" option. I guess I'll just have to simply abandon all use of KGV

  4. #4

    Default Re: KGhostView Problems

    I started having troubles getting fonts to look the right size in all of my programs at once so I went back and did it the right way. I found the answer in another forum. I had to edit the "DisplaySize" value in xorg.conf. I found my dot pitch value (0.259 mm) on Wikipedia's "Dot Pitch" page and changed my "DisplaySize" value to 331 207. This is the result of my screen res (1280x800) multiplied by the dot pitch. Apparently the automatically determined number in xorg.conf mistakenly multiplied the x-axis value by 2. Now I get 98x98 dpi instead of 49x98 - sweet!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •