Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: How to disable strigi?

  1. #1
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Question How to disable strigi?

    Suddenly (i.e. after updating all packages of my suse 10.3 (but not to 11.0)), my machine often shows a high load and a 1GB directory called .strigi appeared in my home directory.

    How do I get rid of that ****?

    I tried uninstalling with yast, but then it complained that lots of kde stuff was depending on it. I could not find relevant entries in the KDE Control Centre nor in Yast using the provided search tools. So how can I at least disable it and reclaim my cpu and disk resources?

    First the trouble with beagle, now strigi! This is a pain! I thought Linux was different than resource-wasting Windows forcing you to upgrade your hardware, but now it seems Linux got even with respect to that.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: How to disable strigi?

    p, li { white-space: pre-wrap; } strigi is a very fast crawling, very small memory footprint, no hammering of the system with pluggable backend desktop search engine.
    That's from the Package info

    If I select delete there is no issue for me.

    Perhaps post the conflicts

    When the conflict box pops up, use the expert button to save the errors to a file to paste here.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: How to disable strigi?

    Follow the given hints, since it'd be interesting to know what causes these conflicts.

    Yet there is an easy way to deactivate Strigi. Systemsettings → Advanced → Nepomuk.

  4. #4
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Question Re: How to disable strigi?

    Quote Originally Posted by gropiuskalle View Post
    Yet there is an easy way to deactivate Strigi. Systemsettings → Advanced → Nepomuk.
    ? I don't see a tab "Advanced" nor "Nepomuk", neither in Yast2 nor in the KDE Control Center.

    To clarify: I use Suse10.3 with KDE 3.5.10 "release 27.3".

    ---

    I can remove strigi itself without conflicts, but removing libstrigi0 causes the conflicts listed in the next post below (due to length). I am not aware of using any KDE4-stuff, though the conflicts strangely seem KDE4-related

    Is it enough to remove the strigi package and leave libstrigi0 as it is? (I recall in order to get rid of Kerry/Beagle one had to remove the libraries as well.)

    ---

    And yes, everything new promises to be lightweight and faster, yet it never is. Maybe it is faster on modern hardware, but I am talking about old single core machines (700Mhz Desktop and 1.8GHz Notebook).

  5. #5
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Default Re: How to disable strigi?

    I cut some lines to make it fit here:
    Code:
    #### YaST2 conflicts list - generated 2008-10-16 10:40:39 ####
    
    kde4-krdc has missing dependencies
        There are no alternative providers of libstreams.so.0 installed for kde4-krdc-4.0.4-19.61.i586
        === kde4-krdc-4.0.4-19.61.i586 ===
            libstrigi0-0.5.9-12.27.i586 provides libstreams.so.0, but is scheduled to be uninstalled.
            strigi-0.5.5-20.i586[openSUSE-10.3-FTP_10.3] provides libstreams.so.0, but it is not installable.  Try installing it on its own for more details.
            kde4-krdc-4.0.4-19.61.i586 depends on libstrigi0
            kde4-krdc-4.0.4-19.61.i586 is lacking the requirement libstreamanalyzer.so.0
        (null)
        Conflict Resolution:
            ( ) keep libstrigi0
            ( ) delete kde4-krdc
            ( ) Ignore this requirement just here
            ( ) Generally ignore this requirement
    kde4-krfb has missing dependencies
        There are no alternative providers of kdebase4-runtime < 4.0.60 installed for kde4-krfb-4.0.4-19.61.i586
        === kde4-krfb-4.0.4-19.61.i586 ===
            kdebase4-runtime-4.0.4-26.31.i586 provides kdebase4-runtime == 4.0.4-26.31, but is scheduled to be uninstalled.
            kdebase4-runtime-3.93.0.svn712052-11.i586[openSUSE-10.3-FTP_10.3] provides kdebase4-runtime == 3.93.0.svn712052-11, but it is not installable.  Try installing it on its own for more details.
            kde4-krfb-4.0.4-19.61.i586 depends on libkde4
            kde4-krfb-4.0.4-19.61.i586 is lacking the requirement libkdeui.so.5
        (null)
        Conflict Resolution:
            ( ) keep kdebase4-runtime
            ( ) delete kde4-krfb
            ( ) Ignore this requirement just here
            ( ) Generally ignore this requirement
    kdebase4-runtime has missing dependencies
        There are no alternative providers of libstrigiqtdbusclient.so.0 installed for kdebase4-runtime-4.0.4-26.31.i586
        === kdebase4-runtime-4.0.4-26.31.i586 ===
            libstrigi0-0.5.9-12.27.i586 provides libstrigiqtdbusclient.so.0, but is scheduled to be uninstalled.
            strigi-0.5.5-20.i586[openSUSE-10.3-FTP_10.3] provides libstrigiqtdbusclient.so.0, but it is not installable.  Try installing it on its own for more details.
            kdebase4-runtime-4.0.4-26.31.i586 depends on libstrigi0
            kdebase4-runtime-4.0.4-26.31.i586 is lacking the requirement libstreamanalyzer.so.0
            There are no alternative providers of libkmediaplayer.so.4 installed for kdebase4-runtime-4.0.4-26.31.i586
        (null)
        Conflict Resolution:
            ( ) keep libstrigi0
            ( ) delete kdebase4-runtime
            ( ) Ignore this requirement just here
            ( ) Generally ignore this requirement
    kdelibs4-core has missing dependencies
        There are no alternative providers of libkjs.so.4 installed for kdelibs4-core-4.0.4-33.13.i586
        === kdelibs4-core-4.0.4-33.13.i586 ===
            libkde4-4.0.4-33.13.i586 provides libkjs.so.4, but is scheduled to be uninstalled.
            libkde4-3.93.0.svn712047-6.i586[openSUSE-10.3-FTP_10.3] provides libkjs.so.4, but it is not installable.  Try installing it on its own for more details.
            kdelibs4-core-4.0.4-33.13.i586 depends on libkde4
            kdelibs4-core-4.0.4-33.13.i586 is lacking the requirement libkjs.so.4
        (null)
        Conflict Resolution:
            ( ) keep libkde4
            ( ) delete kdelibs4-core
            ( ) Ignore this requirement just here
            ( ) Generally ignore this requirement
    kdelibs4 has missing dependencies
        There are no alternative providers of libstrigi0 >= 0.5.9 installed for kdelibs4-4.0.4-33.13.i586
        === kdelibs4-4.0.4-33.13.i586 ===
            libstrigi0-0.5.9-12.27.i586 provides libstrigi0 == 0.5.9-12.27, but is scheduled to be uninstalled.
            libstrigi0-0.5.9-12.27.i586[KDE4_Core] provides libstrigi0 == 0.5.9-12.27, but it is not installable.  Try installing it on its own for more details.
            kdelibs4-4.0.4-33.13.i586 depends on libstrigi0
            kdelibs4-4.0.4-33.13.i586 is lacking the requirement libstreamanalyzer.so.0
        (null)
        Conflict Resolution:
            ( ) keep libstrigi0
            ( ) delete kdelibs4
            ( ) Ignore this requirement just here
            ( ) Generally ignore this requirement
    kdepimlibs4 has missing dependencies
        There are no alternative providers of libstreams.so.0 installed for kdepimlibs4-4.0.98-1.19.i586
        === kdepimlibs4-4.0.98-1.19.i586 ===
            libstrigi0-0.5.9-12.27.i586 provides libstreams.so.0, but is scheduled to be uninstalled.
            strigi-0.5.5-20.i586[openSUSE-10.3-FTP_10.3] provides libstreams.so.0, but it is not installable.  Try installing it on its own for more details.
            kdepimlibs4-4.0.98-1.19.i586 depends on libstrigi0
            kdepimlibs4-4.0.98-1.19.i586 is lacking the requirement libstreamanalyzer.so.0
        (null)
        Conflict Resolution:
            ( ) keep libstrigi0
            ( ) delete kdepimlibs4
            ( ) Ignore this requirement just here
            ( ) Generally ignore this requirement
    kio_iso has missing dependencies
        There are no alternative providers of libstreams.so.0 installed for kio_iso-1.99.1-1.3.i586
        === kio_iso-1.99.1-1.3.i586 ===
            libstrigi0-0.5.9-12.27.i586 provides libstreams.so.0, but is scheduled to be uninstalled.
            strigi-0.5.5-20.i586[openSUSE-10.3-FTP_10.3] provides libstreams.so.0, but it is not installable.  Try installing it on its own for more details.
            kio_iso-1.99.1-1.3.i586 depends on libstrigi0
            kio_iso-1.99.1-1.3.i586 is lacking the requirement libstreamanalyzer.so.0
        (null)
    ktorrent has missing dependencies
        There are no alternative providers of libstreams.so.0 installed for ktorrent-3.1.3-3.4.i586
        === ktorrent-3.1.3-3.4.i586 ===
            libstrigi0-0.5.9-12.27.i586 provides libstreams.so.0, but is scheduled to be uninstalled.
            strigi-0.5.5-20.i586[openSUSE-10.3-FTP_10.3] provides libstreams.so.0, but it is not installable.  Try installing it on its own for more details.
            ktorrent-3.1.3-3.4.i586 depends on libstrigi0
            ktorrent-3.1.3-3.4.i586 is lacking the requirement libstreamanalyzer.so.0
            ktorrent-2.2.7-0.pm.3.i586[http://ftp.skynet.be/pub/packman/suse/10.3/] provides ktorrent == 2.2.7-0.pm.3, but has another vendor ().
        (null)
    ktorrent-lang has missing dependencies
        There are no alternative providers of ktorrent == 3.1.3 installed for ktorrent-lang-3.1.3-3.4.i586
        === ktorrent-lang-3.1.3-3.4.i586 ===
            ktorrent-3.1.3-3.4.i586 provides ktorrent == 3.1.3-3.4, but is scheduled to be uninstalled.
            ktorrent-3.1.3-3.4.i586[KDE4_Extra] provides ktorrent == 3.1.3-3.4, but it is not installable.  Try installing it on its own for more details.
            ktorrent-lang-3.1.3-3.4.i586 depends on ktorrent
            ktorrent-lang-3.1.3-3.4.i586 is lacking the requirement ktorrent == 3.1.3
        (null)
    libakonadi4 has missing dependencies
        There are no alternative providers of libstreams.so.0 installed for libakonadi4-4.0.98-1.19.i586
        === libakonadi4-4.0.98-1.19.i586 ===
            libstrigi0-0.5.9-12.27.i586 provides libstreams.so.0, but is scheduled to be uninstalled.
            strigi-0.5.5-20.i586[openSUSE-10.3-FTP_10.3] provides libstreams.so.0, but it is not installable.  Try installing it on its own for more details.
            libakonadi4-4.0.98-1.19.i586 depends on libstrigi0
            libakonadi4-4.0.98-1.19.i586 is lacking the requirement libstreamanalyzer.so.0
            There are no alternative providers of libkparts.so.4 installed for libakonadi4-4.0.98-1.19.i586
        (null)
    libkde4 has missing dependencies
        There are no alternative providers of libstreams.so.0 installed for libkde4-4.0.4-33.13.i586
        === libkde4-4.0.4-33.13.i586 ===
            libstrigi0-0.5.9-12.27.i586 provides libstreams.so.0, but is scheduled to be uninstalled.
            strigi-0.5.5-20.i586[openSUSE-10.3-FTP_10.3] provides libstreams.so.0, but it is not installable.  Try installing it on its own for more details.
            libkde4-4.0.4-33.13.i586 depends on libstrigi0
            libkde4-4.0.4-33.13.i586 is lacking the requirement libstreamanalyzer.so.0
        (null)
    libkdepimlibs4 has missing dependencies
        There are no alternative providers of libstreams.so.0 installed for libkdepimlibs4-4.0.98-1.19.i586
        === libkdepimlibs4-4.0.98-1.19.i586 ===
            libstrigi0-0.5.9-12.27.i586 provides libstreams.so.0, but is scheduled to be uninstalled.
            strigi-0.5.5-20.i586[openSUSE-10.3-FTP_10.3] provides libstreams.so.0, but it is not installable.  Try installing it on its own for more details.
            libkdepimlibs4-4.0.98-1.19.i586 depends on libstrigi0
            libkdepimlibs4-4.0.98-1.19.i586 is lacking the requirement libstreamanalyzer.so.0
        (null)
    pattern:kde_internet has missing dependencies
        There are no alternative providers of ktorrent installed for pattern:kde_internet-10.3-159.i586
        === pattern:kde_internet-10.3-159.i586 ===
            ktorrent-3.1.3-3.4.i586 provides ktorrent == 3.1.3-3.4, but is scheduled to be uninstalled.
            ktorrent-2.2.1-32.i586[openSUSE-10.3-FTP_10.3] provides ktorrent == 2.2.1-32, but has another architecture.
            ktorrent-3.1.3-3.4.i586[KDE4_Extra] provides ktorrent == 3.1.3-3.4, but it is not installable.  Try installing it on its own for more details.
            pattern:kde_internet-10.3-159.i586 depends on ktorrent
            pattern:kde_internet-10.3-159.i586 is lacking the requirement ktorrent
        (null)
    #### YaST2 conflicts list END ###

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: How to disable strigi?

    To clarify: I use Suse10.3 with KDE 3.5.10 "release 27.3".
    So tell us what repo's you have:

    zypper lr
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Default Re: How to disable strigi?

    Only community repositories, i.e.:

    ATI, Main (Non-OSS), Main (OSS), Main Update, Packman, VideoLan, Driver for Webcams, KDE:Backports, KDE:Community, Mozilla, and OpenOffice.org


    Anyway, removing the "strigi" package was apparently enough to disable it. Thanks!

  8. #8
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: How to disable strigi?

    Well, I was talking about KDE4, in its systemsettings you could modify these settings as described.

    Hit Alt + F2 and "systemsettings", does some kinda settings-module pop up?

  9. #9
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Default Re: How to disable strigi?

    Ah ok, good to know how this will work in KDE4.

    No the command "systemsettings" is not available, not even as root.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,726
    Blog Entries
    20

    Default Re: How to disable strigi?

    kde4
    config desktop - advanced tab - Nepomuk

    edit: sorry your kde3! lol

    just tell us what your repo's are
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •