Results 1 to 7 of 7

Thread: Problem with openSuse updater

Hybrid View

  1. #1
    sm7urw NNTP User

    Default Problem with openSuse updater

    Hi!
    As the openSUSE updater runs, it finds many new updates (too many?) I get the following error;

    mktemp: cannot make temp dir /tmp/opensuseupdaterHCOLDU49961: too many links

    Why is this? The updater just quits and no new software packages are installed.

  2. #2
    Join Date
    Sep 2008
    Location
    Slovenia
    Posts
    335

    Default Re: Problem with openSuse updater

    It may be, that you are running out of free space on the disk

  3. #3
    sm7urw NNTP User

    Default Re: Problem with openSuse updater

    Thanks for your reply! I thought so too, but it turns out that I have 6.7 GB free on the volume mounted as /

    Even stranger is the fact that basically no program whatsoever seems to start when I run KDE and click on the menu or icons. This puzzle me alot...

    Any more suggestions?

  4. #4
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Problem with openSuse updater

    Is your file system maybe mount as read-only? You can check that using the mount command - the root / should state rw and not ro.

    What is your partition layout? If you like, post the output of mount so we can see what's listed.

    Also, can you create and delete a file in the /tmp dir?
    If so, you could try clearing out all files in /tmp and rebooting

    as root (take care with this command not to remove something you don't want to!):
    rm -Rf /tmp/*
    rm -Rf /tmp/.*

    and reboot...
    Have a lot of fun!

  5. #5
    sm7urw NNTP User

    Default Re: Problem with openSuse updater

    Hi!

    No, it seems as if the / is mounted as rw. This is the layout;

    /dev/sda2 on / type ext3 (rw,acl,user_xattr)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    debugfs on /sys/kernel/debug type debugfs (rw)
    udev on /dev type tmpfs (rw)
    devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
    /dev/sda3 on /home type ext3 (rw,acl,user_xattr,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0)
    securityfs on /sys/kernel/security type securityfs (rw)

    Here is a clue; When i run rm -Rf /tmp/* I get the followin error

    -bash: /bin/rm: Argument list too long

    (the tmp folder is filled with files such as YaST2-32767-SW1uUX and so on. It seems as if YAST is creating an enormous amount of files the whole time it is downloading new updates..?! process y2base also changes PID all the time. Im trying to kill it..)

  6. #6
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Problem with openSuse updater

    You could try renaming the tmp directory and recreating one with the same rights set and then reboot.

    Also might be time to fschk your filesystem to be sure. You might wanna backup any important data before doing so!

    before rebooting have a look at the output dmesg gives you to see if there are disk or other hw errors reported.
    Have a lot of fun!

  7. #7
    sm7urw NNTP User

    Default Re: Problem with openSuse updater

    I dont know how, but I managed to solve the problem. What I did was basiclly the following;

    - I rebooted the machine and made sure that the updater/yast2 process didn't restart.
    - I removed all the yast2-folders in the /tmp folder.
    - I did run a update to make sure that the same thing didn't happen again, and it worked.

    However I still dont really understand why the yast2 process just went wild. There was a new process started every few seconds, which caused the application hang and creation of thousands of /tmp/yast2_* -folders.

    Thanks for all the support!

    Cheers!

    // H

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •