Results 1 to 10 of 10

Thread: HP laserjet 1020 install

  1. #1
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default HP laserjet 1020 install

    Hi all,

    trying to figure out how to get my laserjet 1020 working.

    Tried the cups localhost server, it does get listed, but doesn't work.

    Any help would be greatly appreciated,

    Thanks

    Heeter
    Linux Counter 475994

  2. #2
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    32,947
    Blog Entries
    15

    Default Re: HP laserjet 1020 install

    Quote Originally Posted by Heeter View Post
    Hi all,

    trying to figure out how to get my laserjet 1020 working.

    Tried the cups localhost server, it does get listed, but doesn't work.

    Any help would be greatly appreciated,

    Thanks

    Heeter
    Hi
    For HP printers/scanners I've normally installed hplip via YaST or
    zypper and then as root user run hp-setup. Then use hp-toolbox to
    control, never used YaST.

    HP Linux Imaging
    and Printing


    --
    Cheers
    Malcolm

  3. #3
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default Re: HP laserjet 1020 install

    Great will try that.


    Thanks for the heads up,

    Heeter
    Linux Counter 475994

  4. #4
    Join Date
    Jun 2008
    Location
    Alberta, Canada
    Posts
    457

    Default Re: HP laserjet 1020 install

    Hi MalcomLewis

    It worked like a charm,

    Thanks

    Heeter
    Linux Counter 475994

  5. #5
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,621

    Default Re: HP laserjet 1020 install

    Quote Originally Posted by malcolmlewis View Post
    Hi
    For HP printers/scanners I've normally installed hplip via YaST or
    zypper and then as root user run hp-setup. Then use hp-toolbox to
    control, never used YaST.
    Whereas I have simply accepted the default in YaST and never bothered with hp-setup or hp-toolbox and never had a problem.

  6. #6
    Join Date
    Jun 2008
    Location
    New Zealand
    Posts
    78

    Default Re: HP laserjet 1020 install

    Whereas I have simply accepted the default in YaST and never bothered with hp-setup or hp-toolbox and never had a problem.
    Is that with an HP1020 though? For me, Yast generates a message saying this type of printer is not supported directly.

    I was using the foo2zjs driver, which worked well.

    However thanks to this post, I've jumped ship to the HPLIP driver which works just as well.
    BZFlag: good clean fun. Sorta.

  7. #7
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,621

    Default Re: HP laserjet 1020 install

    Not tried it with the HP1020 but I made the comment because I see so many posts about people downloading extra things for HP printers when I have never had to.

    But then I have never had a YaST message saying I needed something more either.

  8. #8

    Default Re: HP laserjet 1020 install

    I can this working hp 1020 driver. where for linux?

  9. #9
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,621

    Default Re: HP laserjet 1020 install

    hplip from YaST if you haven't already got it installed.

  10. #10
    Join Date
    Sep 2010
    Location
    Antananarivo, Madagascar
    Posts
    110

    Default Re: HP laserjet 1020 install

    Quote Originally Posted by malcolmlewis View Post
    Hi
    For HP printers/scanners I've normally installed hplip via YaST or
    zypper and then as root user run hp-setup. Then use hp-toolbox to
    control, never used YaST.

    HP Linux Imaging
    and Printing


    --
    Cheers
    Malcolm
    Please SUSE! Dont be like some other women I know!

    11.4 KDE out of the box

    I followed the above instructions
    My HP 1020 gets detected and then when I click on next
    to do
    Code:
    Download and install the plug-in from an HP  authorized server (recommended)
    I get an error message

    Code:
    ERROR: Plug-in file does not match its digital signature.
    File may have been corrupted or altered.
    Error code: 2
    and then when I click

    Code:
    The printer you are trying to setup requires a binary driver plug-in and it failed to install.
    Please check your internet connection and try again.
    Visit http://hplipopensource.com for more infomation.
    Please help! I am considering XP again after a long and happy time on 11.3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •