Hello to all .. im having a big problem here..
I'm Using OpenSUSE 11.0 x86_64

I'm trying to compile a server of ragnarok the server have the option to run under txt database or MySql .. I try the server on OpenSUSE 11.0 i386 and I dont have any problem at all.

but here on x86_64 the server just dont pick up Mysql x86_64

here it's the outputs

./configure

oni@linux-oni:~/RO/stable> ./configure
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking whether byte ordering is bigendian... no
checking whether pointers can be stored in ints (old code)... yes (with -m32)
checking whether gcc supports -Wno-unused-parameter... yes
checking whether gcc supports -Wno-pointer-sign... yes
checking whether gcc supports -Wno-switch... yes
checking for setrlimit... yes
checking for inflateEnd in -lz... yes
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
checking for sqrt in -lm... yes
checking for clock_gettime in -lrt... yes
checking for mysql_config... /usr/bin/mysql_config
checking for mysql_init in -lmysqlclient... no
checking mysql.h usability... yes
checking mysql.h presence... yes
checking for mysql.h... yes
checking MySQL library (optional)... no
configure: disabling MySQL (optional)
checking for pcre_study in -lpcre... no
checking PCRE library (optional)... no
configure: disabling PCRE (optional)
checking host OS... Linux
checking for MinGW... no
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/common/Makefile
config.status: creating src/char/Makefile
config.status: creating src/login/Makefile
config.status: creating src/ladmin/Makefile
config.status: creating src/char_sql/Makefile
config.status: creating src/login_sql/Makefile
config.status: creating src/txt-converter/Makefile
config.status: creating src/map/Makefile
config.status: creating src/plugins/Makefile
config.status: creating src/tool/Makefile
oni@linux-oni:~/RO/stable>
make sql
oni@linux-oni:~/RO/stable> make sql
MySQL not found or disabled by the configure script
make: *** [needs_mysql] Error 1
any one have an idea how can fix this???

i guess the problem is that the configure it's looking for the file of Sql on other directory.
im not an expert .. but i will try everything possible here.

thanks a lot.
if need more info just tell me.

thanks.