Results 1 to 5 of 5

Thread: rpmlib(PayloadIsLzma) revisited

  1. #1

    Default rpmlib(PayloadIsLzma) revisited

    Greetings

    The problem related to rpm packages and compressing using lzma is reported by many, and has also receieved some suggestions to solution. It looks like it is a generic problem since the same dependency problem is reported on several different install packages.

    I'm however still stuck. I'm installing the latest vym packages on my OpenSuSE 10.2 (2.6.18.8-0.10-default) like this:

    # rpm -Uhv -P ./vym-1.12.0.i586.rpm
    error: Failed dependencies:
    rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by vym-1.12.0-5.1.i586

    (Proposed by carboncore in openSUSE Forums - View Single Post - upgrade RPM)

    # rpm -qp vym-1.12.0.i586.rpm --requires
    zip
    unzip
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(CompressedFileNames) <= 3.0.4-1
    /bin/bash
    /usr/bin/perl
    libICE.so.6
    libQt3Support.so.4
    libQtCore.so.4
    libQtGui.so.4
    libQtNetwork.so.4
    libQtSql.so.4
    libQtXml.so.4
    libSM.so.6
    libX11.so.6
    libXcursor.so.1
    libXext.so.6
    libXfixes.so.3
    libXi.so.6
    libXinerama.so.1
    libXrandr.so.2
    libXrender.so.1
    libc.so.6
    libc.so.6(GLIBC_2.0)
    libc.so.6(GLIBC_2.1.3)
    libc.so.6(GLIBC_2.2)
    libdl.so.2
    libfontconfig.so.1
    libfreetype.so.6
    libgcc_s.so.1
    libgcc_s.so.1(GCC_3.0)
    libm.so.6
    libm.so.6(GLIBC_2.0)
    libpng12.so.0
    libpthread.so.0
    libpthread.so.0(GLIBC_2.0)
    librt.so.1
    libstdc++.so.6
    libstdc++.so.6(CXXABI_1.3)
    libstdc++.so.6(GLIBCXX_3.4)
    libz.so.1
    rpmlib(PayloadIsLzma) <= 4.4.2-1

    And I do have lzma installed:

    # rpm -qa|grep -i lzma
    lzma-devel-4.32.5-0.pm.1
    lzma-4.32.5-0.pm.1
    liblzmadec0-4.32.5-0.pm.1

    Using Yast I it looks to me that I have the latest available rpm packages available for 10.2. My rpm package looks like this.

    # rpm -qa|grep -i rpm
    deltarpm-3.3-31
    rpm-python-4.4.2-76
    rpm-4.4.2-76

    So, what am I missing to get the vym packages installed?

    Any comments or suggestions are welcome.

    Ragards,
    Durque

  2. #2

    Question Re: rpmlib(PayloadIsLzma) revisited

    Greetings

    Was this one to tricky to comment? Let me try to refrase.

    * Do I have to upgrade rpm package manager or Yast or both?

    * Are there upgrades available for OpenSuSE 10.2 or do I have to upgrade the entire system to OpenSuSE 11 to solve this issue?

    I'm currently at:
    $ rpm --version
    RPM version 4.4.2

    Regards,
    Durque

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: rpmlib(PayloadIsLzma) revisited

    I don't have an answer for you but since 10.2 is going out of support soon, maybe you should consider upgrading the OS.

  4. #4

    Default Re: rpmlib(PayloadIsLzma) revisited

    Thanxs

    Not exactly what I hoped for, but not unexpected.
    Is 10.2 -> 11.0 a smooth ride or is a complete cold install
    the only (best) way to go?

    Regards,
    Durque

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: rpmlib(PayloadIsLzma) revisited

    I would not be game to update 2 versions in one go unless I had very limited physical access to the machine and time later to patch things up by remote login.

    Sometimes I do a 1 version update but there are usually some things to fix up, packages that have been obsoleted, new functionality that needs to be adapted to.

    So unless you feel confident about being able to deal with the mismatch, I would say, as would most others, backup your personal files and take a snapshot of the system config (mostly in /etc) for reference and do a fresh install, then restore your home directory. If /home is a separate partition, you won't even need to restore. Don't forget any data outside /home, like crontabs and databases (e.g. MySQL).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •