Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: klamav not compatible with new clamav

  1. #1
    Join Date
    Jun 2008
    Location
    tehran
    Posts
    180

    Default klamav not compatible with new clamav

    hi
    i just upgraded klamav in opensuse repositories and it doesnt work and it says somethins about a missing lib

    the previous version worked finbe

    and i couldn't compile the new version
    had anybody got the new version working?

  2. #2
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: klamav not compatible with new clamav

    uninstall the old & then install the new,see if that works

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: klamav not compatible with new clamav

    When I have used it in the past from the update of Clam usually comes before Klam
    Just wait a week or so and you should be able to update them both. This assumes you are installing from .rpm's in the repo's.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Jun 2008
    Location
    tehran
    Posts
    180

    Default Re: klamav not compatible with new clamav

    Quote Originally Posted by deltaflyer44 View Post
    uninstall the old & then install the new,see if that works

    Andy
    no it didn't help

  5. #5
    Join Date
    Jun 2008
    Location
    tehran
    Posts
    180

    Default Re: klamav not compatible with new clamav

    Quote Originally Posted by caf4926 View Post
    When I have used it in the past from the update of Clam usually comes before Klam
    Just wait a week or so and you should be able to update them both. This assumes you are installing from .rpm's in the repo's.
    its more than two weeks now and in its website its source is supposed to be compatible with clamav0.9x but i cat compile it

  6. #6
    Join Date
    Jun 2008
    Location
    PHX
    Posts
    481

    Default Re: klamav not compatible with new clamav

    Quote Originally Posted by rd1381 View Post
    hi
    i just upgraded klamav in opensuse repositories and it doesnt work and it says somethins about a missing lib
    Post the compiling error msg and missing library.
    <>---><^>

  7. #7
    Join Date
    Jun 2008
    Location
    tehran
    Posts
    180

    Default Re: klamav not compatible with new clamav

    if gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I/opt/kde3/include -I/usr/lib/qt3/include -I. -DQT_THREAD_SUPPORT -D_REENTRANT -O2 -MT clamdmail.o -MD -MP -MF ".deps/clamdmail.Tpo" -c -o clamdmail.o clamdmail.c; \
    then mv -f ".deps/clamdmail.Tpo" ".deps/clamdmail.Po"; else rm -f ".deps/clamdmail.Tpo"; exit 1; fi
    clamdmail.c: In function ‘clamdscan’:
    clamdmail.c:163: error: ‘CL_EFSYNC’ undeclared (first use in this function)
    clamdmail.c:163: error: (Each undeclared identifier is reported only once
    clamdmail.c:163: error: for each function it appears in.)
    make[3]: *** [clamdmail.o] Error 1

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,249
    Blog Entries
    15

    Default Re: klamav not compatible with new clamav

    Quote Originally Posted by rd1381
    if gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I/opt/kde3/include
    -I/usr/lib/qt3/include -I. -DQT_THREAD_SUPPORT -D_REENTRANT -O2
    -MT clamdmail.o -MD -MP -MF ".deps/clamdmail.Tpo" -c -o clamdmail.o
    clamdmail.c; \
    then mv -f ".deps/clamdmail.Tpo" ".deps/clamdmail.Po"; else rm
    -f ".deps/clamdmail.Tpo"; exit 1; fi
    clamdmail.c: In function ‘clamdscan’:
    clamdmail.c:163: error: ‘CL_EFSYNC’ undeclared (first use
    in this function)
    clamdmail.c:163: error: (Each undeclared identifier is reported only
    once
    clamdmail.c:163: error: for each function it appears in.)
    make[3]: *** [clamdmail.o] Error 1

    Hi
    You could try the klamav 0.44 version here?
    http://download.opensuse.org/reposit...openSUSE_11.0/

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 10:41, 1 user, load average: 0.32, 0.22, 0.25
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  9. #9
    Join Date
    Jun 2008
    Location
    tehran
    Posts
    180

    Default Re: klamav not compatible with new clamav

    Quote Originally Posted by malcolmlewis View Post
    Hi
    You could try the klamav 0.44 version here?
    Index of /repositories/home:/benstein/openSUSE_11.0

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 10:41, 1 user, load average: 0.32, 0.22, 0.25
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

    if you look i said that i tried the new version in yast repositories

    that is the version you suggest witch is not compatible with clamav new version

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,249
    Blog Entries
    15

    Default Re: klamav not compatible with new clamav

    Quote Originally Posted by rd1381
    malcolmlewis;1879446 Wrote:
    > Hi
    > You could try the klamav 0.44 version here?
    > 'Index of /repositories/home:/benstein/openSUSE_11.0'
    > (http://tinyurl.com/49go4x)

    49go4x ->
    http://download.opensuse.org/reposit...openSUSE_11.0/
    >


    if you look i said that i tried the new version in yast repositories

    that is the version you suggest witch is not compatible with clamav new
    version
    Hi
    Hmmm, the src rpm builds fine here...?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 2:46, 2 users, load average: 1.13, 0.69, 0.31
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •