Results 1 to 9 of 9

Thread: Error 'Null' Window at login & startup

  1. #1

    Question Error 'Null' Window at login & startup

    Hi everyone. Linux noob here. I have been doing some fiddling with the disk drives and installing and removing software getting the hang of all this, but now (can't pinpoint exactly what I was doing when it first happen) every time I login I get this window message messagebox that only says: 'NULL' and a big red sign on it and an 'OK' button to proceed. I click on it and absolutely nothing else happens. Everything works and its as if no error window ever popped up. What is going on here?
    Where can I check what is causing this messagebox to appear. Is there a boot or startup log? Any help is greatly appreciated!
    -M

  2. #2
    Join Date
    Oct 2008
    Location
    Choctaw, OK
    Posts
    66

    Default Re: Error 'Null' Window at login & startup

    Well, what comes to mind is looking at your ~/.xsession-errors file. I'm wondering if perhaps some of your default settings got changed or erased, such as your LANG variable or something. You can always run the 'env' command from the terminal, but I'm pretty sure the resulting spew of lines would seem overwhelming to a noob.
    Ed Hurst
    Open for Business (ofb.biz)

  3. #3

    Default Re: Error 'Null' Window at login & startup

    post:

    Wow. Ok. Lots of info from both of those suggestions. I guess with the info that I have on the error it's going to be hard to pinpoint where it popping up. I am going to post both of the outputs anyway with the hope that an expert eye can spot something.

    Code:
    chepolinux:/home/chepoxxx # env
    LESSKEY=/etc/lesskey.bin
    MANPATH=/usr/local/man:/usr/share/man
    NNTPSERVER=news
    INFODIR=/usr/local/info:/usr/share/info:/usr/info
    HOSTNAME=chepolinux
    XKEYSYMDB=/usr/share/X11/XKeysymDB
    DESKTOP_STARTUP_ID=
    HOST=chepolinux
    TERM=xterm
    SHELL=/bin/bash
    PROFILEREAD=true
    XDG_SESSION_COOKIE=1fc20e05305a3e5d1a1fd32a484e714c-1223107230.851350-1535636360
    HISTSIZE=1000
    GTK_RC_FILES=/etc/gtk/gtkrc:/home/chepoxxx/.gtkrc-1.2-gnome2
    WINDOWID=54526030
    MORE=-sl
    XSESSION_IS_UP=yes
    GTK_MODULES=gnomebreakpad
    JRE_HOME=/usr/lib/jvm/jre
    GROFF_NO_SGR=yes
    USER=chepoxxx
    DESKTOP_LAUNCH=gnome-open
    LS_COLORS=no=00:fi=00:di=01;34:ln=00;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=41;33;01:ex=00;32:*.cmd=00;32:*.exe=01;32:*.com=01;32:*.bat=01;32:*.btm=01;32:*.dll=01;32:*.tar=00;31:*.tbz=00;31:*.tgz=00;31:*.rpm=00;31:*.deb=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.lzma=00;31:*.zip=00;31:*.zoo=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.tb2=00;31:*.tz2=00;31:*.tbz2=00;31:*.avi=01;35:*.bmp=01;35:*.fli=01;35:*.gif=01;35:*.jpg=01;35:*.jpeg=01;35:*.mng=01;35:*.mov=01;35:*.mpg=01;35:*.pcx=01;35:*.pbm=01;35:*.pgm=01;35:*.png=01;35:*.ppm=01;35:*.tga=01;35:*.tif=01;35:*.xbm=01;35:*.xpm=01;35:*.dl=01;35:*.gl=01;35:*.wmv=01;35:*.aiff=00;32:*.au=00;32:*.mid=00;32:*.mp3=00;32:*.ogg=00;32:*.voc=00;32:*.wav=00;32:
    XNLSPATH=/usr/share/X11/nls
    ENV=/etc/bash.bashrc
    HOSTTYPE=i386
    SSH_AUTH_SOCK=/tmp/keyring-MwejCb/ssh
    GNOME_KEYRING_SOCKET=/tmp/keyring-MwejCb/socket
    FROM_HEADER=
    USERNAME=chepoxxx
    SESSION_MANAGER=local/chepolinux:@/tmp/.ICE-unix/4995,unix/chepolinux:/tmp/.ICE-unix/4995
    PAGER=less
    CSHEDIT=emacs
    XDG_CONFIG_DIRS=/etc/alacarte_system:/etc/xdg
    MINICOM=-c on
    DESKTOP_SESSION=gnome
    PATH=/home/chepoxxx/bin:/usr/local/bin:/usr/bin:/sbin:/usr/sbin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin
    MAIL=/var/spool/mail/chepoxxx
    CPU=i686
    JAVA_BINDIR=/usr/lib/jvm/jre/bin
    GDM_XSERVER_LOCATION=local
    PWD=/home/chepoxxx
    INPUTRC=/home/chepoxxx/.inputrc
    XMODIFIERS=@im=local
    JAVA_HOME=/usr/lib/jvm/jre
    GNOME_KEYRING_PID=4992
    LANG=en_US.UTF-8
    PYTHONSTARTUP=/etc/pythonstart
    GDMSESSION=gnome
    ICEAUTHORITY=/home/chepoxxx/.ICEauthority
    TEXINPUTS=:/home/chepoxxx/.TeX:/usr/share/doc/.TeX:/usr/doc/.TeX
    HOME=/root
    QT_SYSTEM_DIR=/usr/share/desktop-data
    SHLVL=2
    ALSA_CONFIG_PATH=/etc/alsa-pulse.conf
    OSTYPE=linux
    LESS_ADVANCED_PREPROCESSOR=no
    SDL_AUDIODRIVER=pulse
    XCURSOR_THEME=DMZ
    GNOME_DESKTOP_SESSION_ID=Default
    LS_OPTIONS=-A -N --color=tty -T 0
    WINDOWMANAGER=/usr/bin/gnome
    MACHTYPE=i686-suse-linux
    LESS=-M -I
    LOGNAME=chepoxxx
    G_FILENAME_ENCODING=@locale,UTF-8,ISO-8859-15,CP1252
    XDG_DATA_DIRS=/etc/alacarte_system:/usr/local/share:/usr/share:/usr/share/gdm:/etc/opt/kde3/share:/opt/kde3/share
    DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-VBAOvEK4Ze,guid=448877d80f4c855009c8229c48e722a2
    LESSOPEN=lessopen.sh %s
    WINDOWPATH=7:7:7:7:7:7:7
    INFOPATH=/usr/local/info:/usr/share/info:/usr/info
    DISPLAY=:0.0
    XAUTHLOCALHOSTNAME=chepolinux
    LESSCLOSE=lessclose.sh %s %s
    G_BROKEN_FILENAMES=1
    XAUTHORITY=/root/.xauthvSXzkK
    COLORTERM=gnome-terminal
    JAVA_ROOT=/usr/lib/jvm/jre
    _=/usr/bin/env
    -M

  4. #4

    Default Re: Error 'Null' Window at login & startup

    And the /.xession.errors file right after I login shows:

    Code:
    chown: changing ownership of `/dev/xconsole': Operation not permitted
    chmod: changing permissions of `/dev/xconsole': Operation not permitted
    /etc/X11/xim: Checking whether an input method should be started.
    /etc/X11/xim: user environment variable LANG=en_US.UTF-8
    sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
    INPUT_METHOD is not set or empty (no user selected input method).
    Trying to start a default input method for the locale en_US.UTF-8 ...
    There is no default input method for the current locale.
    Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
                      Ignoring extra symbols
    Warning:          No symbols defined for <SYRQ> (keycode 92)
    Warning:          No symbols defined for <II5D> (keycode 93)
    Warning:          No symbols defined for <II65> (keycode 101)
    ... *** I cut out all the lines in between these two, they basically show the same info***
    Warning:          No symbols defined for <I7E> (keycode 254)
    Warning:          No symbols defined for <I7F> (keycode 255)
    SESSION_MANAGER=local/chepolinux:@/tmp/.ICE-unix/7554,unix/chepolinux:/tmp/.ICE-unix/7554
    which: no kwin in (/home/chepoxxx/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin)
    which: no fusion-icon in (/home/chepoxxx/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin)
    Checking for Xgl: not present. 
    Detected PCI ID for VGA: 01:00.0 0300: 1002:5960 (rev 01) (prog-if 00 [VGA controller])
    Checking for texture_from_pixmap: not present. 
    Trying again with indirect rendering:
    Checking for texture_from_pixmap: present. 
    Checking for non power of two support: present. 
    Checking for Composite extension: present. 
    Comparing resolution (1280x1024) to maximum 3D texture size (2048): Passed.
    Checking for nVidia: not present. 
    Checking for FBConfig: present. 
    Checking for Xgl: not present. 
    W: core-util.c: setpriority(): Permission denied
    Connection failure: Connection refused
    Failed to get the list of printers from cupsd
    MSG: /org/freedesktop/DBus org.freedesktop.DBus NameAcquired
    Initializing nautilus-open-terminal extension
    seahorse nautilus module initialized
    Initializing nautilus-share extension
    
    ** (nm-applet:7770): WARNING **: nm_object_get_property: Error getting 'WirelessHardwareEnabled' for /org/freedesktop/NetworkManager: The name org.freedesktop.NetworkManager was not provided by any .service files
    
    
    ** (nm-applet:7770): WARNING **: No connections defined
    beagled will run in the background.
    Use beagle-status to check progress of beagled.
    For log files check /home/chepoxxx/.beagle/Log/current-Beagle.
    
    
    ** (nm-applet:7770): WARNING **: nm_object_get_property: Error getting 'ActiveConnections' for /org/freedesktop/NetworkManager: The name org.freedesktop.NetworkManager was not provided by any .service files
    
    
    ** (nautilus:7748): WARNING **: Unable to add monitor: Not supported
    which: no kwin in (/home/chepoxxx/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin)
    Starting gtk-window-decorator
    Nautilus-Share-Message: REFRESHING SHARES
    Nautilus-Share-Message: ------------------------------------------
    Nautilus-Share-Message: spawn arg "net"
    Nautilus-Share-Message: spawn arg "usershare"
    Nautilus-Share-Message: spawn arg "info"
    Nautilus-Share-Message: end of spawn args; SPAWNING
    
    Nautilus-Share-Message: returned from spawn: SUCCESS: 
    Nautilus-Share-Message: exit code 0
    Nautilus-Share-Message: caller wants GKeyFile
    Nautilus-Share-Message: success from calling net usershare and parsing its output
    Nautilus-Share-Message: ------------------------------------------
    Nautilus-Share-Message: unknown format for key 'incoming/usershare_acl' as it contains 'Everyone:F,'.  Assuming that the share is read-only
    Nautilus-Share-Message: unknown format for key 'weeds s03/usershare_acl' as it contains 'Everyone:F,'.  Assuming that the share is read-only
    /usr/bin/compiz (animation) - Error: Animation settings mismatch in "Animation Selection" list for Focus event.
    /usr/bin/compiz (animation) - Error: Animation settings mismatch in "Animation Selection" list for Focus event.
    /usr/bin/compiz (animation) - Error: Animation settings mismatch in "Animation Selection" list for Focus event.
    -M

  5. #5
    Join Date
    Oct 2008
    Location
    Choctaw, OK
    Posts
    66

    Default Re: Error 'Null' Window at login & startup

    Two things grab my attention as anomalous.

    Under the 'env' command, I see "HOME=/root" -- different from mine. I'm sure that's not right, but SUSE has recently changed over to using the "no root login" system, so it may be correct. Still, I think it's wrong. Unless someone who knows corrects me, I'm going to suggest we change that. This is the part that's tricky, especially for noobs. Let me see if I can explain this without losing you -- I'm not going to assume anything, so don't be insulted if I state the obvious.

    In the terminal, if you simply type 'cd' and ENTER, followed by 'pwd', you will likely see the answer "/root". Not good. So we'll type 'cd /home/chepoxxx'. Now, assuming you did a default installation, you probably have the Joe editor, so we'll do this:
    Code:
    joe .profile
    to open your profile. At the bottom of that file, type 'export HOME=/home/chepoxxx', hit ENTER, then CTRL+K followed by X. That should save and close the file. That should fix that problem.

    The other thing in the .xsession-errors is the "/dev/xconsole" problem. I can't find out how to fix that, but I think that's related. So let's see if we can make it go away if you now logout and log back in.

    Let me know.
    Ed Hurst
    Open for Business (ofb.biz)

  6. #6
    crunchie-uk NNTP User

    Default Re: Error 'Null' Window at login & startup

    I have started getting this error now too, im wondering if it is KDE related as i installed KDE then uninstalled it?

    RE the home=/root i get this when typing pwd
    Code:
    crunchie@linux-g1gp:~> cd
    crunchie@linux-g1gp:~> pwd
    /home/crunchie

    Here is env output.

    Code:
    LESSKEY=/etc/lesskey.bin
    MANPATH=/usr/local/man:/usr/share/man
    NNTPSERVER=news
    INFODIR=/usr/local/info:/usr/share/info:/usr/info
    HOSTNAME=linux-g1gp
    XKEYSYMDB=/usr/share/X11/XKeysymDB
    DESKTOP_STARTUP_ID=
    HOST=linux-g1gp
    TERM=xterm
    SHELL=/bin/bash
    PROFILEREAD=true
    XDG_SESSION_COOKIE=1d55fc11cdd77e91e0668fb1484e644e-1223421244.528486-1412739759
    HISTSIZE=1000
    GTK_RC_FILES=/etc/gtk/gtkrc:/home/crunchie/.gtkrc-1.2-gnome2
    WINDOWID=50331726
    MORE=-sl
    XSESSION_IS_UP=yes
    GTK_MODULES=gnomebreakpad
    JRE_HOME=/usr/lib/jvm/jre
    GROFF_NO_SGR=yes
    USER=crunchie
    DESKTOP_LAUNCH=gnome-open
    LS_COLORS=no=00:fi=00:di=01;34:ln=00;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=41;33;01:ex=00;32:*.cmd=00;32:*.exe=01;32:*.com=01;32:*.bat=01;32:*.btm=01;32:*.dll=01;32:*.tar=00;31:*.tbz=00;31:*.tgz=00;31:*.rpm=00;31:*.deb=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.lzma=00;31:*.zip=00;31:*.zoo=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.tb2=00;31:*.tz2=00;31:*.tbz2=00;31:*.avi=01;35:*.bmp=01;35:*.fli=01;35:*.gif=01;35:*.jpg=01;35:*.jpeg=01;35:*.mng=01;35:*.mov=01;35:*.mpg=01;35:*.pcx=01;35:*.pbm=01;35:*.pgm=01;35:*.png=01;35:*.ppm=01;35:*.tga=01;35:*.tif=01;35:*.xbm=01;35:*.xpm=01;35:*.dl=01;35:*.gl=01;35:*.wmv=01;35:*.aiff=00;32:*.au=00;32:*.mid=00;32:*.mp3=00;32:*.ogg=00;32:*.voc=00;32:*.wav=00;32:
    XNLSPATH=/usr/share/X11/nls
    ENV=/etc/bash.bashrc
    HOSTTYPE=i386
    SSH_AUTH_SOCK=/tmp/keyring-rO5H5G/ssh
    GNOME_KEYRING_SOCKET=/tmp/keyring-rO5H5G/socket
    FROM_HEADER=
    USERNAME=crunchie
    SESSION_MANAGER=local/linux-g1gp:@/tmp/.ICE-unix/30232,unix/linux-g1gp:/tmp/.ICE-unix/30232
    PAGER=less
    CSHEDIT=emacs
    XDG_CONFIG_DIRS=/etc/xdg
    MINICOM=-c on
    DESKTOP_SESSION=gnome
    PATH=/home/crunchie/bin:/usr/local/bin:/usr/bin:/sbin:/usr/sbin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/opt/kde3/bin:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin
    MAIL=/var/spool/mail/crunchie
    CPU=i686
    JAVA_BINDIR=/usr/lib/jvm/jre/bin
    GDM_XSERVER_LOCATION=local
    PWD=/home/crunchie
    INPUTRC=/home/crunchie/.inputrc
    XMODIFIERS=@im=local
    JAVA_HOME=/usr/lib/jvm/jre
    GNOME_KEYRING_PID=30229
    LANG=en_GB.UTF-8
    PYTHONSTARTUP=/etc/pythonstart
    GDMSESSION=gnome
    ICEAUTHORITY=/home/crunchie/.ICEauthority
    TEXINPUTS=:/home/crunchie/.TeX:/usr/share/doc/.TeX:/usr/doc/.TeX
    HOME=/root
    QT_SYSTEM_DIR=/usr/share/desktop-data
    SHLVL=2
    OSTYPE=linux
    LESS_ADVANCED_PREPROCESSOR=no
    SDL_AUDIODRIVER=pulse
    XCURSOR_THEME=DMZ
    GNOME_DESKTOP_SESSION_ID=Default
    LS_OPTIONS=-A -N --color=tty -T 0
    WINDOWMANAGER=/usr/bin/gnome
    MACHTYPE=i686-suse-linux
    LESS=-M -I
    LOGNAME=crunchie
    G_FILENAME_ENCODING=@locale,UTF-8,ISO-8859-15,CP1252
    XDG_DATA_DIRS=/usr/local/share:/usr/share:/usr/share/gdm:/etc/opt/kde3/share:/opt/kde3/share
    DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-dirzowXPDA,guid=1a18a9ae11e050c9bce3515548ebed3e
    LESSOPEN=lessopen.sh %s
    WINDOWPATH=7:7:7:7:7:7:7:7:7:7
    INFOPATH=/usr/local/info:/usr/share/info:/usr/info
    DISPLAY=:0.0
    LADSPA_PATH=/usr/lib/ladspa
    XAUTHLOCALHOSTNAME=linux-g1gp
    LESSCLOSE=lessclose.sh %s %s
    G_BROKEN_FILENAMES=1
    XAUTHORITY=/root/.xauthQn9rPR
    COLORTERM=gnome-terminal
    JAVA_ROOT=/usr/lib/jvm/jre
    _=/usr/bin/env

  7. #7
    crunchie-uk NNTP User

    Default Re: Error 'Null' Window at login & startup

    and here is xsession

    Code:
    chown: changing ownership of `/dev/xconsole': Operation not permitted
    chmod: changing permissions of `/dev/xconsole': Operation not permitted
    /etc/X11/xim: Checking whether an input method should be started.
    /etc/X11/xim: user environment variable LANG=en_GB.UTF-8
    sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
    INPUT_METHOD is not set or empty (no user selected input method).
    Trying to start a default input method for the locale en_GB.UTF-8 ...
    There is no default input method for the current locale.
    Warning:          No symbols defined for <SYRQ> (keycode 92)
    Warning:          No symbols defined for <II5D> (keycode 93)
    Warning:          No symbols defined for <II65> (keycode 101)
    Warning:          No symbols defined for <BRK> (keycode 114)
    Warning:          No symbols defined for <FK13> (keycode 118)
    Warning:          No symbols defined for <FK14> (keycode 119)
    Warning:          No symbols defined for <FK15> (keycode 120)
    Warning:          No symbols defined for <FK16> (keycode 121)
    Warning:          No symbols defined for <FK17> (keycode 122)
    Warning:          No symbols defined for <KPDC> (keycode 123)
    Warning:          No symbols defined for <XFER> (keycode 129)
    Warning:          No symbols defined for <I02> (keycode 130)
    Warning:          No symbols defined for <NFER> (keycode 131)
    Warning:          No symbols defined for <I04> (keycode 132)
    Warning:          No symbols defined for <AE13> (keycode 133)
    Warning:          No symbols defined for <I06> (keycode 134)
    Warning:          No symbols defined for <I07> (keycode 135)
    Warning:          No symbols defined for <I08> (keycode 136)
    Warning:          No symbols defined for <I09> (keycode 137)
    Warning:          No symbols defined for <I0A> (keycode 138)
    Warning:          No symbols defined for <I0B> (keycode 139)
    Warning:          No symbols defined for <I0C> (keycode 140)
    Warning:          No symbols defined for <I0D> (keycode 141)
    Warning:          No symbols defined for <I0E> (keycode 142)
    Warning:          No symbols defined for <I0F> (keycode 143)
    Warning:          No symbols defined for <I11> (keycode 145)
    Warning:          No symbols defined for <I12> (keycode 146)
    Warning:          No symbols defined for <I13> (keycode 147)
    Warning:          No symbols defined for <I14> (keycode 148)
    Warning:          No symbols defined for <I15> (keycode 149)
    Warning:          No symbols defined for <I16> (keycode 150)
    Warning:          No symbols defined for <I17> (keycode 151)
    Warning:          No symbols defined for <I18> (keycode 152)
    Warning:          No symbols defined for <I1A> (keycode 154)
    Warning:          No symbols defined for <I1B> (keycode 155)
    Warning:          No symbols defined for <K59> (keycode 157)
    Warning:          No symbols defined for <I1E> (keycode 158)
    Warning:          No symbols defined for <I1F> (keycode 159)
    Warning:          No symbols defined for <I23> (keycode 163)
    Warning:          No symbols defined for <I25> (keycode 165)
    Warning:          No symbols defined for <I26> (keycode 166)
    Warning:          No symbols defined for <I27> (keycode 167)
    Warning:          No symbols defined for <I28> (keycode 168)
    Warning:          No symbols defined for <I29> (keycode 169)
    Warning:          No symbols defined for <K5A> (keycode 170)
    Warning:          No symbols defined for <I2B> (keycode 171)
    Warning:          No symbols defined for <I2C> (keycode 172)
    Warning:          No symbols defined for <I2D> (keycode 173)
    Warning:          No symbols defined for <I2F> (keycode 175)
    Warning:          No symbols defined for <I31> (keycode 177)
    Warning:          No symbols defined for <I33> (keycode 179)
    Warning:          No symbols defined for <I34> (keycode 180)
    Warning:          No symbols defined for <K5B> (keycode 181)
    Warning:          No symbols defined for <K5D> (keycode 182)
    Warning:          No symbols defined for <K5E> (keycode 183)
    Warning:          No symbols defined for <K5F> (keycode 184)
    Warning:          No symbols defined for <I39> (keycode 185)
    Warning:          No symbols defined for <I3A> (keycode 186)
    Warning:          No symbols defined for <I3B> (keycode 187)
    Warning:          No symbols defined for <I3C> (keycode 188)
    Warning:          No symbols defined for <K62> (keycode 189)
    Warning:          No symbols defined for <K63> (keycode 190)
    Warning:          No symbols defined for <K64> (keycode 191)
    Warning:          No symbols defined for <K65> (keycode 192)
    Warning:          No symbols defined for <K66> (keycode 193)
    Warning:          No symbols defined for <I42> (keycode 194)
    Warning:          No symbols defined for <I43> (keycode 195)
    Warning:          No symbols defined for <I44> (keycode 196)
    Warning:          No symbols defined for <I45> (keycode 197)
    Warning:          No symbols defined for <K67> (keycode 198)
    Warning:          No symbols defined for <K68> (keycode 199)
    Warning:          No symbols defined for <K69> (keycode 200)
    Warning:          No symbols defined for <K6A> (keycode 201)
    Warning:          No symbols defined for <I4A> (keycode 202)
    Warning:          No symbols defined for <K6B> (keycode 203)
    Warning:          No symbols defined for <K6C> (keycode 204)
    Warning:          No symbols defined for <K6D> (keycode 205)
    Warning:          No symbols defined for <K6E> (keycode 206)
    Warning:          No symbols defined for <K6F> (keycode 207)
    Warning:          No symbols defined for <HKTG> (keycode 208)
    Warning:          No symbols defined for <KANA> (keycode 209)
    Warning:          No symbols defined for <EISU> (keycode 210)
    Warning:          No symbols defined for <AB11> (keycode 211)
    Warning:          No symbols defined for <I54> (keycode 212)
    Warning:          No symbols defined for <I55> (keycode 213)
    Warning:          No symbols defined for <I5A> (keycode 218)
    Warning:          No symbols defined for <K74> (keycode 219)
    Warning:          No symbols defined for <K75> (keycode 220)
    Warning:          No symbols defined for <K76> (keycode 221)
    Warning:          No symbols defined for <I5E> (keycode 222)
    Warning:          No symbols defined for <I60> (keycode 224)
    Warning:          No symbols defined for <I61> (keycode 225)
    Warning:          No symbols defined for <I62> (keycode 226)
    Warning:          No symbols defined for <I63> (keycode 227)
    Warning:          No symbols defined for <I64> (keycode 228)
    Warning:          No symbols defined for <I6E> (keycode 238)
    Warning:          No symbols defined for <I6F> (keycode 239)
    Warning:          No symbols defined for <I70> (keycode 240)
    Warning:          No symbols defined for <I71> (keycode 241)
    Warning:          No symbols defined for <I72> (keycode 242)
    Warning:          No symbols defined for <I73> (keycode 243)
    Warning:          No symbols defined for <I74> (keycode 244)
    Warning:          No symbols defined for <I75> (keycode 245)
    Warning:          No symbols defined for <I76> (keycode 246)
    Warning:          No symbols defined for <I77> (keycode 247)
    Warning:          No symbols defined for <I78> (keycode 248)
    Warning:          No symbols defined for <I79> (keycode 249)
    Warning:          No symbols defined for <I7A> (keycode 250)
    Warning:          No symbols defined for <I7B> (keycode 251)
    Warning:          No symbols defined for <I7C> (keycode 252)
    Warning:          No symbols defined for <I7D> (keycode 253)
    Warning:          No symbols defined for <I7E> (keycode 254)
    Warning:          No symbols defined for <I7F> (keycode 255)
    SESSION_MANAGER=local/linux-g1gp:@/tmp/.ICE-unix/30232,unix/linux-g1gp:/tmp/.ICE-unix/30232
    which: no kwin in (/home/crunchie/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/opt/kde3/bin:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:.)
    which: no fusion-icon in (/home/crunchie/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/opt/kde3/bin:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:.)
    Checking for Xgl: not present. 
    Detected PCI ID for VGA: 01:00.0 0300: 10de:01d8 (rev a1) (prog-if 00 [VGA controller])
    Checking for texture_from_pixmap: present. 
    Checking for non power of two support: present. 
    Checking for Composite extension: present. 
    Comparing resolution (1280x800) to maximum 3D texture size (4096): Passed.
    Checking for nVidia: present. 
    Checking for FBConfig: present. 
    Checking for Xgl: not present. 
    Failed to get the list of printers from cupsd
    MSG: /org/freedesktop/DBus org.freedesktop.DBus NameAcquired
    
    ** (gsynaptics-init:30449): WARNING **: Using synclient
    Unknown parameter CoastingSpeedThreshold
    Initializing nautilus-open-terminal extension
    Initializing nautilus-share extension
    Screen is composited.
    LOADED : /usr/share/applications/MozillaFirefox.desktop
    LOADED : /usr/share/applications/vlc.desktop
    LOADED : /usr/share/applications/pidgin.desktop
    LOADED : /usr/share/applications/gnome-terminal.desktop
    APPLET : /usr/lib/awn/applets/taskman.desktop
    
    ** (nautilus:30430): WARNING **: Unable to add monitor: Not supported
    Launched application : 30859
    Launched application : 31052

  8. #8
    Join Date
    Oct 2008
    Location
    Choctaw, OK
    Posts
    66

    Default Re: Error 'Null' Window at login & startup

    Well, at least you end up in the proper HOME. Still, for now, I can only suggest you make the same change in your ~./profile as I posted above.

    However, I believe I have figured out the problem with the 'xconsole' stuff. According to the mailing list for syslog-ng (the package which includes xconsole), on SUSE 10.0, a user was advised to comment out some portions of a file at '/etc/syslog-ng/syslog-ng.conf', starting around line 122 [http://osdir.com/ml/syslog-ng/2006-01/msg00089.html]. You do that by placing a hash mark '#' in front of the four or five lines mentioned.
    Last edited by br073n; 07-Oct-2008 at 17:14. Reason: typos
    Ed Hurst
    Open for Business (ofb.biz)

  9. #9

    Default Re: Error 'Null' Window at login & startup

    Just to let every one know, the problem on my box has resolved magically by itself. To mention a few things I did (not really focusing on fixing the issue) was:

    • 1. Updated opensSUSE with all patches & fixes
    • 2. Installed several software (VLC, Jubler, and a few plugins)
    • 3. Booted with openSUSE 11.0 DVD in drive (could this be the culprit??)


    Sorry I can't be of much help. Good luck on solving your issue.
    -M

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •