Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Nvidia Separate X Screen Help

  1. #1

    Default Nvidia Separate X Screen Help

    Hello,


    I am currently running openSUSE 11.0 x86_64, using KDE 3.5. I have a Nvidia 7600GT graphics card, with a Viewsonic VA720, and a Samsung Syncmaster 940BW connected.


    I have the current nvidia driver 173.14.12. Configured to run Separate X screens via nvidia-settings.


    My problem is, screen:0(syncmaster 940BW 1440x900) is the primary screen and the resolution is correct on the monitor, but the KDE desktop overlay is messed up. My panel bar is shorter than the width of the monitor, and the desktop extends below the bottom of the monitor. On the login screen, the bottom is cut off, and the right hand side is extended. screen:1(Viewsonic va720 1280x1024) is operating perfectly.


    So my question is, how can I adjust my desktop size on screen:0 to that it is the correct size of the monitor. I have included my X config file. If you need screenshots, just ask.

    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 1.0 (buildmeister@builder58) Thu Jul 17 18:39:42 PDT 2008

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder58) Thu Jul 17 18:39:00 PDT 2008
    # /.../
    # SaX generated X11 config file
    # Created on: 2008-10-02T22:14:43-0400.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "ServerLayout"
    Identifier "Layout[all]"
    Screen 0 "Screen0" 0 0
    Screen 1 "Screen1" RightOf "Screen0"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    EndSection

    Section "Files"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    EndSection

    Section "Module"
    Load "freetype"
    Load "type1"
    Load "dbe"
    Load "glx"
    Load "extmod"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    Option "Xinerama" "0"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard[0]"
    Driver "kbd"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Identifier "Mouse[1]"
    Driver "mouse"
    Option "Buttons" "17"
    Option "Device" "/dev/input/mice"
    Option "Name" "Microsoft Wireless Optical Desktop? 2.20"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    EndSection

    Section "Monitor"
    Identifier "Monitor[0]"
    VendorName "SAMSUNG"
    ModelName "SYNCMASTER 940BW"
    UseModes "Modes[0]"
    DisplaySize 409 256
    HorizSync 30.0 - 81.0
    VertRefresh 56.0 - 75.0
    Option "CalcAlgorithm" "XServerPool"
    Option "DPMS"
    Option "PreferredMode" "1440x900"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Samsung SyncMaster"
    HorizSync 30.0 - 81.0
    VertRefresh 56.0 - 75.0
    EndSection

    Section "Monitor"
    Identifier "Monitor1"
    VendorName "Unknown"
    ModelName "ViewSonic VA720"
    HorizSync 30.0 - 82.0
    VertRefresh 50.0 - 75.0
    EndSection

    Section "Device"
    Identifier "Device[0]"
    Driver "nvidia"
    VendorName "NVidia"
    BoardName "GeForce 7600 GT"
    Screen 0
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 7600 GT"
    BusID "PCI:1:0:0"
    Screen 0
    EndSection

    Section "Device"
    Identifier "Videocard1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 7600 GT"
    BusID "PCI:1:0:0"
    Screen 1
    EndSection

    Section "Screen"
    Identifier "Screen[0]"
    Device "Device[0]"
    Monitor "Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "DFP: 1440x900 +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "Screen1"
    Device "Videocard1"
    Monitor "Monitor1"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "CRT: nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "off"
    EndSection




    Thank you in advance for your help.
    Mark Brown

  2. #2

    Default Re: Nvidia Separate X Screen Help

    Have you started x after your nvidia configuration?
    People who do not break things first will never learn to create anything

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,129
    Blog Entries
    15

    Default Re: Nvidia Separate X Screen Help

    Quote Originally Posted by CynicalPride
    Hello,


    I am currently running openSUSE 11.0 x86_64, using KDE 3.5. I have a
    Nvidia 7600GT graphics card, with a Viewsonic VA720, and a Samsung
    Syncmaster 940BW connected.


    I have the current nvidia driver 173.14.12. Configured to run Separate
    X screens via nvidia-settings.


    My problem is, screen:0(syncmaster 940BW 1440x900) is the primary
    screen and the resolution is correct on the monitor, but the KDE desktop
    overlay is messed up. My panel bar is shorter than the width of the
    monitor, and the desktop extends below the bottom of the monitor. On the
    login screen, the bottom is cut off, and the right hand side is
    extended. screen:1(Viewsonic va720 1280x1024) is operating perfectly.


    So my question is, how can I adjust my desktop size on screen:0 to that
    it is the correct size of the monitor. I have included my X config file.
    If you need screenshots, just ask.

    <snip xorg.conf>

    Thank you in advance for your help.
    Mark Brown
    Hi
    I would recommend backup your xorg.conf file and run through using sax2
    rather than the nvidia one. If it doesn't work you can just copy the
    backup back and restart the X server.

    Here is a link to my desktop, it's a SLED machine but runs dual
    monitors to have a look at http://nopaste.com/p/amwBisOW3

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 16:03, 2 users, load average: 0.05, 0.13, 0.18
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  4. #4

    Default Re: Nvidia Separate X Screen Help

    I have everything up and running, X is running, KDE 3.5 is loaded and working, and everything is usable, Just the desktop on the primary monitor isn't right.


    Thanks
    Mark Brown

  5. #5

    Default Re: Nvidia Separate X Screen Help

    Quote Originally Posted by CynicalPride View Post
    I have everything up and running, X is running, KDE 3.5 is loaded and working, and everything is usable, Just the desktop on the primary monitor isn't right.


    Thanks
    Mark Brown
    If screen 0 (samsung) has an auto image fit in the control panel you can try it and see if the resolution correspond to your nvidia settings before attempting another move.
    People who do not break things first will never learn to create anything

  6. #6

    Default Re: Nvidia Separate X Screen Help

    Hello,


    Screen:0 Samsung Syncmaster 940BW reports 1440x900 resolution in the auto image setting. The resolution is correct on both monitor, the problem lies in the desktop size itself, It's almost as if KDE is not setting the desktop size correctly. The bottom of the screen is cut off, and the right side is "extended"

    http://www.myinfinity.net/screen0.jpg Screen:0
    http://www.myinfinity.net/screen0app.jpg Screen:0 showing bottom cut off
    http://www.myinfinity.net/screen1.jpg Screen:1 showing working perfectly
    http://www.myinfinity.net/screen1app.jpg Screen:1 showing working perfectly with same app running

    Thanks
    Mark Brown
    Last edited by CynicalPride; 02-Oct-2008 at 21:20. Reason: Added Pictures

  7. #7

    Default Re: Nvidia Separate X Screen Help

    Quote Originally Posted by CynicalPride View Post
    Hello,


    Screen:0 Samsung Syncmaster 940BW reports 1440x900 resolution in the auto image setting. The resolution is correct on both monitor, the problem lies in the desktop size itself, It's almost as if KDE is not setting the desktop size correctly. The bottom of the screen is cut off, and the right side is "extended"


    Thanks
    Mark Brown
    Just for testing
    Logout of kde and login using icewm or xfwvm if those were preinstalled and see if the problem persists.
    People who do not break things first will never learn to create anything

  8. #8

    Default Re: Nvidia Separate X Screen Help

    The login screen is also affected by this issue, I am unable to select a session type due to the fact that the bottom of the screen is cut off. Being that this is also affecting the login screen, I would have to imagine that it would also be present in other GUI's, I will however check that out right now. Please take a look at the pictures I posted in my last link. I think they will help explain more of what my problem is.


    Problem Exist in Gnome
    Problem Exist in KDE4
    Couldn't duplicate problem in IceWM due to the fact that the second desktop wouldn't appear.

    Thanks
    Mark Brown
    Last edited by CynicalPride; 02-Oct-2008 at 21:31. Reason: Updated Test Results

  9. #9

    Default Re: Nvidia Separate X Screen Help

    Quote Originally Posted by CynicalPride View Post
    The login screen is also affected by this issue, I am unable to select a session type due to the fact that the bottom of the screen is cut off. Being that this is also affecting the login screen, I would have to imagine that it would also be present in other GUI's, I will however check that out right now. Please take a look at the pictures I posted in my last link. I think they will help explain more of what my problem is.


    Problem Exist in Gnome
    Problem Exist in KDE4
    Couldn't duplicate problem in IceWM due to the fact that the second desktop wouldn't appear.

    Thanks
    Mark Brown
    I can see it.
    While in the login screen can you try pressing the samsung auto image adjust to see if you can resize the screen to fit the whole area of the login screen.
    People who do not break things first will never learn to create anything

  10. #10

    Default Re: Nvidia Separate X Screen Help

    Auto image adjust doesn't work on the syncmaster, It just reports the current mode that the monitor is in, and reports that auto image is not available. It will not let me adjust the image manually either.



    Thanks
    Mark Brown

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •