Results 1 to 6 of 6

Thread: Mplay dependency

  1. #1
    Join Date
    Sep 2008
    Location
    VA
    Posts
    20

    Default Mplay dependency

    I've tried to install mplayer (and a bunch of other things like it) and all show a dependency to libmpcdec.s0.3 . The packman and the openSuse repository have mplayer, but none have libmpcdec.s0.3 ! Anyone know where I can get the both, or at least libmpcdec.s0.3?

  2. #2

    Default Re: Mplay dependency

    If you go in to YaST -> Software Management and select the checkbox "RPM Provides" in addition to the others preselected, then you can search for libraries like libmpcdec and have a package show up.

    The packaged for that particular one is libmpcdec5, and it is from the standard openSUSE repo-oss

    g

  3. #3

    Default Re: Mplay dependency

    oops,

    I just realized that you are looking for libmpcdec.so.3 not libmpcdec.so.5. Sorry about that. Depending on what your system is, it could be that someone at packman made the RPM link to the wrong library. They are pretty good at fixing those quickly.

    g

  4. #4
    Join Date
    Jun 2008
    Location
    PHX
    Posts
    481

    Default Re: Mplay dependency

    What is your output:

    # zypper install MPlayer
    <>---><^>

  5. #5
    Join Date
    Sep 2008
    Location
    VA
    Posts
    20

    Default Re: Mplay dependency

    linux-sr5c:/home/XXXXXXX # zypper install MPlayer
    Downloading repository 'Packman-RPMs' metadata [done]
    Building repository 'Packman-RPMs' cache [done]
    Reading installed packages...

    Problem: nothing provides libdirectfb-0.9.so.25 needed by MPlayer-1.0rc2_r27637-2.pm.1.i586
    Solution 1: do not ask to install a solvable providing MPlayer

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Mplay dependency

    Quote Originally Posted by bangorme View Post
    Problem: nothing provides libdirectfb-0.9.so.25 needed by MPlayer-1.0rc2_r27637-2.pm.1.i586
    Solution 1: do not ask to install a solvable providing MPlayer
    libdirectfb comes with DirectFB or DirectFB-64bit in the openSUSE OSS repositority.

    IMHO you are either inappropriately mixing 32-bit and 64-bit applications, or you failed to setup the OSS repository.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •