Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Installing clamav and clamtk for suse 11 Gnome environment

  1. #1
    yaarappa NNTP User

    Cool Installing clamav and clamtk for suse 11 Gnome environment

    Hi,

    I am new to Linux and I do not have a Windows partition.

    I have installed clamav. When I proceeded to install clamtk-3.11-0.pm.1.noarch.rpm it asked me for succession of different files which I managed to find from yast2 and the internet. At the moment I am at a standstill as I cannot find perl = 5.8.8 anywhere, because the latest perl = 5.10.0 is available and the other not. Activeperl 5.8.8 is no use it is insisting on perl = 5.8.8

    Am I doing something wrong here? should I need all these other files to install clamtk? why is it these files are not provided?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,814
    Blog Entries
    15

    Default Re: Installing clamav and clamtk for suse 11 Gnome environment

    Quote Originally Posted by yaarappa
    Hi,

    I am new to Linux and I do not have a Windows partition.

    I have installed clamav. When I proceeded to install
    clamtk-3.11-0.pm.1.noarch.rpm it asked me for succession of different
    files which I managed to find from yast2 and the internet. At the moment
    I am at a standstill as I cannot find perl = 5.8.8 anywhere, because the
    latest perl = 5.10.0 is available and the other not. Activeperl 5.8.8 is
    no use it is insisting on perl = 5.8.8

    Am I doing something wrong here? should I need all these other files
    to install clamtk? why is it these files are not provided?

    Hi
    You should look at installing KlamAV which is provided with openSUSE 11
    else you could look at rebuilding the src rpm.

    If your not running 11, can you please advise the openSUSE version and
    which desktop your using.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 12:01, 2 users, load average: 0.07, 0.07, 0.07
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  3. #3
    yaarappa NNTP User

    Default Re: Installing clamav and clamtk for suse 11 Gnome environme

    Hi,

    I am using suse 11 and the gnome desktop. I understand that KlamAv is for KDE desktop and how do I rebuild the src rpm?
    Last edited by yaarappa; 03-Oct-2008 at 13:24. Reason: further clarification

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,814
    Blog Entries
    15

    Default Re: Installing clamav and clamtk for suse 11 Gnome environment

    Quote Originally Posted by yaarappa
    Hi,

    I am using suse 11 and the gnome desktop. I understand that KlamAv is
    for KDE desktop and how do I rebuild the src rpm?
    Hi
    Overlooked the Gnome bit in your subject, my apologies. Now I
    downloaded and installed the clamtk frontend rpm the only files I had
    to add were;
    Code:
    perl-File-Find-Rule is needed by clamtk-3.11-0.pm.1.noarch
    perl-Date-Calc is needed by clamtk-3.11-0.pm.1.noarch
    perl-Gtk2 is needed by clamtk-3.11-0.pm.1.noarch
    perl-Glib is needed by clamtk-3.11-0.pm.1.noarch
    perl-Config-Tiny is needed by clamtk-3.11-0.pm.1.noarch
    Once the above were installed via YaST the clamtk rpm installed fine.

    Can you post the exact errors you get when running the rpm command?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 11:05, 2 users, load average: 0.82, 0.42, 0.24
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  5. #5
    yaarappa NNTP User

    Question Re: Installing clamav and clamtk for suse 11 Gnome environme

    Hi,

    When I try to install (perl-File-Find-Rule) it is asking for;
    - perl-number-compare is needed by perl-File-Find-Rule
    - perl-text-glob is needed by perl-File-Find-Rule
    and when I try to install either of them it is asking for ;
    -perl = 5.8.8 is needed by perl-number-compare/perl-text-glob but I cant find it anywhere?

    Cheers,

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,814
    Blog Entries
    15

    Default Re: Installing clamav and clamtk for suse 11 Gnome environment

    Quote Originally Posted by yaarappa
    Hi,

    When I try to install (perl-File-Find-Rule) it is asking for;
    - perl-number-compare is needed by perl-File-Find-Rule
    - perl-text-glob is needed by perl-File-Find-Rule
    and when I try to install either of them it is asking for ;
    -perl = 5.8.8 is needed by perl-number-compare/perl-text-glob but I
    cant find it anywhere?

    Cheers,
    Hi
    Is perl actually installed? You also need to add the packman repository.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 4:20, 2 users, load average: 0.12, 0.55, 0.68
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  7. #7
    yaarappa NNTP User

    Default Re: Installing clamav and clamtk for suse 11 Gnome environme

    How do I do that? is it included in the dvd? what is packman repositary? Pardon my ignorance

  8. #8

    Default Re: Installing clamav and clamtk for suse 11 Gnome environme

    i have opensuse 11.1 with gnome but, when i tried to install clamtk, it says i need perl-config-tiny but, i couldn't find that package anywhere. what do i do now because i cant install clamtk.

  9. #9
    gtx75 NNTP User

    Default Re: Installing clamav and clamtk for suse 11 Gnome environment


    i have opensuse 11.1 with gnome but, when i tried to install clamtk, it
    says i need perl-config-tiny but, i couldn't find that package anywhere.
    what do i do now because i cant install clamtk.


    --
    gtx75
    ------------------------------------------------------------------------
    gtx75's Profile: http://forums.opensuse.org/member.php?userid=17857
    View this thread: http://forums.opensuse.org/showthread.php?t=396634


  10. #10
    Malcolm NNTP User

    Default Re: Installing clamav and clamtk for suse 11 Gnome environment

    Quote Originally Posted by gtx75
    i have opensuse 11.1 with gnome but, when i tried to install clamtk, it
    says i need perl-config-tiny but, i couldn't find that package anywhere.
    what do i do now because i cant install clamtk.
    Hi
    There are two ways, use cpan from the cli or search here
    Get It

    CPAN is worth learning about in case you cannot find a perl module

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-4-default
    up 3 days 2:54, 1 user, load average: 0.50, 0.24, 0.23
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •