Results 1 to 6 of 6

Thread: mplayer error with latest libcaca0

  1. #1
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,575
    Blog Entries
    38

    Default mplayer error with latest libcaca0

    I discovered an error on both my openSUSE-10.3 and 11.0 PCs with the latest caca-utils-0.9_0.99.beta15-0.pm.5.i586.rpm and libcaca0-0.9_0.99.beta15-0.pm.5.i586.rpm from Packman not being compatible with MPlayer-1.0rc2_r27637-2.pm.1.i586.rpm also packaged by Packman.

    When trying to play an flv or mpeg file, the error I get is:
    oldcpu@stonehenge01:~/data/musicvideos> mplayer oldcpu-video.mpg
    mplayer: error while loading shared libraries: libcucul.so.0: cannot open shared object file: No such file or directory


    It is a puzzling error, as libcucul.so.0 does come with the libcaca0-0.9_0.99.beta15-0.pm.5.i586.rpm.

    On my openSUSE-10.3 PC, I rolled libcaca back to libcaca0-0.9_0.99.beta14-0.pm.5.i586.rpm and the problem went away, and I could play mpeg and flv files with no problem.

    My 11.0 mplayer is still broken, as I did not keep the older version (and hence I could not roll back on 11.0).

    Has anyone else encountered this problem?

  2. #2

    Default Re: mplayer error with latest libcaca0

    Yes, I think it's a ZYpp bug. It tried to reproduce it but I could not find the old package ([packman] Get old package versions?).
    Just reinstall beta15 "zypper in -f" and it will work. The problems is than even if the packages contains libcucul.so.0 it seems to be deleted in the update process.

    Can you please pass me beta14 10.3 i586 package?

    Thanks.

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,575
    Blog Entries
    38

    Default Re: mplayer error with latest libcaca0

    Quote Originally Posted by RedDwarf View Post
    Can you please pass me beta14 10.3 i586 package?
    I've uploaded it to this free filefactory site ...
    libcaca-0.9_0.99.beta14-0.pm.0.i586.rpm
    ..... for anyone not following this thread closely, this rpm is an "older" version of libcaca for openSUSE-10.3.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,575
    Blog Entries
    38

    Default Re: mplayer error with latest libcaca0

    Quote Originally Posted by RedDwarf View Post
    Just reinstall beta15 "zypper in -f" and it will work. The problems is than even if the packages contains libcucul.so.0 it seems to be deleted in the update process.
    Thankyou.

    "zypper in -f libcaca0" worked on my openSUSE-11.0 PC. But I am surprised I encountered this error, as I believe I used smart to install libcaca0 (and not zypper) hence the error is common to both package managers.

  5. #5

    Default Re: mplayer error with latest libcaca0

    Quote Originally Posted by oldcpu View Post
    But I am surprised I encountered this error, as I believe I used smart to install libcaca0 (and not zypper) hence the error is common to both package managers.
    Seems to be a RPM error. I have asked at [opensuse-packaging] RPM bug when updating or something I should know?

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,575
    Blog Entries
    38

    Default Re: mplayer error with latest libcaca0

    Quote Originally Posted by RedDwarf View Post
    I sent an email to the Packman packager, who noted he downgraded libcaca to beta14, which should be available as soon as the mirrors are synced, and he would look into fixing the problem with the latest version.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •