Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Catastrofic Upgrade KDE COMPIZ XGL Kernel

  1. #1

    Exclamation Catastrofic Upgrade KDE COMPIZ XGL Kernel

    Hello,
    I Have maybe 5 Different simultaneous upgrade related problems.
    I have the same problem in 2 different PCs.
    One have an onboard intel video card and teh other have an nvidia 8800.
    But both show the same behavior.
    I add Some repositories to get the QT 4.4 required by kde 4.4.1
    Then I make a big upgrade to,
    -Kernel 2.6.25.16-0.1
    -XGL git_071026-79.3
    -Xorg 7.4-5.1
    -Compiz 0.7.8-2.3
    -Compiz Fusion 0.7.8-3.1
    -KDE4 4.1.2

    After that I needed to reinstall video drivers and then
    I have 3d acceleration but not desktop effects in any desktop (KDE3, Gnome), and in kde4 the desktop icons don't show the Gizmos, makin impossible to transform, rotate or move it. and the Konsole always give a signal 11 (SIGSEGV).

    Both PCs do the same.
    Should I Wait for some new upgrades?
    The Math is the Only Way

  2. #2

    Default Re: Catastrofic Upgrade KDE COMPIZ XGL Kernel

    i have same catastrofic after upgrade compiz and XORG

  3. #3
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    249

    Default Re: Catastrofic Upgrade KDE COMPIZ XGL Kernel

    Same here > Gnome.

  4. #4
    Join Date
    Sep 2008
    Location
    Chania - Crete - Greece
    Posts
    70

    Default Re: Catastrofic Upgrade KDE COMPIZ XGL Kernel

    I also use Compiz in my openSuSE 11.0. My kernel, xorg etc. were upgraded without upgrading Compiz, fuzion and emerald (I just kept my 0.7.4-something) and my 3D effects were fine. When I upgraded compiz packages to the new ones (0.7.8-x) my 3D effects were gone! This happens in all graphical environments (both KDE 3.5.10 and 4.1.2 and GNOME 2.22)

    I run dmesg from a console window and I get the following:
    ...
    compiz[14496]: segfault at 20726176 ip 20726176 sp bf9fee5c error 4 in libgcc_s.so.1[b74e7000+c000]
    ...

  5. #5

    Angry Re: Catastrofic Upgrade KDE COMPIZ XGL Kernel

    Well, I find a partial solution
    I have Downgrade compiz to 0.7.4
    And The 3d effects are back, but the KDE 4 Still have with Strange new errors by now.
    I'm working with KDE 3.5
    The Math is the Only Way

  6. #6
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    436

    Default Re: Catastrofic Upgrade KDE COMPIZ XGL Kernel

    I had the same problems, but after downgrading, I still don't have my effects back. Is there something else one should do after downgrading?

  7. #7
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    436

    Default Re: Catastrofic Upgrade KDE COMPIZ XGL Kernel

    My bad. I went back to see if I had missed anything (I should have done that before writing), and I had found that I in fact had missed a few of the required downgrades. After doing the required downgrades, everything has gone back to the way it should (effects, etc..). Sorry!

  8. #8
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    249

    Default Re: Catastrofic Upgrade KDE COMPIZ XGL Kernel

    Meh I don't wanna downgrade...

    Who controls what is getting placed in that repository and where can I check if there is a solution thats being worked on? Cause it sounds like a bug and not wrong settings or corrupted files on our PC's.

    I don't mean to nag, its just, like ever other update in that repository kills something in a bad way. If it's bleeding edge kinda stuff then there should be a place to report stuff right?

  9. #9

    Default Re: Catastrofic Upgrade KDE COMPIZ XGL Kernel

    some solution?

  10. #10

    Smile Re: Catastrofic Upgrade KDE COMPIZ XGL Kernel

    I Find some interesting Symptoms, The Xorg Upgrade overwrite the DISPLAYMANAGER_XSERVER Variable to "Xorg" in the /etc/sysconfig/displaymanager File, so I needed to change it to "xgl" again.
    But anyway the usual methods to auto start compiz at the startup simply don't work finaly I added a .desktop file in my kde3 autorun folder pointiong to Compiz.

    And also many qt4 software, like skype and others using qt4 show corrupt graphics or missing parts of the screen, but it looks ok after clicking on the corrupt area. Some Sort of refresh error?

    AND I have a large list of missing features in KDE4.
    For example i alway use the Search box in the launch as a calculator, in KDE 4.0 it works, but since 4.1 it don't work.

    By Now I have KDE 3.5 working.
    But if the Nvidia driver Is "Sync to Vblank" Active.
    It produces complete system crash after some minutes of using an openGL aplication.
    Really Strange for me.
    The Math is the Only Way

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •