Results 1 to 10 of 10

Thread: kde 4.1

  1. #1

    Default kde 4.1

    Hello

    I am using openSUSE 10.3. I wanted to try the new KDE 4.1 so I used the
    repositories. However, all I got was KDE 4.0 preview. Is KDE 4.1 not
    supported by openSUSE 10.3 or am I going wrong somewhere?

    Thank you

  2. #2
    Join Date
    Jun 2008
    Location
    Copenhagen, Denmark
    Posts
    43

    Default Re: kde 4.1

    No KDE4.1.x is definitely not _supported_ on 10.3 - neither is it on 11.0.

    But it is _available_ via semi-official unsupported Build service repositories for use at your own risk.

    Add these repos:
    Code:
    http://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_10.3/
    Code:
    http://download.opensuse.org/repositories/KDE:/Qt/openSUSE_10.3/
    Note that these packages are being actively developed for 11.1.

  3. #3

    Default Re: kde 4.1

    cb400f wrote:

    >
    > No KDE4.1.x is definitely not _supported_ on 10.3 - neither is it on
    > 11.0.
    >
    > But it is _available_ via semi-official unsupported Build service
    > repositories for use at your own risk.
    >
    > Add these repos:
    >
    > Code:
    > --------------------
    >

    http://download.opensuse.org/reposit...openSUSE_10.3/
    > --------------------


    > Code:
    > --------------------
    > http://download.opensuse.org/reposit...openSUSE_10.3/
    > --------------------
    >
    >
    > Note that these packages are being actively developed for 11.1.
    >
    >

    Thank you

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: kde 4.1

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: kde 4.1

    caf4926 wrote:

    >
    > You may need this also
    > 'Index of /repositories/KDE:/Qt/openSUSE_10.3'
    > (http://download.opensuse.org/reposit...openSUSE_10.3/)
    >
    >

    I get a dependency problem with kde4-filesystem with a warning to change the
    architecture.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: kde 4.1

    In the error box
    click expert
    save the error to a .txt file
    then paste contents here
    it may help us see the problem
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: kde 4.1

    caf4926 wrote:

    >
    > In the error box
    > click expert
    > save the error to a .txt file
    > then paste contents here
    > it may help us see the problem
    >
    >

    #### YaST2 conflicts list - generated 2008-10-03 21:46:44 ####

    Can't satisfy requirement libkdefx.so.5()(64bit) for
    libkonq4-3.93.0.svn712052-11.x86_64

    === libkonq4-3.93.0.svn712052-11.x86_64 ===
    libkonq4-3.93.0.svn712052-11.x86_64 is needed by
    kdebase4-4.1.2-35.3.x86_64[openSUSE_10.3] (libkonq.so.5()(64bit))
    libkde4-3.93.0.svn712047-6.2.x86_64 provides libkdefx.so.5()(64bit),
    but is scheduled to be uninstalled.
    libkde4-3.93.0.svn712047-5.x86_64[openSUSE-10.3-DVD 10.3] provides
    libkdefx.so.5()(64bit), but another version of that package is already
    installed.
    libkonq4-3.93.0.svn712052-11.x86_64 depends on libkde4
    libkonq4-3.93.0.svn712052-11.x86_64 is lacking the requirement
    libkdefx.so.5()(64bit)
    libkonq4-3.93.0.svn712052-11.x86_64 replaced by
    libkonq5-4.1.2-35.3.x86_64[openSUSE_10.3]
    (null)
    Conflict Resolution:
    ( ) delete libkonq4
    ( ) Ignore this requirement just here
    ( ) Generally ignore this requirement
    kdelibs4-core cannot be installed due to missing dependencies
    There are no installable providers of kde4-filesystem >= 4.1.2 for
    kdelibs4-core-4.1.2-44.2.x86_64[openSUSE_10.3]
    === kdelibs4-core-4.1.2-44.2.x86_64[openSUSE_10.3] ===
    kdelibs4-core-4.1.2-44.2.x86_64[openSUSE_10.3] is needed by
    kdelibs4-4.1.2-44.2.x86_64[openSUSE_10.3] (kdelibs4-core == 4.1.2)
    kde4-filesystem-4.1.2-20.1.i586[openSUSE_10.3] provides
    kde4-filesystem == 4.1.2-20.1, but has another architecture.
    (null)
    Conflict Resolution:
    ( ) Install kde4-filesystem although it would change the
    architecture
    ( ) do not install kdelibs4-core
    ( ) Ignore this requirement just here
    No valid solution found with just resolvables of best architecture.
    With this run only resolvables with the best architecture have been
    regarded.
    Regarding all possible resolvables takes time, but can come to a valid
    result.
    Conflict Resolution:
    ( ) Make a solver run with ALL possibilities.

    #### YaST2 conflicts list END ###


    This was the error report.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: kde 4.1

    Just try this, I seem to recall
    Conflict Resolution:
    ( ) delete libkonq4

    is the solution

    Mark it to delete
    Just cancel the error for now
    And go to Packages at the top of the Yast page and select update all if newer version avail.(That's working from the kde4 desktop repo)

    see if you still get the error

    I have a feeling libkonq4 has been replaced by libkonq5

    If it all turns ugly, just exit and abandon, and reply back here
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Mar 2008
    Location
    Vsters, Sweden ex. Highbury London UK
    Posts
    1,245

    Default Re: kde 4.1

    Ignoring errors is asking for trouble NOT good advice
    Quote Originally Posted by caf4926 View Post
    ....
    Just cancel the error for now
    Core 2 Duo 3.16GHz, 8GB DDR2, 3.5TB, GeForce 9600 GT, Amilo LCD 26", OS 11.1 x86_64, KDE4.2.4 (2)
    My wine tips & tricks

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: kde 4.1

    It's good advice. Sorry geoffro. You missed the point of my comments.

    To cancel a dependency error and move on to try the next step is fine.

    I checked my install and can confirm that libkonq4 has been replaced by libkonq5, even though libkonq4 still appears in the repo (obviously) as it is from the original 4.0.4 kde that shipped with suse 11.
    In fact it was one of the kde build service team that advised ME on this maybe a month ago or so.

    I did say
    If it all turns ugly, just exit and abandon, and reply back here
    Which obviously means don't carry on if the error remains!

    Notice the two points in the error he posted

    Conflict Resolution:
    ( ) delete libkonq4

    Conflict Resolution:
    ( ) Install kde4-filesystem although it would change the
    architecture
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •